summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-02-07 14:36:54 +0000
committerMarkus Meier <maekke@gentoo.org>2009-02-07 14:36:54 +0000
commit419d232cb3d043fb86b05c0afdeb9fe5980c7f2f (patch)
tree947b8d80594ca9f42a24440a856250c922d01323 /media-libs/libexif
parentold (diff)
downloadgentoo-2-419d232cb3d043fb86b05c0afdeb9fe5980c7f2f.tar.gz
gentoo-2-419d232cb3d043fb86b05c0afdeb9fe5980c7f2f.tar.bz2
gentoo-2-419d232cb3d043fb86b05c0afdeb9fe5980c7f2f.zip
old
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'media-libs/libexif')
-rw-r--r--media-libs/libexif/ChangeLog6
-rw-r--r--media-libs/libexif/libexif-0.6.16-r1.ebuild72
-rw-r--r--media-libs/libexif/libexif-0.6.16.ebuild70
3 files changed, 5 insertions, 143 deletions
diff --git a/media-libs/libexif/ChangeLog b/media-libs/libexif/ChangeLog
index c2dbb688d46a..2033f7be6bc9 100644
--- a/media-libs/libexif/ChangeLog
+++ b/media-libs/libexif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libexif
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.104 2009/02/06 20:10:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.105 2009/02/07 14:36:54 maekke Exp $
+
+ 07 Feb 2009; Markus Meier <maekke@gentoo.org> -libexif-0.6.16.ebuild,
+ -libexif-0.6.16-r1.ebuild:
+ old
06 Feb 2009; Jeroen Roovers <jer@gentoo.org> libexif-0.6.17.ebuild:
Stable for HPPA (bug #256173).
diff --git a/media-libs/libexif/libexif-0.6.16-r1.ebuild b/media-libs/libexif/libexif-0.6.16-r1.ebuild
deleted file mode 100644
index 54404cd4b3d8..000000000000
--- a/media-libs/libexif/libexif-0.6.16-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.16-r1.ebuild,v 1.8 2008/06/14 18:18:51 zmedico Exp $
-
-inherit eutils libtool
-
-DESCRIPTION="Library for parsing, editing, and saving EXIF data"
-HOMEPAGE="http://libexif.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc nls"
-
-DEPEND="dev-util/pkgconfig
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )"
-
-RDEPEND="nls? ( virtual/libintl )"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.6.13-pkgconfig.patch"
- epatch "${FILESDIR}/${PN}-CVE-2007-6351.patch"
- epatch "${FILESDIR}/${PN}-CVE-2007-6352.patch"
-
- # We do this for sane .so versioning on FreeBSD
- elibtoolize
-}
-
-src_compile() {
- local my_conf="--with-doc-dir=/usr/share/doc/${PF}"
- use nls || my_conf="${my_conf} --without-libintl-prefix"
- econf $(use_enable nls) $(use_enable doc docs) \
- --with-pic --disable-rpath ${my_conf} || die
- emake || die
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- dodir /usr/include/libexif
- use nls && dodir /usr/share/locale
- use doc && dodir /usr/share/doc/${PF}
- dodir /usr/$(get_libdir)/pkgconfig
-
- make DESTDIR="${D}" install || die
-
- dodoc ChangeLog README
-
- # installs a blank directory for whatever broken reason
- use nls || rm -rf "${D}usr/share/locale"
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.6.13-r2"
- previous_less_than_0_6_13_r2=$?
-}
-
-pkg_postinst() {
- if [[ $previous_less_than_0_6_13_r2 = 0 ]] ; then
- elog "If you are upgrading from a version of libexif older than 0.6.13-r2,"
- elog "you will need to do the following to rebuild dependencies:"
- elog "# revdep-rebuild --soname libexif.so.9"
- elog "# revdep-rebuild --soname libexif.so.10"
- elog ""
- elog "Note, it is actually safe to create a symlink from libexif.so.10 to"
- elog "libexif.so.12 if you need to during the update."
- fi
-}
diff --git a/media-libs/libexif/libexif-0.6.16.ebuild b/media-libs/libexif/libexif-0.6.16.ebuild
deleted file mode 100644
index 5e56cabff539..000000000000
--- a/media-libs/libexif/libexif-0.6.16.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.16.ebuild,v 1.13 2008/06/14 18:18:51 zmedico Exp $
-
-inherit eutils libtool
-
-DESCRIPTION="Library for parsing, editing, and saving EXIF data"
-HOMEPAGE="http://libexif.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc nls"
-
-DEPEND="dev-util/pkgconfig
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )"
-
-RDEPEND="nls? ( virtual/libintl )"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.6.13-pkgconfig.patch"
-
- # We do this for sane .so versioning on FreeBSD
- elibtoolize
-}
-
-src_compile() {
- local my_conf="--with-doc-dir=/usr/share/doc/${PF}"
- use nls || my_conf="${my_conf} --without-libintl-prefix"
- econf $(use_enable nls) $(use_enable doc docs) \
- --with-pic --disable-rpath ${my_conf} || die
- emake || die
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- dodir /usr/include/libexif
- use nls && dodir /usr/share/locale
- use doc && dodir /usr/share/doc/${PF}
- dodir /usr/$(get_libdir)/pkgconfig
-
- make DESTDIR="${D}" install || die
-
- dodoc ChangeLog README
-
- # installs a blank directory for whatever broken reason
- use nls || rm -rf "${D}usr/share/locale"
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.6.13-r2"
- previous_less_than_0_6_13_r2=$?
-}
-
-pkg_postinst() {
- if [[ $previous_less_than_0_6_13_r2 = 0 ]] ; then
- elog "If you are upgrading from a version of libexif older than 0.6.13-r2,"
- elog "you will need to do the following to rebuild dependencies:"
- elog "# revdep-rebuild --soname libexif.so.9"
- elog "# revdep-rebuild --soname libexif.so.10"
- elog ""
- elog "Note, it is actually safe to create a symlink from libexif.so.10 to"
- elog "libexif.so.12 if you need to during the update."
- fi
-}