summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-07 09:41:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-07 09:41:22 +0000
commit6b6b1218b4a78e864feaf1c4e8321145b9953958 (patch)
tree9b6e0363acbdf2b0b41d404c7561d7c949e7d593 /media-libs/libdecodeqr/files
parentAdd as-is and X11 to LICENSE for oldXMenu und etc/rgb.txt, respectively. (diff)
downloadgentoo-2-6b6b1218b4a78e864feaf1c4e8321145b9953958.tar.gz
gentoo-2-6b6b1218b4a78e864feaf1c4e8321145b9953958.tar.bz2
gentoo-2-6b6b1218b4a78e864feaf1c4e8321145b9953958.zip
Initial commit.
(Portage version: 2.2_rc13/cvs/Linux 2.6.28-rc3-00054-g75fa677 x86_64)
Diffstat (limited to 'media-libs/libdecodeqr/files')
-rw-r--r--media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch b/media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch
new file mode 100644
index 000000000000..a2fc53c3ff44
--- /dev/null
+++ b/media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch
@@ -0,0 +1,31 @@
+diff -Nuar libdecodeqr-0.9.3.orig/src/libdecodeqr/Makefile.in libdecodeqr-0.9.3/src/libdecodeqr/Makefile.in
+--- libdecodeqr-0.9.3.orig/src/libdecodeqr/Makefile.in 2008-11-07 01:26:19.463859379 -0800
++++ libdecodeqr-0.9.3/src/libdecodeqr/Makefile.in 2008-11-07 01:27:55.190972807 -0800
+@@ -31,7 +31,7 @@
+ ARFLAGS=rcs
+
+ LD=@LD@
+-LDFLAGS=@LDFLAGS@ -shared -soname $(SONAME)
++LDFLAGS=@LDFLAGS@
+ LIBCV=@LIBCV@
+ LIBS=$(LIBCV)
+
+@@ -53,13 +53,13 @@
+ $(AR) $(ARFLAGS) $@ $(objs)
+
+ $(LIBNAME_SO): $(objs)
+- $(LD) -o $@ $(objs) $(LDFLAGS) $(LIBS)
++ $(LD) $(LDFLAGS) -o $@ $(objs) -shared -soname $(SONAME) $(LIBS)
+
+ install: $(dsts)
+- $(INSTALL) -m 0755 $(LIBNAME_A) $(LIBNAME_SO) $(libdir)
+- $(LDCONFIG) -n $(libdir)
+- $(LN) -sf $(libdir)/$(LIBNAME_SO) $(libdir)/$(BASENAME).so
+- $(INSTALL) -m 0644 decodeqr.h qrerror.h qrtypes.h $(includedir)
++ $(INSTALL) -m 0755 $(LIBNAME_A) $(LIBNAME_SO) $(DESTDIR)$(libdir)
++ #$(LDCONFIG) -n $(libdir)
++ $(LN) -sf $(libdir)/$(LIBNAME_SO) $(DESTDIR)$(libdir)/$(BASENAME).so
++ $(INSTALL) -m 0644 decodeqr.h qrerror.h qrtypes.h $(DESTDIR)$(includedir)
+
+ clean:
+ -rm *.a *.o *.so.*