summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-03-14 20:39:18 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-03-14 20:39:18 +0000
commit3367c75c3743a11ecc674c029601b05c4089ba7a (patch)
treefaae64f75782440896edb9267b341e2d38ca8f9a /media-libs/hamlib
parentVersion bump. Remove older. (diff)
downloadgentoo-2-3367c75c3743a11ecc674c029601b05c4089ba7a.tar.gz
gentoo-2-3367c75c3743a11ecc674c029601b05c4089ba7a.tar.bz2
gentoo-2-3367c75c3743a11ecc674c029601b05c4089ba7a.zip
Add fixes for python/tcl bindings and python.eclass fixes by Thomas Beierlein
(Portage version: 2.1.8/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog9
-rw-r--r--media-libs/hamlib/files/hamlib-bindings.diff73
-rw-r--r--media-libs/hamlib/hamlib-1.2.10.ebuild20
3 files changed, 88 insertions, 14 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index 2c189657340a..30643345bbaa 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/hamlib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.40 2009/12/11 02:40:33 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.41 2010/03/14 20:39:17 darkside Exp $
+
+ 14 Mar 2010; Jeremy Olexa <darkside@gentoo.org> hamlib-1.2.10.ebuild,
+ +files/hamlib-bindings.diff:
+ Add fixes for python/tcl bindings and python.eclass fixes by Thomas
+ Beierlein
*hamlib-1.2.10 (11 Dec 2009)
diff --git a/media-libs/hamlib/files/hamlib-bindings.diff b/media-libs/hamlib/files/hamlib-bindings.diff
new file mode 100644
index 000000000000..ecb9715b1e5e
--- /dev/null
+++ b/media-libs/hamlib/files/hamlib-bindings.diff
@@ -0,0 +1,73 @@
+# drop longrunning and unneeded search for python library
+--- macros/python.m4.orig 2010-03-12 07:11:49.000000000 +0100
++++ macros/python.m4 2010-03-12 07:12:21.000000000 +0100
+@@ -56,21 +56,6 @@
+
+ if test "$cf_with_python_devel" != "no" ; then
+
+- # Check for Python library path
+- AC_MSG_CHECKING([for Python library path])
+- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- break
+- fi
+- done
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
+- AC_MSG_RESULT([$python_path])
+- if test -z "$python_path" ; then
+- AC_MSG_WARN([cannot find Python library path])
+- fi
+- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -lpython$PYTHON_VERSION"])
+ #
+ python_site=`echo $python_path | sed "s/config/site-packages/"`
+ AC_SUBST([PYTHON_SITE_PKG],[$python_site])
+Index: bindings/Makefile.am
+# fix tcl and python install path
+===================================================================
+--- bindings/Makefile.am (revision 2854)
++++ bindings/Makefile.am (working copy)
+@@ -69,7 +69,7 @@
+
+ tcl_ltlib = hamlibtcl.la
+
+-tcldir = $(prefix)/lib/tcl
++tcldir = @tclpackagedir@/hamlib
+
+ PKG_VER=1.0
+ DLL=hamlibtcl-$(PKG_VER)@TCL_SHLIB_SUFFIX@
+@@ -105,7 +105,7 @@
+
+ python_ltlib = _Hamlib.la
+
+-pythondir = $(prefix)/lib/python
++pythondir = @pythondir@
+
+ nodist__Hamlib_la_SOURCES = hamlibpy_wrap.c
+ _Hamlib_la_LDFLAGS = -no-undefined -module -avoid-version
+@@ -131,8 +131,8 @@
+ uninstall-py:
+
+ ##########################################
+-
+-lib_LTLIBRARIES = $(tcl_ltlib) $(python_ltlib)
++_Hamlib_la_LTLIBRARIES = $(python_ltlib)
++lib_LTLIBRARIES = $(tcl_ltlib)
+ # lib_LTLIBRARIES = @BINDING_LIB_TARGETS@
+
+ all-local: @BINDING_ALL@
+Index: configure.ac
+# add macro to determine path to tcl packages
+===================================================================
+--- configure.ac (revision 2854)
++++ configure.ac (working copy)
+@@ -330,6 +330,8 @@
+ AC_SUBST(TCL_LIB_SPEC)
+ AC_SUBST(TCL_INCLUDE_SPEC)
+ AC_SUBST(TCL_SHLIB_SUFFIX)
++tclpackagedir=`echo $TCL_PACKAGE_PATH | cut -d ' ' -f 1 | sed "s,$TCL_PREFIX,\\${prefix},"`
++AC_SUBST(tclpackagedir)
+
+ # TODO: require "${ac_cv_header_sys_socket_h}" = "no"
+
diff --git a/media-libs/hamlib/hamlib-1.2.10.ebuild b/media-libs/hamlib/hamlib-1.2.10.ebuild
index afb9a519dea0..0505267f8c36 100644
--- a/media-libs/hamlib/hamlib-1.2.10.ebuild
+++ b/media-libs/hamlib/hamlib-1.2.10.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.10.ebuild,v 1.1 2009/12/11 02:40:33 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.10.ebuild,v 1.2 2010/03/14 20:39:17 darkside Exp $
+PYTHON_DEPEND="2"
inherit autotools eutils multilib python
DESCRIPTION="Ham radio backend rig control libraries"
@@ -36,15 +37,10 @@ src_unpack() {
sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
-e "s#fix}/include#fix}/include/hamlib#" \
hamlib.pc.in || die "sed failed"
- sed -i -e "s#/lib/#/$(get_libdir)/#g" \
- bindings/Makefile.am || die "sed failed"
-
- if use python ; then
- # fix python lib path
- python_version
- sed -i -e "s#/python#/python${PYVER}#" \
- bindings/Makefile.am || die "sed failed"
- fi
+
+ # fix python and tcl lib path and
+ # drop unneeded search for python library
+ epatch "${FILESDIR}"/${PN}-bindings.diff
# avoid compilation and use of bundled libltdl copy
sed -i -e "s/lib libltdl src/lib src/g" \
@@ -60,7 +56,7 @@ src_compile() {
--with-rpc-backends \
--without-perl-binding \
$(use_with python python-binding) \
- $(use_enable tcl tcl-binding)
+ $(use_enable tcl tcl-binding)
emake || die "emake failed"