summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-07-30 11:55:46 +0000
committerMart Raudsepp <leio@gentoo.org>2010-07-30 11:55:46 +0000
commitb6bb65b3c85c37afb412c834067adc9339e9ae14 (patch)
treeb769c2a9f0db4441d352fd2b51777302063bb1de /media-libs/gst-plugins-good
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-b6bb65b3c85c37afb412c834067adc9339e9ae14.tar.gz
gentoo-2-b6bb65b3c85c37afb412c834067adc9339e9ae14.tar.bz2
gentoo-2-b6bb65b3c85c37afb412c834067adc9339e9ae14.zip
Version bump. Noteworthy changes in "Stylish Kids in Riot" release: WebM demuxing supported in matroskademux. VP8 support in matroska muxer/demuxer, avimux and qtdemux. Dedicated webmmux element for WebM muxing (restricted matroska). Automatic interlacing detection now default in deinterlace element. Push mode seeking support in matroskademux and qtdemux. More color format support in alpha, deinterlace, gamma, smptealpha, videobalance, videobox, videoflip, videomixer and y4menc elements (to avoid unnecessary slow color format conversions). Huge amount of RTP and RTSP improvements, as usual. New imagefreeze plugin - still frame stream generator. capssetter element moved from -bad to here (in debugutils).
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog19
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.23.ebuild65
2 files changed, 83 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index c0a8e7324f49..d6c5d9bc16be 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,23 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.95 2010/07/27 17:36:08 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.96 2010/07/30 11:55:46 leio Exp $
+
+*gst-plugins-good-0.10.23 (30 Jul 2010)
+
+ 30 Jul 2010; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-good-0.10.23.ebuild:
+ Version bump. Noteworthy changes in "Stylish Kids in Riot" release:
+ WebM demuxing support in matroskademux.
+ VP8 support in matroska muxer/demuxer, avimux and qtdemux.
+ Dedicated webmmux element for WebM muxing (restricted matroska).
+ Automatic interlacing detection now default in deinterlace element.
+ Push mode seeking support in matroskademux and qtdemux.
+ More color format support in alpha, deinterlace, gamma, smptealpha,
+ videobalance, videobox, videoflip, videomixer and y4menc elements
+ (to avoid unnecessary slow color format conversions).
+ Huge amount of RTP and RTSP improvements, as usual.
+ New imagefreeze plugin - still frame stream generator.
+ capssetter element moved from -bad to here (in debugutils).
27 Jul 2010; Pacho Ramos <pacho@gentoo.org>
gst-plugins-good-0.10.22.ebuild:
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.23.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.23.ebuild
new file mode 100644
index 000000000000..fe7c6206e62b
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.23.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.23.ebuild,v 1.1 2010/07/30 11:55:46 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.29
+ >=media-libs/gstreamer-0.10.29
+ >=dev-libs/liboil-0.3.14
+ sys-libs/zlib
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.18"
+
+# Always enable optional bz2 support for matroska
+# Always enable optional zlib support for qtdemux, id3demux and matroska
+# Many media files require these to work, as some container headers are often compressed, bug 291154
+GST_PLUGINS_BUILD="bz2 zlib"
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-good_src_configure \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ echo
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}