summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-04 16:54:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-04 16:54:22 +0000
commita01ac24470c1a02e392dbf81dc2b227595d1aeec (patch)
treea52b0b6903191b1da0cea808f204714cb82e105b /media-libs/fmod/fmod-3.61.ebuild
parentAdded banner (diff)
downloadgentoo-2-a01ac24470c1a02e392dbf81dc2b227595d1aeec.tar.gz
gentoo-2-a01ac24470c1a02e392dbf81dc2b227595d1aeec.tar.bz2
gentoo-2-a01ac24470c1a02e392dbf81dc2b227595d1aeec.zip
initial ebuild #13537
Diffstat (limited to 'media-libs/fmod/fmod-3.61.ebuild')
-rw-r--r--media-libs/fmod/fmod-3.61.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/fmod/fmod-3.61.ebuild b/media-libs/fmod/fmod-3.61.ebuild
new file mode 100644
index 000000000000..3e9f07c6247f
--- /dev/null
+++ b/media-libs/fmod/fmod-3.61.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fmod/fmod-3.61.ebuild,v 1.1 2003/03/04 16:54:22 vapier Exp $
+
+MY_P="fmodapi${PV/.}linux"
+DESCRIPTION="music and sound effects library, and a sound processing system"
+SRC_URI="http://www.fmod.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.fmod.org/"
+
+SLOT="0"
+LICENSE="fmod"
+KEYWORDS="x86 -ppc sparc -mips -alpha -arm -hppa"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dolib api/libfmod-${PV}.so
+ dosym /usr/lib/libfmod-${PV}.so /usr/lib/libfmod.so
+
+ insinto /usr/include
+ doins api/inc/*
+
+ insinto /usr/share/${PN}/media
+ doins media/*
+ cp -r samples ${D}/usr/share/${PN}/
+
+ dohtml -r documentation/*
+ dodoc README.TXT documentation/Revision.txt
+}