summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-16 19:41:10 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-16 19:41:10 +0000
commit73b79a60357ae28519f758a1d3a835005bb2af34 (patch)
treecb3ff6bf9ccc8197df85ac43d412a017d3789707 /media-libs/avidemux-core
parentinitial import (diff)
downloadgentoo-2-73b79a60357ae28519f758a1d3a835005bb2af34.tar.gz
gentoo-2-73b79a60357ae28519f758a1d3a835005bb2af34.tar.bz2
gentoo-2-73b79a60357ae28519f758a1d3a835005bb2af34.zip
Made 9999 ebuild that uses upstream's git, applied various cmake related ebuild fixes to simplify maintenance; thanks to Nikoli for the suggestion.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-libs/avidemux-core')
-rw-r--r--media-libs/avidemux-core/ChangeLog8
-rw-r--r--media-libs/avidemux-core/avidemux-core-9999.ebuild104
2 files changed, 111 insertions, 1 deletions
diff --git a/media-libs/avidemux-core/ChangeLog b/media-libs/avidemux-core/ChangeLog
index ad8973091bea..87400ede2011 100644
--- a/media-libs/avidemux-core/ChangeLog
+++ b/media-libs/avidemux-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/avidemux-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.9 2013/07/12 22:58:35 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.10 2013/07/16 19:41:10 tomwij Exp $
+
+*avidemux-core-9999 (16 Jul 2013)
+
+ 16 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +avidemux-core-9999.ebuild:
+ Made 9999 ebuild that uses upstream's git, applied various cmake related
+ ebuild fixes to simplify maintenance; thanks to Nikoli for the suggestion.
12 Jul 2013; Tom Wijsman <TomWij@gentoo.org> avidemux-core-2.6.4.ebuild:
Cleaned up ebuild to make it shorter, use the eclass more and lowercase
diff --git a/media-libs/avidemux-core/avidemux-core-9999.ebuild b/media-libs/avidemux-core/avidemux-core-9999.ebuild
new file mode 100644
index 000000000000..9804264154fc
--- /dev/null
+++ b/media-libs/avidemux-core/avidemux-core-9999.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/avidemux-core-9999.ebuild,v 1.1 2013/07/16 19:41:10 tomwij Exp $
+
+EAPI="5"
+
+inherit cmake-utils eutils flag-o-matic
+
+SLOT="2.6"
+
+DESCRIPTION="Core libraries for a video editor designed for simple cutting, filtering and encoding tasks."
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+IUSE="debug nls sdl system-ffmpeg vdpau xv"
+KEYWORDS="~amd64 ~x86"
+
+MY_PN="${PN/-core/}"
+if [[ ${PV} == *9999* ]] ; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git https://git.gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git"
+
+ inherit git-2
+else
+ MY_P="${MY_PN}_${PV}"
+ SRC_URI="mirror://sourceforge/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
+DEPEND="
+ !<media-video/avidemux-${PV}
+ dev-db/sqlite:3
+ nls? ( sys-devel/gettext:0 )
+ sdl? ( media-libs/libsdl:0 )
+ system-ffmpeg? ( >=virtual/ffmpeg-9[mp3,theora] )
+ xv? ( x11-libs/libXv:0 )
+ vdpau? ( x11-libs/libvdpau:0 )
+"
+RDEPEND="
+ $DEPEND
+"
+DEPEND="
+ $DEPEND
+ virtual/pkgconfig:0
+ !system-ffmpeg? ( dev-lang/yasm:0[nls=] )
+"
+
+S="${WORKDIR}/${MY_P}"
+BUILD_DIR="${S}/buildCore"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ mkdir "${BUILD_DIR}" || die "Can't create build folder."
+
+ cmake-utils_src_prepare
+
+ if use system-ffmpeg ; then
+ # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
+ local error="Failed to remove ffmpeg."
+
+ rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
+ sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
+ else
+ # Avoid existing avidemux installations from making the build process fail, bug #461496.
+ sed -i -e "s:getFfmpegLibNames(\"\${sourceDir}\"):getFfmpegLibNames(\"${S}/buildCore/ffmpeg/source/\"):g" cmake/admFFmpegUtil.cmake \
+ || die "Failed to avoid existing avidemux installation from making the build fail."
+ fi
+
+ # Add lax vector typing for PowerPC.
+ if use ppc || use ppc64 ; then
+ append-cflags -flax-vector-conversions
+ fi
+
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DAVIDEMUX_SOURCE_DIR='${S}'
+ $(cmake-utils_use nls GETTEXT)
+ $(cmake-utils_use sdl SDL)
+ $(cmake-utils_use vdpau VDPAU)
+ $(cmake-utils_use xv XVIDEO)
+ "
+
+ if use debug ; then
+ mycmakeargs+=" -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1"
+ fi
+
+ CMAKE_USE_DIR="${S}"/avidemux_core cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile -j1
+}
+
+src_install() {
+ cmake-utils_src_install -j1
+}