summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-02-29 07:23:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-02-29 07:23:42 +0000
commit50ba915bcb39178592bb7c55c2c4691cd2855666 (patch)
tree935fc240a38455b11879b3b306f3e73191bccf33 /media-libs/atlas-c++
parentStable on x86 wrt #211360 (diff)
downloadgentoo-2-50ba915bcb39178592bb7c55c2c4691cd2855666.tar.gz
gentoo-2-50ba915bcb39178592bb7c55c2c4691cd2855666.tar.bz2
gentoo-2-50ba915bcb39178592bb7c55c2c4691cd2855666.zip
Making test compile. Bug #211773
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs/atlas-c++')
-rw-r--r--media-libs/atlas-c++/ChangeLog8
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.4.5.ebuild6
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.5.92.ebuild6
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1.ebuild11
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch16
5 files changed, 38 insertions, 9 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 72995276571f..c8539f21e894 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/atlas-c++
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.22 2008/02/28 15:41:38 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.23 2008/02/29 07:23:41 tupone Exp $
+
+ 29 Feb 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/atlas-c++-0.6.1-strict-aliasing.patch, atlas-c++-0.4.5.ebuild,
+ atlas-c++-0.5.92.ebuild, atlas-c++-0.6.1.ebuild:
+ Making test compile. Bug #211773 by Raúl Porcel.
+ Fixing DESCRIPTION on old ebuild to clean repoman warnings
28 Feb 2008; Ferris McCormick <fmccor@gentoo.org> atlas-c++-0.6.1.ebuild:
Restore ~sparc keyword --- Bug #211773 --- note that one test won't build,
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
index 656ebbdd9fe9..1ba75d5dbfe1 100644
--- a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.12 2007/11/25 10:19:45 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.13 2008/02/29 07:23:41 tupone Exp $
MY_PN="Atlas-C++"
MY_P=${MY_PN}-${PV}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+DESCRIPTION="Atlas protocol, used in role playing games at worldforge."
HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
SRC_URI="ftp://ftp.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
diff --git a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
index 43b4e4327592..cc8bf556f5d3 100644
--- a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.4 2007/11/25 10:19:45 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.5 2008/02/29 07:23:41 tupone Exp $
inherit eutils
MY_PN="Atlas-C++"
MY_P=${MY_PN}-${PV}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+DESCRIPTION="Atlas protocol, used in role playing games at worldforge."
HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
index 5daf0aad6e19..3883883d1376 100644
--- a/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild,v 1.2 2008/02/28 15:41:38 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild,v 1.3 2008/02/29 07:23:41 tupone Exp $
-inherit eutils
+inherit eutils autotools
MY_PN="Atlas-C++"
MY_P=${MY_PN}-${PV}
@@ -21,6 +21,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-strict-aliasing.patch
+ eautoreconf
+}
+
src_compile() {
econf \
$(use_enable zlib) \
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch
new file mode 100644
index 000000000000..edf1ac197755
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-strict-aliasing.patch
@@ -0,0 +1,16 @@
+--- tests/Objects/Makefile.am.old 2008-02-29 07:43:45.000000000 +0100
++++ tests/Objects/Makefile.am 2008-02-29 07:44:21.000000000 +0100
+@@ -28,3 +28,5 @@
+ attributes_SOURCES = attributes.cpp
+
+ flags_SOURCES = flags.cpp
++
++AM_CPPFLAGS = -fno-strict-aliasing
+--- benchmark/Makefile.am.old 2008-02-29 07:57:10.000000000 +0100
++++ benchmark/Makefile.am 2008-02-29 07:57:33.000000000 +0100
+@@ -31,3 +31,5 @@
+
+ Objects_asMessage_SOURCES = Objects_asMessage.cpp timer.h
+ Objects_iterator_SOURCES = Objects_iterator.cpp timer.h
++
++AM_CPPFLAGS = -fno-strict-aliasing