summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-12-03 13:36:36 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-12-03 13:36:36 +0000
commite5410013e1e1b1ec04bf16fa3fc0cadd733cde70 (patch)
tree1a49ce58cb1cdf150953075fa408015ba0e5d08a /media-gfx
parentAdded CVS Header after a request from grobian. (diff)
downloadgentoo-2-e5410013e1e1b1ec04bf16fa3fc0cadd733cde70.tar.gz
gentoo-2-e5410013e1e1b1ec04bf16fa3fc0cadd733cde70.tar.bz2
gentoo-2-e5410013e1e1b1ec04bf16fa3fc0cadd733cde70.zip
Add patch by Phillip Berndt <phillip.berndt at googlemail dot com> for bug 79694. This works around the Gdk-ERROR - BadMatch issues when using the composite extension.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qiv/ChangeLog10
-rw-r--r--media-gfx/qiv/files/digest-qiv-2.0-r13
-rw-r--r--media-gfx/qiv/files/qiv-2.0-composite.patch12
-rw-r--r--media-gfx/qiv/qiv-2.0-r1.ebuild42
4 files changed, 66 insertions, 1 deletions
diff --git a/media-gfx/qiv/ChangeLog b/media-gfx/qiv/ChangeLog
index d5c54dc841e8..d4ff27ebf388 100644
--- a/media-gfx/qiv/ChangeLog
+++ b/media-gfx/qiv/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/qiv
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/qiv/ChangeLog,v 1.24 2006/10/20 21:30:52 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/qiv/ChangeLog,v 1.25 2006/12/03 13:36:36 vanquirius Exp $
+
+*qiv-2.0-r1 (03 Dec 2006)
+
+ 03 Dec 2006; Marcelo Goes <vanquirius@gentoo.org>
+ +files/qiv-2.0-composite.patch, +qiv-2.0-r1.ebuild:
+ Add patch by Phillip Berndt <phillip.berndt at googlemail dot com> for bug
+ 79694. This works around the Gdk-ERROR - BadMatch issues when using the
+ composite extension.
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> qiv-2.0.ebuild:
Stable on Alpha.
diff --git a/media-gfx/qiv/files/digest-qiv-2.0-r1 b/media-gfx/qiv/files/digest-qiv-2.0-r1
new file mode 100644
index 000000000000..58a67da927f1
--- /dev/null
+++ b/media-gfx/qiv/files/digest-qiv-2.0-r1
@@ -0,0 +1,3 @@
+MD5 165d0c2f264718821f94732196b7f9e1 qiv-2.0-src.tgz 76561
+RMD160 82b17c20468228258f7c1e7c61588c80e1c40107 qiv-2.0-src.tgz 76561
+SHA256 2f0c03ee7e79c9210f060c87d51811e4540f126d8c3d751b31aab69160b3d091 qiv-2.0-src.tgz 76561
diff --git a/media-gfx/qiv/files/qiv-2.0-composite.patch b/media-gfx/qiv/files/qiv-2.0-composite.patch
new file mode 100644
index 000000000000..34a05c228d8c
--- /dev/null
+++ b/media-gfx/qiv/files/qiv-2.0-composite.patch
@@ -0,0 +1,12 @@
+diff -Nru qiv-2.0/main.c qiv-2.0/main.c
+--- qiv-2.0/main.c 2006-10-18 16:35:42.184652947 +0200
++++ qiv-2.0/main.c 2006-10-18 16:36:48.260782447 +0200
+@@ -41,6 +41,7 @@
+
+ /* Initialize GDK and Imlib */
+
++ putenv("XLIB_SKIP_ARGB_VISUALS=1");
+ gdk_init(&argc,&argv);
+ gdk_imlib_init();
+
+Files qiv-2.0.old/qiv and qiv-2.0/qiv differ
diff --git a/media-gfx/qiv/qiv-2.0-r1.ebuild b/media-gfx/qiv/qiv-2.0-r1.ebuild
new file mode 100644
index 000000000000..7fe4a72b9e4d
--- /dev/null
+++ b/media-gfx/qiv/qiv-2.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/qiv/qiv-2.0-r1.ebuild,v 1.1 2006/12/03 13:36:36 vanquirius Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${P%%_*}"
+DESCRIPTION="Quick Image Viewer"
+SRC_URI="http://www.kdown1.de/files/${MY_P}-src.tgz"
+HOMEPAGE="http://www.klografx.net/qiv/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+DEPEND="media-libs/libpng
+ >=media-libs/tiff-3.5.5
+ >=media-libs/imlib-1.9.10
+ || (
+ ( >=x11-libs/libX11-1.0.0
+ >=x11-proto/xineramaproto-1.1.2 )
+ virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-composite.patch
+}
+
+src_compile() {
+ use xinerama && sed -i "s:# GTD_XINERAMA = -DGTD_XINERAMA:GTD_XINERAMA = -DGTD_XINERAMA:" Makefile
+ emake || die
+}
+
+src_install () {
+ into /usr
+ dobin qiv
+ doman qiv.1
+ dodoc README{,.TODO,.CHANGES}
+}