summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-08 16:37:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-08 16:37:28 +0000
commite1140eced07aee4f0615b3ff8be7eee12fd438f6 (patch)
tree362e11e089f681cc0a67c947b217256109ad0616 /media-gfx
parentVersion bump, drop old (diff)
downloadgentoo-2-e1140eced07aee4f0615b3ff8be7eee12fd438f6.tar.gz
gentoo-2-e1140eced07aee4f0615b3ff8be7eee12fd438f6.tar.bz2
gentoo-2-e1140eced07aee4f0615b3ff8be7eee12fd438f6.zip
Fix missing zlib.h include with libpng >= 1.5 present wrt #378183 by by Diego Elio Pettenò
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pngnq/ChangeLog9
-rw-r--r--media-gfx/pngnq/files/pngnq-1.0-libpng15.patch13
-rw-r--r--media-gfx/pngnq/pngnq-1.0.ebuild22
3 files changed, 31 insertions, 13 deletions
diff --git a/media-gfx/pngnq/ChangeLog b/media-gfx/pngnq/ChangeLog
index 045fb82b6389..58105cc55cc5 100644
--- a/media-gfx/pngnq/ChangeLog
+++ b/media-gfx/pngnq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pngnq
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngnq/ChangeLog,v 1.9 2010/05/21 16:15:19 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngnq/ChangeLog,v 1.10 2011/08/08 16:37:28 ssuominen Exp $
+
+ 08 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> pngnq-1.0.ebuild,
+ +files/pngnq-1.0-libpng15.patch:
+ Fix missing zlib.h include with libpng >= 1.5 present wrt #378183 by by Diego
+ Elio Pettenò
21 May 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> pngnq-1.0.ebuild:
x86 stable wrt bug #319535
diff --git a/media-gfx/pngnq/files/pngnq-1.0-libpng15.patch b/media-gfx/pngnq/files/pngnq-1.0-libpng15.patch
new file mode 100644
index 000000000000..7590431dcd3a
--- /dev/null
+++ b/media-gfx/pngnq/files/pngnq-1.0-libpng15.patch
@@ -0,0 +1,13 @@
+--- src/rwpng.c
++++ src/rwpng.c
+@@ -31,8 +31,9 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <zlib.h>
+
+-#include "png.h" /* libpng header; includes zlib.h */
++#include "png.h" /* libpng header */
+ #include "rwpng.h" /* typedefs, common macros, public prototypes */
+
+ /* future versions of libpng will provide this macro: */
diff --git a/media-gfx/pngnq/pngnq-1.0.ebuild b/media-gfx/pngnq/pngnq-1.0.ebuild
index 03ec9900da7d..5d946d8716b8 100644
--- a/media-gfx/pngnq/pngnq-1.0.ebuild
+++ b/media-gfx/pngnq/pngnq-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngnq/pngnq-1.0.ebuild,v 1.5 2010/05/21 16:15:19 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngnq/pngnq-1.0.ebuild,v 1.6 2011/08/08 16:37:28 ssuominen Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils
DESCRIPTION="Pngnq is a tool for quantizing PNG images in RGBA format."
@@ -14,15 +14,15 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="media-libs/libpng"
+RDEPEND="media-libs/libpng"
+DEPEND="${RDEPEND}"
+
+DOCS=( NEWS README )
src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-libpng14.patch
- eautoreconf
-}
+ epatch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-libpng1{4,5}.patch
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README NEWS || die
+ eautoreconf
}