summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-26 07:42:27 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-26 07:42:27 +0000
commite0c7076e470481a6809b868265ed9e2ba2e0eeed (patch)
treec82986546345c48a8a903393604832d9d5a618ab /media-gfx
parentMask media-gfx/opencolorio[pdf] (diff)
downloadgentoo-2-e0c7076e470481a6809b868265ed9e2ba2e0eeed.tar.gz
gentoo-2-e0c7076e470481a6809b868265ed9e2ba2e0eeed.tar.bz2
gentoo-2-e0c7076e470481a6809b868265ed9e2ba2e0eeed.zip
Remove automagic dependency on pdflatex binary, add USE-flag 'pdf' for building extra pdf documentation, fix patch for documentation building
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/opencolorio/ChangeLog7
-rw-r--r--media-gfx/opencolorio/files/opencolorio-documentation-gen.patch16
-rw-r--r--media-gfx/opencolorio/metadata.xml3
-rw-r--r--media-gfx/opencolorio/opencolorio-1.0.7.ebuild11
4 files changed, 26 insertions, 11 deletions
diff --git a/media-gfx/opencolorio/ChangeLog b/media-gfx/opencolorio/ChangeLog
index 002dcb6fe4f3..b07dff3d82d6 100644
--- a/media-gfx/opencolorio/ChangeLog
+++ b/media-gfx/opencolorio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/opencolorio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencolorio/ChangeLog,v 1.2 2012/11/24 21:40:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencolorio/ChangeLog,v 1.3 2012/11/26 07:42:27 pinkbyte Exp $
+
+ 26 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> opencolorio-1.0.7.ebuild,
+ files/opencolorio-documentation-gen.patch, metadata.xml:
+ Remove automagic dependency on pdflatex binary, add USE-flag 'pdf' for
+ building extra pdf documentation, fix patch for documentation building
24 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> opencolorio-1.0.7.ebuild,
+files/opencolorio-openimageio.patch:
diff --git a/media-gfx/opencolorio/files/opencolorio-documentation-gen.patch b/media-gfx/opencolorio/files/opencolorio-documentation-gen.patch
index 283282232e9b..172d50d1d6dd 100644
--- a/media-gfx/opencolorio/files/opencolorio-documentation-gen.patch
+++ b/media-gfx/opencolorio/files/opencolorio-documentation-gen.patch
@@ -1,5 +1,5 @@
---- docs/CMakeLists.txt.orig 2012-08-18 17:21:23.833556790 +0400
-+++ docs/CMakeLists.txt 2012-08-18 17:22:44.968559366 +0400
+--- docs/CMakeLists.txt.orig 2012-11-26 11:05:55.000000000 +0400
++++ docs/CMakeLists.txt 2012-11-26 11:07:42.622459004 +0400
@@ -1,62 +1,3 @@
-
-###############################################################################
@@ -72,7 +72,7 @@
DEPENDS
OpenColorIO
PyOpenColorIO
-@@ -93,19 +34,15 @@
+@@ -93,19 +34,17 @@
COMMENT "Building html docs"
SOURCES ${DOCFILES})
@@ -85,16 +85,18 @@
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/$ENV{P}/html
PATTERN .git EXCLUDE)
++if(OCIO_BUILD_PDF_DOCS)
++
find_package(LATEX)
if(PDFLATEX_COMPILER)
add_custom_target(latex
- COMMAND PYTHONPATH=${PYTHONPATH} ${EXTDIST_BINPATH}/sphinx-build -b latex . ${CMAKE_CURRENT_BINARY_DIR}/build-latex
-+ COMMAND PYTHONPATH=sphinx-build -b latex . ${CMAKE_CURRENT_BINARY_DIR}/build-latex
++ COMMAND PYTHONPATH= sphinx-build -b latex . ${CMAKE_CURRENT_BINARY_DIR}/build-latex
DEPENDS
OpenColorIO
${CMAKE_BINARY_DIR}/docs/conf.py
-@@ -115,7 +52,6 @@
+@@ -115,7 +54,6 @@
${RSTDOC_OUTPUT}
COMMENT "Building latex doc"
SOURCES ${DOCFILES})
@@ -102,7 +104,7 @@
add_custom_target(pdf ALL
COMMAND ${PDFLATEX_COMPILER} OpenColorIO.tex
-@@ -125,6 +61,6 @@
+@@ -125,6 +63,8 @@
add_dependencies(pdf latex)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/build-latex/OpenColorIO.pdf
@@ -110,3 +112,5 @@
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/$ENV{P})
endif()
++
++endif()
diff --git a/media-gfx/opencolorio/metadata.xml b/media-gfx/opencolorio/metadata.xml
index 6e27fe9a4988..723c8e0ff93b 100644
--- a/media-gfx/opencolorio/metadata.xml
+++ b/media-gfx/opencolorio/metadata.xml
@@ -6,4 +6,7 @@
<name>Sergey Popov</name>
</maintainer>
<longdescription lang="en">OpenColorIO (OCIO) is a complete color management solution geared towards motion picture production with an emphasis on visual effects and computer animation.</longdescription>
+ <use>
+ <flag name="pdf">Install extra documentation in PDF format</flag>
+ </use>
</pkgmetadata>
diff --git a/media-gfx/opencolorio/opencolorio-1.0.7.ebuild b/media-gfx/opencolorio/opencolorio-1.0.7.ebuild
index a3d559fd8b28..e5b56a21ddf7 100644
--- a/media-gfx/opencolorio/opencolorio-1.0.7.ebuild
+++ b/media-gfx/opencolorio/opencolorio-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencolorio/opencolorio-1.0.7.ebuild,v 1.2 2012/11/24 21:40:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opencolorio/opencolorio-1.0.7.ebuild,v 1.3 2012/11/26 07:42:27 pinkbyte Exp $
EAPI=4
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/imageworks/OpenColorIO/tarball/v${PV} \
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc opengl python sse2 test"
+IUSE="doc opengl pdf python sse2 test"
RDEPEND="opengl? (
media-libs/lcms:2
@@ -29,7 +29,10 @@ RDEPEND="opengl? (
dev-libs/tinyxml
"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
+ doc? (
+ pdf? ( dev-python/sphinx[latex] )
+ !pdf? ( dev-python/sphinx )
+ )
"
# Documentation building requires Python bindings building
@@ -53,7 +56,6 @@ src_configure() {
# Missing features:
# - Truelight and Nuke are not in portage for now, so their support are disabled
# - Java bindings was not tested, so disabled
- # - Documentation PDF does not build properly ("automagic dependency on pdflatex")
# Notes:
# - OpenImageIO is required for building ociodisplay and ocioconvert (USE opengl)
# - OpenGL, GLUT and GLEW is required for building ociodisplay (USE opengl)
@@ -66,6 +68,7 @@ src_configure() {
-DOCIO_BUILD_TRUELIGHT=OFF
$(cmake-utils_use doc OCIO_BUILD_DOCS)
$(cmake-utils_use opengl OCIO_BUILD_APPS)
+ $(cmake-utils_use pdf OCIO_BUILD_PDF_DOCS)
$(cmake-utils_use python OCIO_BUILD_PYGLUE)
$(cmake-utils_use sse2 OCIO_USE_SSE)
$(cmake-utils_use test OCIO_BUILD_TESTS)