summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-27 08:49:11 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-27 08:49:11 +0000
commit4bca6dd6bb02a97d7d785393b3d543c1682ce13a (patch)
tree50474b0b492b492109c34b11067ea4318e354479 /media-gfx
parentFix for Prefix, thanks Myk Taylor, bug #444898 (diff)
downloadgentoo-2-4bca6dd6bb02a97d7d785393b3d543c1682ce13a.tar.gz
gentoo-2-4bca6dd6bb02a97d7d785393b3d543c1682ce13a.tar.bz2
gentoo-2-4bca6dd6bb02a97d7d785393b3d543c1682ce13a.zip
Initial commit wrt bug #435294. Thanks to Jared B. and Mikle Kolyada for their work on ebuild. The latter will maintain this package through proxy maintainers
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/cropgui/ChangeLog12
-rw-r--r--media-gfx/cropgui/cropgui-0.1.1.ebuild51
-rw-r--r--media-gfx/cropgui/metadata.xml15
3 files changed, 78 insertions, 0 deletions
diff --git a/media-gfx/cropgui/ChangeLog b/media-gfx/cropgui/ChangeLog
new file mode 100644
index 000000000000..a5812bac82ac
--- /dev/null
+++ b/media-gfx/cropgui/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-gfx/cropgui
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/cropgui/ChangeLog,v 1.1 2012/11/27 08:49:11 pinkbyte Exp $
+
+*cropgui-0.1.1 (27 Nov 2012)
+
+ 27 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> +cropgui-0.1.1.ebuild,
+ +metadata.xml:
+ Initial commit wrt bug #435294. Thanks to Jared B. and Mikle Kolyada for
+ their work on ebuild. The latter will maintain this package through proxy
+ maintainers
+
diff --git a/media-gfx/cropgui/cropgui-0.1.1.ebuild b/media-gfx/cropgui/cropgui-0.1.1.ebuild
new file mode 100644
index 000000000000..995206f7f435
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/cropgui/cropgui-0.1.1.ebuild,v 1.1 2012/11/27 08:49:11 pinkbyte Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils python
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="http://emergent.unpythonic.net/01248401946"
+SRC_URI="http://media.unpythonic.net/emergent-files/01248401946/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-python/imaging
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e '/Encoding/d' \
+ -e '/Version/d' \
+ -e '/MimeType/s/$/&;/' \
+ -e '/Categories/s/Application;//' \
+ cropgui.desktop || die 'sed on cropgui.desktop failed'
+}
+
+src_install() {
+ install_cropgui_wrapper() {
+ insinto "$(python_get_sitedir)/${PN}"
+ python_convert_shebangs -q ${PYTHON_ABI} *.py
+ doins cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper cropgui-${PYTHON_ABI} "$(PYTHON -a) $(python_get_sitedir)/${PN}/cropgtk.py"
+ }
+ python_execute_function -q install_cropgui_wrapper
+ python_generate_wrapper_scripts "${ED}/usr/bin/cropgui"
+
+ domenu cropgui.desktop
+ doicon cropgui.png
+}
diff --git a/media-gfx/cropgui/metadata.xml b/media-gfx/cropgui/metadata.xml
new file mode 100644
index 000000000000..a0f314b05cb2
--- /dev/null
+++ b/media-gfx/cropgui/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>zlog.gentoo@gmail.com</email>
+ <name>Mikle Kolyada</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>