summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-25 13:56:58 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-25 13:56:58 +0000
commit4bb3344539fff57a011e048101207a79aa7fc381 (patch)
tree5fa7550a0ab32df89c086f2e6ed594fa515f5b36 /media-gfx
parentVersion bump. #434094 (diff)
downloadgentoo-2-4bb3344539fff57a011e048101207a79aa7fc381.tar.gz
gentoo-2-4bb3344539fff57a011e048101207a79aa7fc381.tar.bz2
gentoo-2-4bb3344539fff57a011e048101207a79aa7fc381.zip
Version bump to latest version.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphite2/ChangeLog7
-rw-r--r--media-gfx/graphite2/graphite2-1.2.0.ebuild100
2 files changed, 106 insertions, 1 deletions
diff --git a/media-gfx/graphite2/ChangeLog b/media-gfx/graphite2/ChangeLog
index 7fe09e5bd7c5..e0031971bde4 100644
--- a/media-gfx/graphite2/ChangeLog
+++ b/media-gfx/graphite2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/graphite2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.32 2012/06/29 11:54:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.33 2012/09/25 13:56:58 scarabeus Exp $
+
+*graphite2-1.2.0 (25 Sep 2012)
+
+ 25 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +graphite2-1.2.0.ebuild:
+ Version bump to latest version.
29 Jun 2012; Tomáš Chvátal <scarabeus@gentoo.org> -graphite2-1.1.2.ebuild,
graphite2-1.1.3.ebuild:
diff --git a/media-gfx/graphite2/graphite2-1.2.0.ebuild b/media-gfx/graphite2/graphite2-1.2.0.ebuild
new file mode 100644
index 000000000000..2430048a0cc0
--- /dev/null
+++ b/media-gfx/graphite2/graphite2-1.2.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.2.0.ebuild,v 1.1 2012/09/25 13:56:58 scarabeus Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="test? 2"
+GENTOO_DEPEND_ON_PERL="no"
+inherit base cmake-utils perl-module python
+
+DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
+HOMEPAGE="http://graphite.sil.org/"
+SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="perl test"
+
+RDEPEND="
+ perl? ( dev-lang/perl )
+"
+DEPEND="${RDEPEND}
+ perl? ( virtual/perl-Module-Build )
+ test? (
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/silgraphite
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-includes-libs-perl.patch"
+ "${FILESDIR}/${PN}-1.0.2-no_harfbuzz_tests.patch"
+ "${FILESDIR}/${PN}-1.0.3-no-test-binaries.patch"
+)
+
+pkg_setup() {
+ use perl && perl-module_pkg_setup
+ if use test; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # fix perl linking
+ if use perl; then
+ _check_build_dir init
+ sed -i \
+ -e "s:@BUILD_DIR@:\"${CMAKE_BUILD_DIR}/src\":" \
+ contrib/perl/Build.PL || die
+ fi
+
+ # make tests optional
+ if ! use test; then
+ sed -i \
+ -e '/tests/d' \
+ CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DVM_MACHINE_TYPE=direct"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use perl; then
+ cd contrib/perl
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ cmake-utils_src_test
+ if use perl; then
+ cd contrib/perl
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use perl; then
+ cd contrib/perl
+ perl-module_src_install
+ fixlocalpod
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+}