summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-06-28 22:33:59 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-06-28 22:33:59 +0000
commit42db6612604dfc9b2dee61c02e49f009c8841f3a (patch)
treed53696ec0e4bc69a0b30b988a2d05beca0d0b789 /media-gfx
parentwhitespace (diff)
downloadgentoo-2-42db6612604dfc9b2dee61c02e49f009c8841f3a.tar.gz
gentoo-2-42db6612604dfc9b2dee61c02e49f009c8841f3a.tar.bz2
gentoo-2-42db6612604dfc9b2dee61c02e49f009c8841f3a.zip
Added patch to make it build with recent boost versions. Removed now unnecessary patch from stack. Added missing exiftool dependency.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/ChangeLog7
-rw-r--r--media-gfx/hugin/files/hugin-0.8.0_rc4-use_system_cmake_findboost.patch116
-rw-r--r--media-gfx/hugin/hugin-0.8.0_rc4.ebuild21
3 files changed, 136 insertions, 8 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index 4896599a548c..6a528075fd2d 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.66 2009/06/27 12:20:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.67 2009/06/28 22:33:59 dev-zero Exp $
+
+ 28 Jun 2009; Tiziano Müller <dev-zero@gentoo.org> hugin-0.8.0_rc4.ebuild,
+ +files/hugin-0.8.0_rc4-use_system_cmake_findboost.patch:
+ Added patch to make it build with recent boost versions. Removed now
+ unnecessary patch from stack. Added missing exiftool dependency.
*hugin-0.8.0_rc4 (27 Jun 2009)
diff --git a/media-gfx/hugin/files/hugin-0.8.0_rc4-use_system_cmake_findboost.patch b/media-gfx/hugin/files/hugin-0.8.0_rc4-use_system_cmake_findboost.patch
new file mode 100644
index 000000000000..ceed7067a6d7
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-0.8.0_rc4-use_system_cmake_findboost.patch
@@ -0,0 +1,116 @@
+diff -Naur hugin-0.8.0.orig/CMakeLists.txt hugin-0.8.0/CMakeLists.txt
+--- hugin-0.8.0.orig/CMakeLists.txt 2009-06-29 00:09:44.091649435 +0200
++++ hugin-0.8.0/CMakeLists.txt 2009-06-29 00:10:23.898439132 +0200
+@@ -89,8 +89,6 @@
+ # create the cache entry
+ SET( SOURCE_BASE_DIR ${work} CACHE FILEPATH "parent dir of hugin source root" )
+
+- # search boost there
+- SET(BOOST_DIR_SEARCH_USER ${SOURCE_BASE_DIR})
+ # wxWidgets
+ SET(wxWidgets_ROOT_DIR ${SOURCE_BASE_DIR}/wxWidgets-2.8.10)
+ # GLEW moved to FildGLEW.cmake module
+@@ -179,11 +177,10 @@
+ ## Boost
+ ##
+
+-SET(Boost_LIB_SUFFIX_DEBUG gd)
+-FIND_PACKAGE(Boost REQUIRED thread)
+-IF (NOT Boost_thread_FOUND)
+- MESSAGE(FATAL_ERROR "boost thread library not found. If it is installed with a\nunrecognized suffix, specify it with -DBoost_LIB_SUFFIX=<suffix>")
+-ENDIF (NOT Boost_thread_FOUND)
++FIND_PACKAGE(Boost COMPONENTS thread)
++IF (NOT Boost_FOUND)
++ MESSAGE(FATAL_ERROR "boost thread library not found. If it is installed with a\nunrecognized suffix, specify it with -DBOOST_LIBRARYDIR=<librarydir> and -DBOOST_INCLUDEDIR=<includedir>")
++ENDIF (NOT Boost_FOUND)
+
+ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+ LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+diff -Naur hugin-0.8.0.orig/src/CMakeLists.txt hugin-0.8.0/src/CMakeLists.txt
+--- hugin-0.8.0.orig/src/CMakeLists.txt 2009-06-29 00:09:44.024975006 +0200
++++ hugin-0.8.0/src/CMakeLists.txt 2009-06-29 00:11:03.751660063 +0200
+@@ -15,11 +15,11 @@
+ IF(LAPACK_FOUND)
+ # need to specify boost thread library
+ set(common_libs huginbase
+- ${Boost_thread_LIBRARIES} ${PANO_LIBRARIES} ${LAPACK_LIBRARIES} huginlevmar)
++ ${Boost_LIBRARIES} ${PANO_LIBRARIES} ${LAPACK_LIBRARIES} huginlevmar)
+ ELSE(LAPACK_FOUND)
+ # need to specify boost thread library
+ set(common_libs huginbase
+- ${Boost_thread_LIBRARIES} ${PANO_LIBRARIES} huginlevmar)
++ ${Boost_LIBRARIES} ${PANO_LIBRARIES} huginlevmar)
+ ENDIF(LAPACK_FOUND)
+ ENDIF (MSVC)
+
+diff -Naur hugin-0.8.0.orig/src/CMakeLists.txt.orig hugin-0.8.0/src/CMakeLists.txt.orig
+--- hugin-0.8.0.orig/src/CMakeLists.txt.orig 1970-01-01 01:00:00.000000000 +0100
++++ hugin-0.8.0/src/CMakeLists.txt.orig 2009-06-17 19:48:37.000000000 +0200
+@@ -0,0 +1,56 @@
++
++# define common sets of libraries, used by different subdirectories
++IF (MSVC)
++ IF(LAPACK_FOUND)
++ # boost_thread is linked automatically
++ # additionally link to our getopt
++ set(common_libs huginbase hugingetopt
++ ${PANO_LIBRARIES} ${LAPACK_LIBRARIES} huginlevmar)
++ ELSE(LAPACK_FOUND)
++ set(common_libs huginbase hugingetopt
++ ${PANO_LIBRARIES} huginlevmar)
++ ENDIF(LAPACK_FOUND)
++ include_directories( ${CMAKE_SOURCE_DIR}/src/foreign/getopt/include )
++ELSE (MSVC)
++ IF(LAPACK_FOUND)
++ # need to specify boost thread library
++ set(common_libs huginbase
++ ${Boost_thread_LIBRARIES} ${PANO_LIBRARIES} ${LAPACK_LIBRARIES} huginlevmar)
++ ELSE(LAPACK_FOUND)
++ # need to specify boost thread library
++ set(common_libs huginbase
++ ${Boost_thread_LIBRARIES} ${PANO_LIBRARIES} huginlevmar)
++ ENDIF(LAPACK_FOUND)
++ENDIF (MSVC)
++
++set(image_libs huginvigraimpex ${OPENEXR_LIBRARIES} ${JPEG_LIBRARIES} ${TIFF_LIBRARIES}
++ ${PNG_LIBRARIES} ${ZLIB_LIBRARIES} ${EXIV2_LIBRARIES})
++
++add_subdirectory(celeste)
++add_subdirectory(foreign)
++add_subdirectory(hugin_base)
++add_subdirectory(tools)
++add_subdirectory(matchpoint)
++add_subdirectory(deghosting)
++
++# build vips stuff, only if vips was found
++# not ready for the general public yet
++IF(VIPS_FOUND)
++# add_subdirectory(vips)
++ENDIF(VIPS_FOUND)
++
++# build gui only if wxWidgets was found
++IF(wxWidgets_FOUND)
++ INCLUDE(${wxWidgets_USE_FILE})
++ add_subdirectory(hugin1)
++
++ include_directories( ${CMAKE_SOURCE_DIR}/src/hugin1 )
++ # do we need to define _UNICODE on windows?
++ IF(WIN32)
++ IF ("${wxWidgets_CONFIGURATION}" STREQUAL "mswu")
++ ADD_DEFINITIONS("-D_UNICODE")
++ ENDIF("${wxWidgets_CONFIGURATION}" STREQUAL "mswu")
++ ENDIF(WIN32)
++ENDIF(wxWidgets_FOUND)
++
++add_subdirectory(translations)
+diff -Naur hugin-0.8.0.orig/src/hugin_base/CMakeLists.txt hugin-0.8.0/src/hugin_base/CMakeLists.txt
+--- hugin-0.8.0.orig/src/hugin_base/CMakeLists.txt 2009-06-29 00:13:41.115785087 +0200
++++ hugin-0.8.0/src/hugin_base/CMakeLists.txt 2009-06-29 00:10:23.901636391 +0200
+@@ -58,6 +58,7 @@
+
+ IF (${HUGIN_SHARED_LIBS})
+ add_library(huginbase SHARED ${HUGIN_BASE_SRC})
++ target_link_libraries(huginbase ${Boost_LIBRARIES})
+ set_target_properties(huginbase PROPERTIES VERSION ${HUGIN_LIB_VERSION})
+ install(TARGETS huginbase DESTINATION ${LIBDIR})
+ ELSE (${HUGIN_SHARED_LIBS})
diff --git a/media-gfx/hugin/hugin-0.8.0_rc4.ebuild b/media-gfx/hugin/hugin-0.8.0_rc4.ebuild
index 66959edc34c7..63d826782d46 100644
--- a/media-gfx/hugin/hugin-0.8.0_rc4.ebuild
+++ b/media-gfx/hugin/hugin-0.8.0_rc4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.8.0_rc4.ebuild,v 1.1 2009/06/27 12:20:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.8.0_rc4.ebuild,v 1.2 2009/06/28 22:33:59 dev-zero Exp $
EAPI="2"
WX_GTK_VER="2.8"
-inherit cmake-utils wxwidgets versionator
+inherit base cmake-utils wxwidgets versionator
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -17,9 +17,8 @@ KEYWORDS="~amd64 ~ppc ~x86"
LANGS=" bg ca cs de en_GB es fr hu it ja ko nl pl pt_BR ru sk sl sv uk zh_CN zh_TW"
IUSE="lapack +sift $(echo ${LANGS//\ /\ linguas_})"
-DEPEND="
- app-arch/zip
- || ( >=dev-libs/boost-1.34 =dev-libs/boost-1.33*[threads] )
+DEPEND="app-arch/zip
+ >=dev-libs/boost-1.35.0-r5
>=media-gfx/enblend-3.0_p20080807
media-gfx/exiv2
media-libs/jpeg
@@ -31,14 +30,22 @@ DEPEND="
x11-libs/wxGTK:2.8
lapack? ( virtual/lapack )
sift? ( media-gfx/autopano-sift-C )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ media-libs/exiftool"
S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
PATCHES=(
"${FILESDIR}"/${PN}-0.8.0_rc3-as-needed.patch
- "${FILESDIR}"/${PN}-0.8.0_rc3-unset_lapack.patch
+ "${FILESDIR}"/${P}-use_system_cmake_findboost.patch
)
+src_prepare() {
+ base_src_prepare
+
+ # Remove faulty module and force usage of system cmake FindBoost
+ rm CMakeModules/FindBoost.cmake
+}
+
pkg_setup() {
DOCS="AUTHORS README TODO"
mycmakeargs="$(cmake-utils_use_enable lapack)"