summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2008-02-10 20:41:34 +0000
committerDominik Stadler <centic@gentoo.org>2008-02-10 20:41:34 +0000
commit42652512eb50902edad1551362b0ef3d677788cc (patch)
tree58b2ff171e278099534db7243b042be703b78f8f /media-gfx
parentinitial import (diff)
downloadgentoo-2-42652512eb50902edad1551362b0ef3d677788cc.tar.gz
gentoo-2-42652512eb50902edad1551362b0ef3d677788cc.tar.bz2
gentoo-2-42652512eb50902edad1551362b0ef3d677788cc.zip
Bump to release 1.41
(Portage version: 2.1.4.2)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/asymptote/ChangeLog13
-rw-r--r--media-gfx/asymptote/asymptote-1.41.ebuild136
-rw-r--r--media-gfx/asymptote/files/asymptote-1.41-configure-ac.patch43
-rw-r--r--media-gfx/asymptote/files/asymptote-1.41-makefile.patch58
-rw-r--r--media-gfx/asymptote/files/asymptote-1.41-xdg-utils.patch19
5 files changed, 267 insertions, 2 deletions
diff --git a/media-gfx/asymptote/ChangeLog b/media-gfx/asymptote/ChangeLog
index 5b60f2dc505d..978d12b19854 100644
--- a/media-gfx/asymptote/ChangeLog
+++ b/media-gfx/asymptote/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/asymptote
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.13 2007/10/27 20:15:58 centic Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.14 2008/02/10 20:41:34 centic Exp $
+
+*asymptote-1.41 (10 Feb 2008)
+
+ 10 Feb 2008; Dominik Stadler <centic@gentoo.org>
+ +files/asymptote-1.41-configure-ac.patch,
+ +files/asymptote-1.41-makefile.patch,
+ +files/asymptote-1.41-xdg-utils.patch, +asymptote-1.41.ebuild:
+ Bump to version 1.41, fixes Bug 208817, thanks to Andrey Grocin
+ for updating the patches.
*asymptote-1.36 (27 Oct 2007)
diff --git a/media-gfx/asymptote/asymptote-1.41.ebuild b/media-gfx/asymptote/asymptote-1.41.ebuild
new file mode 100644
index 000000000000..dd057b163ab0
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-1.41.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-1.41.ebuild,v 1.1 2008/02/10 20:41:34 centic Exp $
+
+inherit eutils elisp-common latex-package
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="boehm-gc doc fftw emacs gsl vim-syntax"
+
+RDEPEND=">=sys-libs/readline-4.3-r5
+ >=sys-libs/ncurses-5.4-r5
+ dev-libs/libsigsegv
+ x11-misc/xdg-utils
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0 )
+ virtual/tetex
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ emacs? ( virtual/emacs )
+ gsl? ( sci-libs/gsl )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.5
+ >=sys-devel/bison-1.875
+ >=sys-devel/flex-2.5.4a-r5
+ doc? ( >=media-gfx/imagemagick-6.1.3.2
+ virtual/ghostscript
+ >=sys-apps/texinfo-4.7-r1 )"
+
+SITEFILE=64${PN}-gentoo.el
+
+pkg_setup() {
+ # checking if Boehm garbage collector was compiled with c++ support
+ if use boehm-gc ; then
+ if ! built_with_use dev-libs/boehm-gc nocxx ; then
+ einfo "dev-libs/boehm-gc has been compiled with nocxx use flag disabled"
+ else
+ echo
+ eerror "You have to rebuild dev-libs/boehm-gc enabling c++ support"
+ die
+ fi
+ fi
+
+ if ! built_with_use dev-lang/python tk; then
+ eerror "Please reemerge dev-lang/python with 'tk' support or xasy will"
+ eerror "not work. In order to fix this, execute the following:"
+ eerror "echo \"dev-lang/python tk\" >> /etc/portage/package.use"
+ eerror "and reemerge dev-lang/python before emerging asymptote."
+ die "requires dev-lang/python with use-flag 'tk'!!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Fixing fftw and gsl enabling
+ epatch "${FILESDIR}/${P}-configure-ac.patch"
+ einfo "Patching configure.ac"
+ sed -i \
+ -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ configure.ac || die "sed configure.ac failed"
+
+ einfo "Building configure"
+ WANT_AUTOCONF=2.5 autoconf
+
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ epatch "${FILESDIR}/${P}-xdg-utils.patch"
+}
+
+src_compile() {
+ for dir in `find /var/cache/fonts -type d`; do addwrite ${dir}; done
+
+ # for the CPPFLAGS see http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ myconf="--with-latex=/usr/share/texmf/tex/latex --disable-gc-debug CPPFLAGS=-DHAVE_SYS_TYPES_H"
+ if use boehm-gc; then
+ myconf="${myconf} --enable-gc=system"
+ else
+ myconf="${myconf} --disable-gc"
+ fi
+
+ econf ${myconf} $(use_with fftw) $(use_with gsl) || die "econf failed"
+ emake || die "emake failed"
+
+ if use emacs ; then
+ elisp-compile base/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ for dir in `find /var/cache/fonts -type d`; do addwrite ${dir}; done
+
+ if use doc; then
+ target="install-all"
+ else
+ target="install"
+ fi
+
+ emake DESTDIR="${D}" ${target} || die "emake install failed"
+
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+
+ if use emacs ; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/asy-ftd.vim"
+ fi
+}
+
+pkg_postinst() {
+ latex-package_rehash
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ latex-package_rehash
+ use emacs && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/files/asymptote-1.41-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.41-configure-ac.patch
new file mode 100644
index 000000000000..71a7bc06d243
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.41-configure-ac.patch
@@ -0,0 +1,43 @@
+diff -U2 --recursive asymptote-1.41.orig/configure.ac asymptote-1.41/configure.ac
+--- asymptote-1.41.orig/configure.ac 2008-02-02 07:13:56.000000000 +0600
++++ asymptote-1.41/configure.ac 2008-02-04 06:21:51.000000000 +0600
+@@ -77,8 +77,14 @@
+ fi
+
+-AC_CHECK_HEADER(fftw3.h,
+- AC_CHECK_LIB([fftw3], fftw_execute,,
++AC_ARG_WITH([fftw],
++ [ --with-fftw use fftw3],
++ [with_fftw=$withval],
++ [with_fftw="no"])
++if test "$with_fftw" = "yes"; then
++AC_CHECK_HEADER([fftw3.h],
++ AC_CHECK_LIB([fftw3], [fftw_execute],,
+ AC_MSG_NOTICE([*** Could not find libfftw3: will compile without optional fast Fourier transforms. ***])),
+ AC_MSG_NOTICE([*** Header file fftw3.h not found: will compile without optional fast Fourier transforms. ***]))
++fi
+
+ GCVERSION=gc-7.0
+@@ -117,5 +123,5 @@
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+@@ -197,4 +203,9 @@
+ AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
+
++AC_ARG_WITH(gsl,
++ [ --with-gsl use gsl libraries],
++ [with_gsl=$withval],
++ [with_gsl="no"])
++if test "$with_gsl" = "yes"; then
+ AC_CHECK_HEADER(gsl/gsl_sf.h,
+ AC_CHECK_LIB([gsl], gsl_sf_Si, [AC_DEFINE(HAVE_LIBGSL, 1,
+@@ -202,4 +213,5 @@
+ AC_MSG_NOTICE([*** Could not find libgsl: will compile without optional special functions. ***]),[-lgslcblas]),
+ AC_MSG_NOTICE([*** Header file gsl_sf.h not found: will compile without optional special functions. ***]))
++fi
+
+ # Checks for typedefs, structures, and compiler characteristics.
diff --git a/media-gfx/asymptote/files/asymptote-1.41-makefile.patch b/media-gfx/asymptote/files/asymptote-1.41-makefile.patch
new file mode 100644
index 000000000000..3202ded70b2b
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.41-makefile.patch
@@ -0,0 +1,58 @@
+diff -U2 --recursive asymptote-1.41.orig/Makefile.in asymptote-1.41/Makefile.in
+--- asymptote-1.41.orig/Makefile.in 2008-02-02 07:13:09.000000000 +0600
++++ asymptote-1.41/Makefile.in 2008-02-04 06:23:35.000000000 +0600
+@@ -51,5 +51,5 @@
+ GUIdir = $(asydir)/GUI
+ docdir = $(DESTDIR)@docdir@
+-exampledir = $(docdir)/examples
++exampledir = $(asydir)/examples
+ animationsdir = $(exampledir)/animations
+ latexdir = $(DESTDIR)@latexdir@
+@@ -136,9 +136,6 @@
+ ${INSTALL} -p -m 644 examples/animations/*.asy $(animationsdir)
+ -${INSTALL} -p -m 644 $(addprefix doc/,$(LATEXFILES)) $(latexdir)
+- -if test -z "$(DESTDIR)"; then \
+- texhash; \
+- fi
+
+-install-doc: html
++install-doc:
+ cd doc; $(MAKE) install-all
+
+diff -U2 --recursive asymptote-1.41.orig/doc/Makefile asymptote-1.41/doc/Makefile
+--- asymptote-1.41.orig/doc/Makefile 2008-02-02 07:14:11.000000000 +0600
++++ asymptote-1.41/doc/Makefile 2008-02-04 06:23:50.000000000 +0600
+@@ -17,10 +17,10 @@
+ html: asymptote/index.html
+
+-man: $(DOCFILES) asy.1
++man: $(MANFILES)
+
+ faq:
+ cd FAQ; $(MAKE) faq
+
+-doc: asymptote.dvi asymptote.info html man faq
++doc: $(DOCFILES) asymptote.info html man faq
+
+ %.png: %.asy
+@@ -85,13 +85,12 @@
+ rm -rf asymptote
+
+-install: man faq
+- cd FAQ; $(MAKE) install
+- ${INSTALL} -d -m 755 $(docdir) $(mandir)/man1
+- ${INSTALL} -p -m 644 $(DOCFILES) $(docdir)
+- ${INSTALL} -p -m 644 $(MANFILES) $(mandir)/man1
++install: man
++ ${INSTALL} -d -m 755 $(mandir)/man1
+
+-install-all: doc install
+- cd FAQ; $(MAKE) install-info
+- ${INSTALL} -d -m 755 $(infodir)
++install-all: doc faq install
++ cd FAQ; $(MAKE) install-all
++ ${INSTALL} -d -m 755 $(infodir) $(docdir)/html/asymptote
++ ${INSTALL} -p -m 644 $(DOCFILES) $(docdir)
++ ${INSTALL} -p -m 644 asymptote/* $(docdir)/html/asymptote
+ ${INSTALL} -p -m 644 asymptote.info $(infodir)
+ -${INSTALL} -p -m 644 asymptote.info-* $(infodir)
diff --git a/media-gfx/asymptote/files/asymptote-1.41-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-1.41-xdg-utils.patch
new file mode 100644
index 000000000000..bc2ac0a780ac
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.41-xdg-utils.patch
@@ -0,0 +1,19 @@
+diff -U2 --recursive asymptote-1.41.orig/settings.cc asymptote-1.41/settings.cc
+--- asymptote-1.41.orig/settings.cc 2008-02-02 07:13:09.000000000 +0600
++++ asymptote-1.41/settings.cc 2008-02-04 19:43:26.000000000 +0600
+@@ -74,12 +74,12 @@
+ const char *HOME="HOME";
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultPython;
+ const string docdir=ASYMPTOTE_DOCDIR;