summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-06 13:48:03 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-06 13:48:03 +0000
commit34df595bf7a973e9f51900a78787dbda8bd6025d (patch)
treeeef02848f23b81116c8d796d66d7214af2d05dc5 /media-gfx
parentadd patch to build with ffmpeg2, bug #536626 (diff)
downloadgentoo-2-34df595bf7a973e9f51900a78787dbda8bd6025d.tar.gz
gentoo-2-34df595bf7a973e9f51900a78787dbda8bd6025d.tar.bz2
gentoo-2-34df595bf7a973e9f51900a78787dbda8bd6025d.zip
fix deps (bug #539008); version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/photoqt/ChangeLog10
-rw-r--r--media-gfx/photoqt/photoqt-1.1.0.1.ebuild18
-rw-r--r--media-gfx/photoqt/photoqt-1.2.ebuild38
3 files changed, 58 insertions, 8 deletions
diff --git a/media-gfx/photoqt/ChangeLog b/media-gfx/photoqt/ChangeLog
index f0f434b54d56..5e5bb0a420e0 100644
--- a/media-gfx/photoqt/ChangeLog
+++ b/media-gfx/photoqt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/photoqt
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoqt/ChangeLog,v 1.3 2014/12/17 18:10:19 kensington Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoqt/ChangeLog,v 1.4 2015/02/06 13:48:03 yngwin Exp $
+
+*photoqt-1.2 (06 Feb 2015)
+
+ 06 Feb 2015; Ben de Groot <yngwin@gentoo.org> +photoqt-1.2.ebuild,
+ photoqt-1.1.0.1.ebuild:
+ fix deps (bug #539008); version bump
17 Dec 2014; Michael Palimaka <kensington@gentoo.org> photoqt-1.1.0.1.ebuild:
Pin dev-qt/linguist-tools to SLOT 5.
diff --git a/media-gfx/photoqt/photoqt-1.1.0.1.ebuild b/media-gfx/photoqt/photoqt-1.1.0.1.ebuild
index db5f8678fb92..2eaae2b8ad8b 100644
--- a/media-gfx/photoqt/photoqt-1.1.0.1.ebuild
+++ b/media-gfx/photoqt/photoqt-1.1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoqt/photoqt-1.1.0.1.ebuild,v 1.3 2014/12/17 18:11:14 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoqt/photoqt-1.1.0.1.ebuild,v 1.4 2015/02/06 13:48:03 yngwin Exp $
EAPI=5
inherit cmake-utils
@@ -14,14 +14,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="graphicsmagick exiv2"
-DEPEND="dev-qt/linguist-tools:5
- dev-qt/qtmultimedia:5
+RDEPEND="dev-qt/qtgui:5
dev-qt/qtimageformats:5
- dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
exiv2? ( media-gfx/exiv2:= )
graphicsmagick? ( media-gfx/graphicsmagick )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
src_configure() {
local mycmakeargs=(
@@ -30,3 +32,7 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+src_compile() {
+ MAKEOPTS+=" -j1" cmake-utils_src_compile
+}
diff --git a/media-gfx/photoqt/photoqt-1.2.ebuild b/media-gfx/photoqt/photoqt-1.2.ebuild
new file mode 100644
index 000000000000..fb6b0f8878b7
--- /dev/null
+++ b/media-gfx/photoqt/photoqt-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/photoqt/photoqt-1.2.ebuild,v 1.1 2015/02/06 13:48:03 yngwin Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Simple but powerful Qt-based image viewer"
+HOMEPAGE="http://photoqt.org/"
+SRC_URI="http://photoqt.org/pkgs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphicsmagick exiv2"
+
+RDEPEND="dev-qt/qtgui:5
+ dev-qt/qtimageformats:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ exiv2? ( media-gfx/exiv2:= )
+ graphicsmagick? ( media-gfx/graphicsmagick )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use graphicsmagick GM)
+ $(cmake-utils_use exiv2 EXIV2)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ MAKEOPTS+=" -j1" cmake-utils_src_compile
+}