summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-05-21 20:15:56 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-05-21 20:15:56 +0000
commit21a9434035466d414499a26bdce9d852c95aa3b5 (patch)
treef7eb8b2b16567de55aa633aa62d872b0f75f25f2 /media-gfx
parentNeeds >=dev-java/commons-io-1.3. Found in bug #178645. (diff)
downloadgentoo-2-21a9434035466d414499a26bdce9d852c95aa3b5.tar.gz
gentoo-2-21a9434035466d414499a26bdce9d852c95aa3b5.tar.bz2
gentoo-2-21a9434035466d414499a26bdce9d852c95aa3b5.zip
Added patch to compile with >=media-gfx/exiv2-0.14. Fixes bug 178939. Fixed manifest, fixes bug 166516.
(Portage version: 2.1.2.7)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/digikam/ChangeLog7
-rw-r--r--media-gfx/digikam/digikam-0.9.1.ebuild7
-rw-r--r--media-gfx/digikam/files/digikam-0.9.1-exiv2.patch116
3 files changed, 127 insertions, 3 deletions
diff --git a/media-gfx/digikam/ChangeLog b/media-gfx/digikam/ChangeLog
index 8dda936e8060..8086dd3b48f9 100644
--- a/media-gfx/digikam/ChangeLog
+++ b/media-gfx/digikam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/digikam
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/ChangeLog,v 1.88 2007/05/20 18:48:47 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/ChangeLog,v 1.89 2007/05/21 20:15:56 philantrop Exp $
+
+ 21 May 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/digikam-0.9.1-exiv2.patch, digikam-0.9.1.ebuild:
+ Added patch to compile with >=media-gfx/exiv2-0.14. Fixes bug 178939. Fixed
+ manifest, fixes bug 166516.
20 May 2007; Matti Bickel <mabi@gentoo.org> digikam-0.9.1.ebuild:
keyworded ~ppc (bug #169160)
diff --git a/media-gfx/digikam/digikam-0.9.1.ebuild b/media-gfx/digikam/digikam-0.9.1.ebuild
index 5aaae5af9a9a..feefb07018f9 100644
--- a/media-gfx/digikam/digikam-0.9.1.ebuild
+++ b/media-gfx/digikam/digikam-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/digikam-0.9.1.ebuild,v 1.7 2007/05/20 18:48:47 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/digikam-0.9.1.ebuild,v 1.8 2007/05/21 20:15:55 philantrop Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -63,6 +63,10 @@ src_unpack(){
kde_src_unpack
rm -f "${S}/configure" "${S_DOC}/configure"
+ if has_version ">=media-gfx/exiv2-0.14"; then
+ epatch "${FILESDIR}/${P}-exiv2.patch"
+ fi
+
local MAKE_PO=$(echo "${LINGUAS} ${LANGS}" | fmt -w 1 | sort | uniq -d | tr '\n' ' ')
elog "Enabling translations for: en ${MAKE_PO}"
sed -i -e "s:^SUBDIRS =.*:SUBDIRS = . ${MAKE_PO}:" "${S}/po/Makefile.am" || die "sed for locale failed"
@@ -91,4 +95,3 @@ src_install(){
mv "${D}/usr/share/applnk/Graphics/digikam.desktop" \
"${D}/usr/share/applications/kde"
}
-
diff --git a/media-gfx/digikam/files/digikam-0.9.1-exiv2.patch b/media-gfx/digikam/files/digikam-0.9.1-exiv2.patch
new file mode 100644
index 000000000000..2b6c72db38f2
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-0.9.1-exiv2.patch
@@ -0,0 +1,116 @@
+--- digikam-0.9.1.orig/digikam/libs/widgets/metadata/exifwidget.cpp 2007-03-04 21:33:32.000000000 +0100
++++ digikam-0.9.1/digikam/libs/widgets/metadata/exifwidget.cpp 2007-05-17 15:05:43.000000000 +0200
+@@ -181,7 +181,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot parse EXIF metadata using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return false;
+ }
+@@ -211,7 +211,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag title using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("Unknown");
+ }
+@@ -228,7 +228,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag description using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("No description available");
+ }
+--- digikam-0.9.1.orig/digikam/libs/widgets/metadata/gpswidget.cpp 2007-03-04 21:33:32.000000000 +0100
++++ digikam-0.9.1/digikam/libs/widgets/metadata/gpswidget.cpp 2007-05-17 15:06:40.000000000 +0200
+@@ -305,7 +305,7 @@
+ {
+ setMetadataEmpty();
+ DDebug() << "Cannot parse EXIF metadata using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return false;
+ }
+@@ -343,7 +343,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag title using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("Unknown");
+ }
+@@ -360,7 +360,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag description using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("No description available");
+ }
+--- digikam-0.9.1.orig/digikam/libs/widgets/metadata/iptcwidget.cpp 2007-03-04 21:33:32.000000000 +0100
++++ digikam-0.9.1/digikam/libs/widgets/metadata/iptcwidget.cpp 2007-05-17 15:05:04.000000000 +0200
+@@ -156,7 +156,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot parse IPTC metadata using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return false;
+ }
+@@ -185,7 +185,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag title using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("Unknow");
+ }
+@@ -202,7 +202,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag description using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("No description available");
+ }
+--- digikam-0.9.1.orig/digikam/libs/widgets/metadata/makernotewidget.cpp 2007-03-04 21:33:32.000000000 +0100
++++ digikam-0.9.1/digikam/libs/widgets/metadata/makernotewidget.cpp 2007-05-17 15:06:18.000000000 +0200
+@@ -198,7 +198,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot parse MAKERNOTE metadata using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return false;
+ }
+@@ -227,7 +227,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag title using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("Unknown");
+ }
+@@ -244,7 +244,7 @@
+ catch (Exiv2::Error& e)
+ {
+ DDebug() << "Cannot get metadata tag description using Exiv2 ("
+- << QString::fromAscii(e.what().c_str())
++ << QString::fromAscii(e.what())
+ << ")" << endl;
+ return i18n("No description available");
+ }