summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-02-10 14:23:37 +0000
committerMichael Januszewski <spock@gentoo.org>2007-02-10 14:23:37 +0000
commitddc5a469c1c96b981494bc249eb5fdec473f6301 (patch)
tree1b88520f8b3ccd7dd607eed6f47245cf42c92177 /media-gfx/splashutils
parenttable on ppc wrt bug 165617 (diff)
downloadgentoo-2-ddc5a469c1c96b981494bc249eb5fdec473f6301.tar.gz
gentoo-2-ddc5a469c1c96b981494bc249eb5fdec473f6301.tar.bz2
gentoo-2-ddc5a469c1c96b981494bc249eb5fdec473f6301.zip
Fix compilation problems with 2.6.19+ kernels (bug #164806).
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog6
-rw-r--r--media-gfx/splashutils/files/splashutils-1.1.9.10-types_h.patch14
-rw-r--r--media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild11
3 files changed, 25 insertions, 6 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 3c8c50e1afdb..8448d52f6fb9 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.71 2007/01/27 15:40:40 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.72 2007/02/10 14:23:37 spock Exp $
+
+ 10 Feb 2007; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-1.1.9.10-types_h.patch, splashutils-1.1.9.10-r1.ebuild:
+ Fix compilation problems with 2.6.19+ kernels (bug #164806).
27 Jan 2007; Michał Januszewski <spock@gentoo.org>
+files/splashutils-1.3-initrd-chvt.patch, splashutils-1.3-r2.ebuild,
diff --git a/media-gfx/splashutils/files/splashutils-1.1.9.10-types_h.patch b/media-gfx/splashutils/files/splashutils-1.1.9.10-types_h.patch
new file mode 100644
index 000000000000..84ab9c8e9aeb
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-1.1.9.10-types_h.patch
@@ -0,0 +1,14 @@
+diff -Naurp splashutils-1.1.9.10-orig/render.c splashutils-1.1.9.10/render.c
+--- splashutils-1.1.9.10-orig/render.c 2007-02-10 15:05:53.000000000 +0100
++++ splashutils-1.1.9.10/render.c 2007-02-10 15:06:36.000000000 +0100
+@@ -17,9 +17,9 @@
+ #undef __KERNEL__
+ #endif
+
+-#include <linux/fb.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <linux/fb.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
diff --git a/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild b/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild
index 0b7afc9e564d..4d4af9214662 100644
--- a/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild,v 1.7 2006/09/27 15:06:52 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild,v 1.8 2007/02/10 14:23:37 spock Exp $
inherit eutils multilib linux-mod
@@ -92,9 +92,10 @@ src_unpack() {
rm ${S}/libs/zlib-${V_ZLIB}/Makefile
cd ${S}
- epatch ${FILESDIR}/splashutils-1.1.9.10-ppc-2.6.14.patch
- epatch ${FILESDIR}/splashutils-1.1.9.10-makefile.patch
- epatch ${FILESDIR}/splashutils-1.1.9.10-2.6.18-vt-fix.patch
+ epatch ${FILESDIR}/${P}-ppc-2.6.14.patch
+ epatch ${FILESDIR}/${P}-makefile.patch
+ epatch ${FILESDIR}/${P}-2.6.18-vt-fix.patch
+ epatch ${FILESDIR}/${P}-types_h.patch
# Check whether the kernel tree has been patched with fbsplash.
if [[ ! -e ${KV_DIR}/include/linux/console_splash.h ]]; then