summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-04-11 16:01:15 +0000
committerMichael Januszewski <spock@gentoo.org>2008-04-11 16:01:15 +0000
commitc6e0b50485df576f2a594165944828f0aabecef0 (patch)
tree2b34c47a4440018580e5e38977abe69d41642cb9 /media-gfx/splashutils
parentbump to 2.22.2. Don't use sync IO, raise glib and nautilus deps. (diff)
downloadgentoo-2-c6e0b50485df576f2a594165944828f0aabecef0.tar.gz
gentoo-2-c6e0b50485df576f2a594165944828f0aabecef0.tar.bz2
gentoo-2-c6e0b50485df576f2a594165944828f0aabecef0.zip
Fix a potential crash in the OpenRC splash plugin. Patch by Roy Marples.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog6
-rw-r--r--media-gfx/splashutils/files/openrc-splash-crash.patch11
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4-r1.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index f6127c4c3819..5507264cbb95 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.133 2008/03/25 09:00:15 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.134 2008/04/11 16:01:15 spock Exp $
+
+ 11 Apr 2008; Michał Januszewski <spock@gentoo.org>
+ +files/openrc-splash-crash.patch, splashutils-1.5.4-r1.ebuild:
+ Fix a potential crash in the OpenRC splash plugin. Patch by Roy Marples.
25 Mar 2008; Michał Januszewski <spock@gentoo.org>
+files/openrc-strlist-abi.patch, splashutils-1.5.4-r1.ebuild:
diff --git a/media-gfx/splashutils/files/openrc-splash-crash.patch b/media-gfx/splashutils/files/openrc-splash-crash.patch
new file mode 100644
index 000000000000..36eed3b703ad
--- /dev/null
+++ b/media-gfx/splashutils/files/openrc-splash-crash.patch
@@ -0,0 +1,11 @@
+--- splash.c.orig 2008-04-10 09:31:54.000000000 +0100
++++ splash.c 2008-04-10 09:54:00.000000000 +0100
+@@ -441,6 +441,8 @@
+ if (list_has(svcs_done, name))
+ return 0;
+
++ if (!svcs_done)
++ svcs_done = rc_stringlist_new();
+ rc_stringlist_add(svcs_done, name);
+ svcs_done_cnt++;
+ }
diff --git a/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild b/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
index b9eb8a079bcb..b1357d7af2cc 100644
--- a/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild,v 1.2 2008/03/25 09:00:15 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild,v 1.3 2008/04/11 16:01:15 spock Exp $
EAPI="1"
@@ -86,6 +86,7 @@ src_unpack() {
cd "${SG}"
if has_version sys-apps/openrc ; then
epatch "${FILESDIR}"/openrc-strlist-abi.patch
+ epatch "${FILESDIR}"/openrc-splash-crash.patch
fi
}