summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-18 19:58:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-18 19:58:03 +0000
commit98166766127c678b2662e0780e8c8cf6dea1c03b (patch)
treeedc58a8a9006fd78727f3b091510bd04ce641380 /media-gfx/sam2p
parentx86 stable per bug 362773 (diff)
downloadgentoo-2-98166766127c678b2662e0780e8c8cf6dea1c03b.tar.gz
gentoo-2-98166766127c678b2662e0780e8c8cf6dea1c03b.tar.bz2
gentoo-2-98166766127c678b2662e0780e8c8cf6dea1c03b.zip
version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/sam2p')
-rw-r--r--media-gfx/sam2p/ChangeLog9
-rw-r--r--media-gfx/sam2p/sam2p-0.48.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/media-gfx/sam2p/ChangeLog b/media-gfx/sam2p/ChangeLog
index 342111f245f2..4fd59b5a4b4b 100644
--- a/media-gfx/sam2p/ChangeLog
+++ b/media-gfx/sam2p/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/sam2p
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.45 2010/10/05 20:43:00 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.46 2011/04/18 19:58:03 aballier Exp $
+
+*sam2p-0.48 (18 Apr 2011)
+
+ 18 Apr 2011; Alexis Ballier <aballier@gentoo.org> +sam2p-0.48.ebuild:
+ version bump
05 Oct 2010; Markus Meier <maekke@gentoo.org> sam2p-0.47.ebuild:
x86 stable, bug #334153
diff --git a/media-gfx/sam2p/sam2p-0.48.ebuild b/media-gfx/sam2p/sam2p-0.48.ebuild
new file mode 100644
index 000000000000..6273ce76abaa
--- /dev/null
+++ b/media-gfx/sam2p/sam2p-0.48.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.48.ebuild,v 1.1 2011/04/18 19:58:03 aballier Exp $
+
+EAPI=2
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Utility to convert raster images to EPS, PDF and many others"
+HOMEPAGE="http://code.google.com/p/sam2p/"
+SRC_URI="http://sam2p.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples gif"
+
+RDEPEND=""
+DEPEND="dev-lang/perl"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.45-fbsd.patch \
+ "${FILESDIR}"/${PN}-0.45-nostrip.patch \
+ "${FILESDIR}"/${PN}-0.45-cflags.patch
+
+ touch stdafx.h bts2.tth #315619
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CXX
+ econf \
+ --enable-lzw \
+ $(use_enable gif)
+
+ rm -f stdafx.h bts2.tth
+}
+
+src_install() {
+ dobin sam2p || die
+ dodoc README
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}