summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-03-05 18:40:18 +0000
committerAnant Narayanan <anant@gentoo.org>2007-03-05 18:40:18 +0000
commit16ea90cbf737e6b71a3fc41258250d69fc0d9802 (patch)
tree78bbd53fa52bf73bc16a9018b068a7cc812f0149 /media-gfx/povray
parentCleanup. (diff)
downloadgentoo-2-16ea90cbf737e6b71a3fc41258250d69fc0d9802.tar.gz
gentoo-2-16ea90cbf737e6b71a3fc41258250d69fc0d9802.tar.bz2
gentoo-2-16ea90cbf737e6b71a3fc41258250d69fc0d9802.zip
Add back stable ebuild. Sorry about this!
(Portage version: 2.1.2.1)
Diffstat (limited to 'media-gfx/povray')
-rw-r--r--media-gfx/povray/ChangeLog5
-rw-r--r--media-gfx/povray/files/digest-povray-3.6.1-r13
-rw-r--r--media-gfx/povray/povray-3.6.1-r1.ebuild56
3 files changed, 63 insertions, 1 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index f73ea2b3b3b1..7c837aca8c5f 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/povray
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.54 2007/03/04 18:00:33 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.55 2007/03/05 18:40:18 anant Exp $
+
+ 05 Mar 2007; <anant@gentoo.org> +povray-3.6.1-r1.ebuild:
+ Big oops, Add back stable ebuild.
*povray-3.6.1-r2 (04 Mar 2007)
diff --git a/media-gfx/povray/files/digest-povray-3.6.1-r1 b/media-gfx/povray/files/digest-povray-3.6.1-r1
new file mode 100644
index 000000000000..4de2b2aa24e4
--- /dev/null
+++ b/media-gfx/povray/files/digest-povray-3.6.1-r1
@@ -0,0 +1,3 @@
+MD5 b5789bb7eeaed0809c5c82d0efda571d povray-3.6.tar.bz2 8200160
+RMD160 84ba679da66089f192cc1bfcf8bdd498e736a9a3 povray-3.6.tar.bz2 8200160
+SHA256 4e8a7fecd44807343b6867e1f2440aa0e09613d6d69a7385ac48f4e5e7737a73 povray-3.6.tar.bz2 8200160
diff --git a/media-gfx/povray/povray-3.6.1-r1.ebuild b/media-gfx/povray/povray-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..d066502584f5
--- /dev/null
+++ b/media-gfx/povray/povray-3.6.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.6.1-r1.ebuild,v 1.19 2007/03/05 18:40:18 anant Exp $
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="The Persistence Of Vision Ray Tracer"
+SRC_URI="ftp://ftp.povray.org/pub/povray/Official/Unix/povray-3.6.tar.bz2"
+HOMEPAGE="http://www.povray.org/"
+
+SLOT="0"
+LICENSE="povlegal-3.6"
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="X svga"
+
+DEPEND="media-libs/libpng
+ >=media-libs/tiff-3.6.1
+ media-libs/jpeg
+ sys-libs/zlib
+ X? ( || ( x11-libs/libXaw virtual/x11 ) )
+ svga? ( media-libs/svgalib )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoconf
+}
+
+src_compile() {
+ local myconf
+
+ # closes bug 71255
+ if get-flag march == k6-2 ; then
+ filter-flags -fomit-frame-pointer
+ fi
+
+ use X && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"\
+ CFLAGS="${CFLAGS} -DX_DISPLAY_MISSING"
+ use svga || myconf="${myconf} --without-svga"
+
+ econf COMPILED_BY="${USER} (on `uname -n`)" ${myconf} || die
+
+ # Copy the user configuration into /etc/skel
+ cp Makefile Makefile.orig
+ sed -e "s:^povconfuser = .*:povconfuser = ${D}etc/skel/.povray/3.6/:" Makefile.orig >Makefile
+
+ einfo Building povray
+ emake || die "build failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+}