summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-24 08:38:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-24 08:38:26 +0000
commitb50841dcbdfc8fff6dad04b13f10022ef57fe57b (patch)
tree6e7e22efd500afab37855935d2e52bfa368b4128 /media-gfx/picturewall
parentStable on amd64 wrt bug #324813 (diff)
downloadgentoo-2-b50841dcbdfc8fff6dad04b13f10022ef57fe57b.tar.gz
gentoo-2-b50841dcbdfc8fff6dad04b13f10022ef57fe57b.tar.bz2
gentoo-2-b50841dcbdfc8fff6dad04b13f10022ef57fe57b.zip
Add menu entry to fix bug #322693
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/picturewall')
-rw-r--r--media-gfx/picturewall/ChangeLog8
-rw-r--r--media-gfx/picturewall/picturewall-1.0-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/media-gfx/picturewall/ChangeLog b/media-gfx/picturewall/ChangeLog
index 2a129038152d..aca51b258021 100644
--- a/media-gfx/picturewall/ChangeLog
+++ b/media-gfx/picturewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/picturewall
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/ChangeLog,v 1.1 2010/05/04 19:55:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/ChangeLog,v 1.2 2010/06/24 08:38:26 hwoarang Exp $
+
+*picturewall-1.0-r1 (24 Jun 2010)
+
+ 24 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +picturewall-1.0-r1.ebuild:
+ Add menu entry to fix bug #322693
*picturewall-1.0 (04 May 2010)
diff --git a/media-gfx/picturewall/picturewall-1.0-r1.ebuild b/media-gfx/picturewall/picturewall-1.0-r1.ebuild
new file mode 100644
index 000000000000..48967a266f35
--- /dev/null
+++ b/media-gfx/picturewall/picturewall-1.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/picturewall-1.0-r1.ebuild,v 1.1 2010/06/24 08:38:26 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+MY_PN="PictureWall"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Qt4 picture viewer and image searching tool using google.com"
+HOMEPAGE="http://www.qt-apps.org/content/show.php?content=106101"
+SRC_URI="http://picturewall.googlecode.com/files/PictureWall_1.0.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/qt-gui-4.5.3"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}/${MY_PN}"
+
+src_install(){
+ dobin bin/${PN} || die "dobin failed"
+ dodoc ReadMe || die "dodoc failed"
+ dohtml -r doc/html/* || die "dohtml failed"
+ make_desktop_entry ${PN} ${MY_PN} || die "make_desktop_entry failed"
+}