summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-01-14 17:53:11 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-01-14 17:53:11 +0000
commit73f69e0fba912b11810902b5131ad10daaa2bd22 (patch)
treef07faf2fb95177682fb50f144fc9d6a4fbdbd7c0 /media-gfx/mandelbulber
parentx86 stable, bug #393007 (diff)
downloadgentoo-2-73f69e0fba912b11810902b5131ad10daaa2bd22.tar.gz
gentoo-2-73f69e0fba912b11810902b5131ad10daaa2bd22.tar.bz2
gentoo-2-73f69e0fba912b11810902b5131ad10daaa2bd22.zip
Version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/mandelbulber')
-rw-r--r--media-gfx/mandelbulber/ChangeLog10
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.10-qa.patch40
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.10.ebuild47
3 files changed, 95 insertions, 2 deletions
diff --git a/media-gfx/mandelbulber/ChangeLog b/media-gfx/mandelbulber/ChangeLog
index 900a54c8dd5d..c0f05dc734ae 100644
--- a/media-gfx/mandelbulber/ChangeLog
+++ b/media-gfx/mandelbulber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/mandelbulber
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/ChangeLog,v 1.5 2011/09/04 10:45:04 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/ChangeLog,v 1.6 2012/01/14 17:53:11 xarthisius Exp $
+
+*mandelbulber-1.10 (14 Jan 2012)
+
+ 14 Jan 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/mandelbulber-1.10-qa.patch, +mandelbulber-1.10.ebuild:
+ Version bump
*mandelbulber-1.08 (04 Sep 2011)
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.10-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.10-qa.patch
new file mode 100644
index 000000000000..036d24539e9c
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.10-qa.patch
@@ -0,0 +1,40 @@
+Respect CXX,CXXFLAGS, fix linking order
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+--- a/makefiles/src/subdir.mk
++++ b/makefiles/src/subdir.mk
+@@ -63,12 +63,14 @@
+ ./src/undo.d \
+ ./src/cl_support.d
+
++CXX ?= g++
++CXXFLAGS ?= -O2 -ffast-math
+
+ # Each subdirectory must supply rules for building sources it contributes
+ src/%.o: ../src/%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
++ $(CXX) $(CXXFLAGS) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
+--- a/makefiles/makefile
++++ b/makefiles/makefile
+@@ -5,6 +5,7 @@
+ -include ../makefile.init
+
+ RM := rm -rf
++CXX ?= g++
+
+ # All of the sources participating in the build are defined here
+ -include sources.mk
+@@ -44,7 +45,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ -L/usr/lib/x86_64-linux-gnu/ `pkg-config --libs gtk+-2.0 gthread-2.0` -o"mandelbulber"$(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o"mandelbulber" $(OBJS) $(USER_OBJS) `pkg-config --libs gtk+-2.0 gthread-2.0` $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
diff --git a/media-gfx/mandelbulber/mandelbulber-1.10.ebuild b/media-gfx/mandelbulber/mandelbulber-1.10.ebuild
new file mode 100644
index 000000000000..c41737183bc6
--- /dev/null
+++ b/media-gfx/mandelbulber/mandelbulber-1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/mandelbulber-1.10.ebuild,v 1.1 2012/01/14 17:53:11 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}${PV}
+
+DESCRIPTION="Tool to render 3D fractals"
+HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=media-libs/libsndfile-1
+ >=media-libs/libpng-1.4
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # https://sourceforge.net/tracker/?func=detail&aid=3368617&group_id=303080&atid=1277701
+ epatch "${FILESDIR}"/${P}-qa.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" -C makefiles all
+}
+
+src_install() {
+ dobin makefiles/${PN}
+ dodoc README NEWS
+ insinto /usr/share/${PN}
+ doins -r usr/share/*
+}
+
+pkg_postinst() {
+ elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
+}