summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-25 17:26:05 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-25 17:26:05 +0000
commitf80ca97c605b78a23fed83d899b67be835b1f87c (patch)
tree72a5168159413f783c7418060070e2631ac19ed3 /media-gfx/jhead
parentAdd ruby19 with patch provided by Rafał Mużyło in bug 423445. (diff)
downloadgentoo-2-f80ca97c605b78a23fed83d899b67be835b1f87c.tar.gz
gentoo-2-f80ca97c605b78a23fed83d899b67be835b1f87c.tar.bz2
gentoo-2-f80ca97c605b78a23fed83d899b67be835b1f87c.zip
Version bump.
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/ChangeLog7
-rw-r--r--media-gfx/jhead/jhead-2.96.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/media-gfx/jhead/ChangeLog b/media-gfx/jhead/ChangeLog
index 2b744d24bd6d..07db804b6126 100644
--- a/media-gfx/jhead/ChangeLog
+++ b/media-gfx/jhead/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/jhead
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.130 2012/06/14 15:20:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.131 2012/06/25 17:26:05 radhermit Exp $
+
+*jhead-2.96 (25 Jun 2012)
+
+ 25 Jun 2012; Tim Harder <radhermit@gentoo.org> +jhead-2.96.ebuild:
+ Version bump.
14 Jun 2012; Jeroen Roovers <jer@gentoo.org> jhead-2.95.ebuild:
Stable for HPPA (bug #419067).
diff --git a/media-gfx/jhead/jhead-2.96.ebuild b/media-gfx/jhead/jhead-2.96.ebuild
new file mode 100644
index 000000000000..550388b9f289
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.96.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.96.ebuild,v 1.1 2012/06/25 17:26:05 radhermit Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ epatch "${FILESDIR}"/${PN}-2.90-mkstemp_respect_flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}