summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2011-02-12 16:48:33 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2011-02-12 16:48:33 +0000
commita9a658cfdf51909391b71569cd5531fcc358e902 (patch)
treeb347cee273438d95bd446d7bcb1f8a5230c5bb76 /media-gfx/jhead
parentalpha/ia64/s390/sh/sparc stable wrt #344827 (diff)
downloadgentoo-2-a9a658cfdf51909391b71569cd5531fcc358e902.tar.gz
gentoo-2-a9a658cfdf51909391b71569cd5531fcc358e902.tar.bz2
gentoo-2-a9a658cfdf51909391b71569cd5531fcc358e902.zip
2.90 version bump.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/ChangeLog10
-rw-r--r--media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch26
-rw-r--r--media-gfx/jhead/jhead-2.90.ebuild33
3 files changed, 67 insertions, 2 deletions
diff --git a/media-gfx/jhead/ChangeLog b/media-gfx/jhead/ChangeLog
index c427067427be..6f0a3d77d63e 100644
--- a/media-gfx/jhead/ChangeLog
+++ b/media-gfx/jhead/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/jhead
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.110 2010/01/07 22:10:36 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.111 2011/02/12 16:48:33 vanquirius Exp $
+
+*jhead-2.90 (12 Feb 2011)
+
+ 12 Feb 2011; Marcelo Goes <vanquirius@gentoo.org> +jhead-2.90.ebuild,
+ +files/jhead-2.90-mkstemp_respect_flags.patch:
+ 2.90 version bump.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org> jhead-2.87.ebuild:
Transfer Prefix keywords
diff --git a/media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch b/media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch
new file mode 100644
index 000000000000..f09214b9f3d6
--- /dev/null
+++ b/media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch
@@ -0,0 +1,26 @@
+diff --exclude='*~' -Naur -Naur jhead-2.90.orig/jhead.c jhead-2.90/jhead.c
+--- jhead-2.90.orig/jhead.c 2011-02-12 14:36:47.000000000 -0200
++++ jhead-2.90/jhead.c 2011-02-12 14:39:28.000000000 -0200
+@@ -358,7 +358,7 @@
+ // as mktemp - that is, that between getting the random name, and making the file
+ // some other program could snatch that exact same name!
+ // also, not all pltforms support mkstemp.
+- mktemp(TempName);
++ mkstemp(TempName);
+
+
+ if(!TempName[0]) {
+diff --exclude='*~' -Naur -Naur jhead-2.90.orig/makefile jhead-2.90/makefile
+--- jhead-2.90.orig/makefile 2011-02-12 14:36:47.000000000 -0200
++++ jhead-2.90/makefile 2011-02-12 14:40:50.000000000 -0200
+@@ -13,8 +13,9 @@
+ $(OBJ)/%.o:$(SRC)/%.c
+ ${CC} $(CFLAGS) -c $< -o $@
+
++
+ jhead: $(objs) jhead.h
+- ${CC} -o jhead $(objs) -lm
++ ${CC} ${LDFLAGS} -o jhead $(objs) -lm
+
+ clean:
+ rm -f $(objs) jhead
diff --git a/media-gfx/jhead/jhead-2.90.ebuild b/media-gfx/jhead/jhead-2.90.ebuild
new file mode 100644
index 000000000000..e84930092a95
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.90.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.90.ebuild,v 1.1 2011/02/12 16:48:33 vanquirius Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_unpack() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-${PV}-mkstemp_respect_flags.patch
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}