summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-01-15 21:30:23 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-01-15 21:30:23 +0000
commitaf71db3c537f4f544c98bb37159007324b8557ca (patch)
treeb72ab43f20b81c58ad348bb31f8935faa40a221a /media-gfx/hugin
parentStable on amd64. (diff)
downloadgentoo-2-af71db3c537f4f544c98bb37159007324b8557ca.tar.gz
gentoo-2-af71db3c537f4f544c98bb37159007324b8557ca.tar.bz2
gentoo-2-af71db3c537f4f544c98bb37159007324b8557ca.zip
Add dep on enblend, and also add patch to fix compilation with gcc-4.1
(paludis 0.1.0 svn 68:104M)
Diffstat (limited to 'media-gfx/hugin')
-rw-r--r--media-gfx/hugin/ChangeLog8
-rw-r--r--media-gfx/hugin/Manifest13
-rw-r--r--media-gfx/hugin/files/hugin-0.5-gcc41.patch40
-rw-r--r--media-gfx/hugin/hugin-0.5.ebuild9
4 files changed, 54 insertions, 16 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index 189ab5806b22..2db0b16cdf3e 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/hugin
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.9 2005/12/18 07:27:21 halcy0n Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.10 2006/01/15 21:30:23 halcy0n Exp $
+
+ 15 Jan 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/hugin-0.5-gcc41.patch, hugin-0.5.ebuild:
+ Add dep on enblend, and also add patch to fix compilation with gcc-4.1
*hugin-0.5 (18 Dec 2005)
diff --git a/media-gfx/hugin/Manifest b/media-gfx/hugin/Manifest
index 3bc6150e085d..935716192419 100644
--- a/media-gfx/hugin/Manifest
+++ b/media-gfx/hugin/Manifest
@@ -1,17 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 5d441ea5beb7ab6d3aafc4b95c78c126 ChangeLog 1601
MD5 4c6cac29aa5eaec6ae74cbd9988a61d9 files/digest-hugin-0.5 62
MD5 549db5b9b4146eb8aff8a35d39eabf1e files/digest-hugin-0.5_rc1-r2 67
+MD5 b8fcbff3c90dbf2257a5414317c33d32 files/hugin-0.5-gcc41.patch 1667
MD5 6cf4d590cbb78ac98c424c8d58d1cc4f files/hugin-0.5_rc2-gcc4.patch 1356
-MD5 0970e5fc1e465125afee313f4d22683c hugin-0.5.ebuild 1417
+MD5 5754a1fdff072cafce28d366705f3e8d hugin-0.5.ebuild 1457
MD5 497db1fa2082827dd88807dffec1fe22 hugin-0.5_rc1-r2.ebuild 1483
MD5 958a93f482686868d880a8b448d0899d metadata.xml 324
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDpQ9jCRZPokWLroQRAo11AJwNaY+OTtykkoE6cHDkto+Kb7RevACgssI8
-RZuFC4HnJRy2eCRSUIXYptg=
-=V8Oy
------END PGP SIGNATURE-----
diff --git a/media-gfx/hugin/files/hugin-0.5-gcc41.patch b/media-gfx/hugin/files/hugin-0.5-gcc41.patch
new file mode 100644
index 000000000000..b176bd28c5ba
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-0.5-gcc41.patch
@@ -0,0 +1,40 @@
+diff -ur hugin-0.5-orig/src/include/PT/Panorama.h hugin-0.5/src/include/PT/Panorama.h
+--- hugin-0.5-orig/src/include/PT/Panorama.h 2005-12-26 21:35:42.000000000 -0500
++++ hugin-0.5/src/include/PT/Panorama.h 2005-12-26 21:36:14.000000000 -0500
+@@ -542,7 +542,7 @@
+ *
+ * only copies inherited variables
+ */
+- void Panorama::updateLensToImages(unsigned int lensNr);
++ void updateLensToImages(unsigned int lensNr);
+
+ /** copy lens variables to image variables.
+ * update all images that use lensNr
+diff -ur hugin-0.5-orig/src/include/PT/PanoramaMemento.h hugin-0.5/src/include/PT/PanoramaMemento.h
+--- hugin-0.5-orig/src/include/PT/PanoramaMemento.h 2005-12-26 21:35:57.000000000 -0500
++++ hugin-0.5/src/include/PT/PanoramaMemento.h 2005-12-26 21:34:00.000000000 -0500
+@@ -154,7 +154,7 @@
+ double getHFOV() const;
+
+ /** set HFOV in degrees */
+- void Lens::setHFOV(double d);
++ void setHFOV(double d);
+
+ /** get focal length of lens, it is calculated from the HFOV */
+ double getFocalLength() const;
+@@ -389,13 +389,13 @@
+ void printScriptLine(std::ostream & o) const;
+
+ /// return string name of output file format
+- static const std::string & PanoramaOptions::getFormatName(FileFormat f);
++ static const std::string & getFormatName(FileFormat f);
+
+ /** returns the FileFormat corrosponding to name.
+ *
+ * if name is not recognized, FileFormat::TIFF is returned
+ */
+- static FileFormat PanoramaOptions::getFormatFromName(const std::string & name);
++ static FileFormat getFormatFromName(const std::string & name);
+
+ /** calculate height of the output panorama
+ *
diff --git a/media-gfx/hugin/hugin-0.5.ebuild b/media-gfx/hugin/hugin-0.5.ebuild
index 1001d10e371f..c3f356945930 100644
--- a/media-gfx/hugin/hugin-0.5.ebuild
+++ b/media-gfx/hugin/hugin-0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.5.ebuild,v 1.1 2005/12/18 07:27:21 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.5.ebuild,v 1.2 2006/01/15 21:30:23 halcy0n Exp $
inherit wxwidgets eutils
@@ -18,11 +18,14 @@ DEPEND=">=media-libs/libpano12-2.7.0.8
sys-libs/zlib
media-libs/libpng
media-libs/jpeg
- media-libs/tiff"
+ media-libs/tiff
+ media-gfx/enblend"
src_unpack() {
unpack ${A}
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+
sed -i -e 's/autopanog\.exe/autopanog/' "${S}"/src/include/hugin/config_defaults.h
}