summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-12-12 23:02:19 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-12-12 23:02:19 +0000
commit7a112f8457c2a445b000cd5575f385c3bf61db5a (patch)
treefa107f851f630108b4292cff06a815f56b8123e4 /media-gfx/gthumb
parentibiblio KDE mirror is broken atm (diff)
downloadgentoo-2-7a112f8457c2a445b000cd5575f385c3bf61db5a.tar.gz
gentoo-2-7a112f8457c2a445b000cd5575f385c3bf61db5a.tar.bz2
gentoo-2-7a112f8457c2a445b000cd5575f385c3bf61db5a.zip
Version bump. Fix some infinite loop, crashes and memory leaks. Translation updates.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/gthumb')
-rw-r--r--media-gfx/gthumb/ChangeLog8
-rw-r--r--media-gfx/gthumb/gthumb-2.14.1.ebuild84
2 files changed, 91 insertions, 1 deletions
diff --git a/media-gfx/gthumb/ChangeLog b/media-gfx/gthumb/ChangeLog
index d5e95c9d5df7..2f191ff49f29 100644
--- a/media-gfx/gthumb/ChangeLog
+++ b/media-gfx/gthumb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/gthumb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gthumb/ChangeLog,v 1.136 2011/10/27 16:28:05 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gthumb/ChangeLog,v 1.137 2011/12/12 23:02:19 eva Exp $
+
+*gthumb-2.14.1 (12 Dec 2011)
+
+ 12 Dec 2011; Gilles Dartiguelongue <eva@gentoo.org> +gthumb-2.14.1.ebuild:
+ Version bump. Fix some infinite loop, crashes and memory leaks. Translation
+ updates.
27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
gthumb-2.12.3.ebuild, gthumb-2.12.4.ebuild, gthumb-2.14.0.ebuild:
diff --git a/media-gfx/gthumb/gthumb-2.14.1.ebuild b/media-gfx/gthumb/gthumb-2.14.1.ebuild
new file mode 100644
index 000000000000..cec21cee2992
--- /dev/null
+++ b/media-gfx/gthumb/gthumb-2.14.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gthumb/gthumb-2.14.1.ebuild,v 1.1 2011/12/12 23:02:19 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Image viewer and browser for Gnome"
+HOMEPAGE="https://live.gnome.org/gthumb"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="cdr exif gnome-keyring gstreamer http raw slideshow tiff test"
+
+# We can't link against libbrasero-burn3
+RDEPEND=">=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-2.24.0:2
+ >=gnome-base/gconf-2.6
+ >=dev-libs/libunique-1.1.2:1
+
+ media-libs/libpng:0
+ virtual/jpeg:0
+ x11-libs/libSM
+
+ cdr? ( >=app-cdr/brasero-2.28
+ <app-cdr/brasero-2.90 )
+ exif? ( >=media-gfx/exiv2-0.18 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.28 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10 )
+ http? (
+ >=net-libs/libsoup-2.26:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4 )
+ slideshow? (
+ >=media-libs/clutter-1:1.0
+ >=media-libs/clutter-gtk-0.10:0.10 )
+ tiff? ( media-libs/tiff )
+ raw? ( >=media-libs/libopenraw-0.0.8 )
+ !raw? ( media-gfx/dcraw )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35
+ app-text/gnome-doc-utils
+ sys-devel/bison
+ sys-devel/flex
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+# Upstream says in configure help that libchamplain support crashes
+# frequently
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-libchamplain
+ --enable-unique
+ --disable-gnome-3
+ $(use_enable cdr libbrasero)
+ $(use_enable exif exiv2)
+ $(use_enable gstreamer)
+ $(use_enable gnome-keyring)
+ $(use_enable http libsoup)
+ $(use_enable raw libopenraw)
+ $(use_enable slideshow clutter)
+ $(use_enable test test-suite)
+ $(use_enable tiff)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove unwanted CFLAGS added with USE=debug
+ sed -e 's/CFLAGS="$CFLAGS -g -O0 -DDEBUG"//' -i configure.ac -i configure || die
+
+ # GSeal doesn't get disabled with --disable-gseal
+ sed -e 's/-DGSEAL_ENABLE//g' -i configure.ac -i configure || die
+}