summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-01-15 00:54:28 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-01-15 00:54:28 +0000
commit00f2146470bd1adf85adafa9e62dd65690e7db72 (patch)
tree8ec4d428ce28077e06ca1bce0ffad4dc4f5aaa6d /media-gfx/graphviz
parentadd MIPS patches; fix locale issue, bug #13240 (diff)
downloadgentoo-2-00f2146470bd1adf85adafa9e62dd65690e7db72.tar.gz
gentoo-2-00f2146470bd1adf85adafa9e62dd65690e7db72.tar.bz2
gentoo-2-00f2146470bd1adf85adafa9e62dd65690e7db72.zip
updated ebuild following up on seemant's libpng-1.0 series fix. Now has png support lined in correctly.
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog9
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.8.10-r21
-rw-r--r--media-gfx/graphviz/graphviz-1.8.10-r2.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index 8232acec3534..b4e4a69ff029 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/graphviz
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.5 2002/12/04 22:15:51 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.6 2003/01/15 00:54:28 george Exp $
+
+*graphviz-1.8.10-r1 (14 Jan 2003)
+
+ 14 jan 2003; George Shapovalov <george@gentoo.org> graphviz-1.8.10-r1.ebuild :
+
+ Following up on seemant's fix to libpng-1.0 series upated the graphviz ebuild to link against correct
+ version of libpng. Please see #10726 for more details.
*graphviz-1.8.10-r1 (10 Nov 2002)
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.8.10-r2 b/media-gfx/graphviz/files/digest-graphviz-1.8.10-r2
new file mode 100644
index 000000000000..83e5bdee4202
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.8.10-r2
@@ -0,0 +1 @@
+MD5 7c9663c8e2cde4f7edc2b412cc148330 graphviz-1.8.10.tar.gz 2837389
diff --git a/media-gfx/graphviz/graphviz-1.8.10-r2.ebuild b/media-gfx/graphviz/graphviz-1.8.10-r2.ebuild
new file mode 100644
index 000000000000..fb63bce84c55
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.8.10-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.8.10-r2.ebuild,v 1.1 2003/01/15 00:54:28 george Exp $
+
+IUSE="tcltk"
+
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.graphviz.org/pub/graphviz/${P}.tar.gz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+SLOT="0"
+LICENSE="as-is | ATT"
+KEYWORDS="~x86 ~ppc"
+
+#Can use freetype-1.3 or 2.0, but not both
+#!!!requires libpng-1.0.x!!!
+DEPEND=">=sys-libs/zlib-1.1.3
+ =media-libs/libpng-1.0*
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( =dev-lang/tk-8.3* )"
+
+src_compile() {
+ local myconf
+ #if no tcltk, this will generate configure warnings, but will
+ #compile without tcltk support
+ use tcltk || myconf="${myconf} --without-tcl --without-tk"
+
+ #libpng-1.0 got tweaked to nicely coexist with libpng-1.2
+ #need to set correct path to the .h's and libs
+ econf ${myconf} \
+ --with-pngincludedir=/usr/include/libpng10/ \
+ --with-pnglibdir=/usr/lib/ || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ dohtml -r .
+ dodoc doc/*.pdf
+}