summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-29 10:14:59 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-29 10:14:59 +0000
commit1c47c37583dd2626f9c9acdfeeb5d63ffd58ce67 (patch)
tree0b71c5ea80ed0d3f6294945c7cb068f948d41891 /media-gfx/graphite2/files/graphite2-fix-nostdlib.patch
parentUse lrdf.pc to gain -I/usr/include/raptor2 (lrdf.h -> raptor.h) (diff)
downloadgentoo-2-1c47c37583dd2626f9c9acdfeeb5d63ffd58ce67.tar.gz
gentoo-2-1c47c37583dd2626f9c9acdfeeb5d63ffd58ce67.tar.bz2
gentoo-2-1c47c37583dd2626f9c9acdfeeb5d63ffd58ce67.zip
Fix nostdlibs typo correctly everywhere, fixes part of the bug #376799.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/graphite2/files/graphite2-fix-nostdlib.patch')
-rw-r--r--media-gfx/graphite2/files/graphite2-fix-nostdlib.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/graphite2/files/graphite2-fix-nostdlib.patch b/media-gfx/graphite2/files/graphite2-fix-nostdlib.patch
new file mode 100644
index 000000000000..7b7c80b47b64
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-fix-nostdlib.patch
@@ -0,0 +1,29 @@
+diff --git a/gr2fonttest/CMakeLists.txt b/gr2fonttest/CMakeLists.txt
+index 4e11217..89f97e4 100644
+--- a/gr2fonttest/CMakeLists.txt
++++ b/gr2fonttest/CMakeLists.txt
+@@ -45,7 +45,7 @@ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+ if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ # -lgcc LINKER_LANGUAGE C
+ add_definitions(-fno-rtti -fno-exceptions)
+- set_target_properties(gr2fonttest PROPERTIES LINK_FLAGS "-nostdlibs -nodefaultlibs" )
++ set_target_properties(gr2fonttest PROPERTIES LINK_FLAGS "-nostdlib -nodefaultlibs" )
+ set(CMAKE_CXX_IMPLICIT_LINK_LIBRARIES "")
+ # This script just fails
+ nolib_test(stdc++ $<TARGET_FILE:gr2fonttest>)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 9c31e35..775a83b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -164,9 +164,9 @@ set_target_properties(graphite2 PROPERTIES LT_VERSION_AGE ${GRAPHITE_API_AGE})
+ if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ add_definitions(-Wall -Wno-unknown-pragmas -Wparentheses -Wextra -Wendif-labels
+ -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fdiagnostics-show-option
+- -fno-rtti -fno-exceptions -nodefaultlibs -nostdlibs
++ -fno-rtti -fno-exceptions -nodefaultlibs -nostdlib
+ -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector)
+- set_target_properties(graphite2 PROPERTIES LINK_FLAGS "-nostdlibs -nodefaultlibs" LINKER_LANGUAGE C)
++ set_target_properties(graphite2 PROPERTIES LINK_FLAGS "-nostdlib -nodefaultlibs" LINKER_LANGUAGE C)
+ if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ target_link_libraries(graphite2 "-lkernel32 -lmsvcr90 -lmingw32 -lgcc -luser32")
+ else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")