summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-26 00:28:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-26 00:28:16 +0000
commit0901d694c404f51ebf8865166a796d1fad1ab1c0 (patch)
tree84ee7d6017d64315fe90d1ab6f4516ddbe4a0217 /media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild
parentdont use old WANT_AUTOCONF #35111 (diff)
downloadgentoo-2-0901d694c404f51ebf8865166a796d1fad1ab1c0.tar.gz
gentoo-2-0901d694c404f51ebf8865166a796d1fad1ab1c0.tar.bz2
gentoo-2-0901d694c404f51ebf8865166a796d1fad1ab1c0.zip
dont use old WANT_AUTOCONF #35111
Diffstat (limited to 'media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild')
-rw-r--r--media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild b/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild
index eb7637585199..5005eb8fab00 100644
--- a/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild
+++ b/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild,v 1.14 2003/12/12 15:54:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0-r5.ebuild,v 1.15 2004/01/26 00:28:16 vapier Exp $
+
+inherit flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Edits icons, what more can you say?"
HOMEPAGE="http://www.advogato.org/proj/GNOME-Iconedit/"
SRC_URI="http://210.77.60.218/ftp/ftp.debian.org/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc ~amd64"
DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
@@ -30,27 +31,23 @@ src_unpack() {
epatch ${FILESDIR}/gnome-iconedit.diff
# Update the Makefiles.
- export WANT_AUTOMAKE_1_4=1
- export WANT_AUTOCONF_2_1=1
+ export WANT_AUTOMAKE=1.4
+ export WANT_AUTOCONF=2.1
automake --add-missing
autoconf
}
src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
-
- CFLAGS="${CFLAGS} `gnome-config --cflags print` -I/usr/include/gdk-pixbuf-1.0"
-
+ append-flags `gnome-config --cflags print` -I/usr/include/gdk-pixbuf-1.0
econf \
--without-gnome-print \
- ${myconf} || die
+ `use_enable nls` \
+ || die
emake || die
}
src_install() {
einstall || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}