summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-03-14 13:45:19 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-03-14 13:45:19 +0000
commit443f8817eac2cd726f04913d94a1e3eb5a141ffe (patch)
treee9be56156d8536d44109535504bbd87d4ef6a28b /media-gfx/freewrl
parentCreate the history directory in /var at runtime. Fix segmentation fault. Sinc... (diff)
downloadgentoo-2-443f8817eac2cd726f04913d94a1e3eb5a141ffe.tar.gz
gentoo-2-443f8817eac2cd726f04913d94a1e3eb5a141ffe.tar.bz2
gentoo-2-443f8817eac2cd726f04913d94a1e3eb5a141ffe.zip
more java build fixes; remove old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-gfx/freewrl')
-rw-r--r--media-gfx/freewrl/ChangeLog7
-rw-r--r--media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch54
-rw-r--r--media-gfx/freewrl/freewrl-1.22.13-r1.ebuild140
-rw-r--r--media-gfx/freewrl/freewrl-1.22.13-r3.ebuild9
-rw-r--r--media-gfx/freewrl/freewrl-9999.ebuild6
5 files changed, 68 insertions, 148 deletions
diff --git a/media-gfx/freewrl/ChangeLog b/media-gfx/freewrl/ChangeLog
index 3af3c47c9d6f..391513d0796c 100644
--- a/media-gfx/freewrl/ChangeLog
+++ b/media-gfx/freewrl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/freewrl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.54 2014/03/12 14:24:13 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.55 2014/03/14 13:45:19 axs Exp $
+
+ 14 Mar 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/freewrl-1.22.13-java-fix.patch, -freewrl-1.22.13-r1.ebuild,
+ freewrl-1.22.13-r3.ebuild, freewrl-9999.ebuild:
+ more java build fixes; remove old
12 Mar 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
freewrl-1.22.13-r1.ebuild, freewrl-1.22.13-r3.ebuild, freewrl-9999.ebuild:
diff --git a/media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch b/media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch
new file mode 100644
index 000000000000..882062cb7e10
--- /dev/null
+++ b/media-gfx/freewrl/files/freewrl-1.22.13-java-fix.patch
@@ -0,0 +1,54 @@
+--- a/src/java/Makefile.sources
++++ b/src/java/Makefile.sources
+@@ -1,4 +1,4 @@
+-dist_noinst_JAVA = \
++noinst_JAVA = \
+ org/web3d/x3d/sai/Browser.java \
+ org/web3d/x3d/sai/BrowserEvent.java \
+ org/web3d/x3d/sai/BrowserFactoryImpl.java \
+@@ -309,6 +309,7 @@ noinst_JAVA = \
+ vrml/InvalidFieldException.java \
+ vrml/InvalidRouteException.java \
+ vrml/InvalidVRMLSyntaxException.java \
++ vrml/InvalidX3DSyntaxException.java \
+ vrml/MField.java \
+ vrml/field/ConstMFColor.java \
+ vrml/field/ConstMFFloat.java \
+--- /dev/null
++++ b/src/java/vrml/InvalidX3DSyntaxException.java
+@@ -0,0 +1,6 @@
++package vrml;
++
++public class InvalidX3DSyntaxException extends Exception {
++ public InvalidX3DSyntaxException() { super(); }
++ public InvalidX3DSyntaxException(String s) { super(s); }
++}
+--- a/src/java/Makefile.am 2014-03-10 10:37:09.000000000 -0400
++++ b/src/java/Makefile.am 2014-03-12 12:29:42.000000000 -0400
+@@ -1,5 +1,10 @@
+ # Java Classes for EAI/SAI/etc.
+
++# NOTE - automake-1.11.6 changed how class*.stamp is generated, now need
++# to use noinst_JAVA and EXTRA_DIST instead of dist_noinst_JAVA to
++# keep behaviour consistent and compatible with both automake-1.11.6 and
++# older automake
++
+ # Get global variables for Makefile defined by toplevel Makefile.globals
+ include $(top_srcdir)/Makefile.globals
+
+@@ -9,11 +14,12 @@
+ jarfile = vrml.jar
+ jardir = $(JAVA_DIR)
+
+-$(jarfile): $(dist_noinst_JAVA) classdist_noinst.stamp
+- $(JAR) cmf $(JAVAROOT)/manifest.extras $@ -C $(JAVAROOT) $$(echo $(dist_noinst_JAVA:.java=.class))
++$(jarfile): $(noinst_JAVA) manifest.extras classnoinst.stamp
++ $(JAR) cmf $(JAVAROOT)/manifest.extras $@ -C $(JAVAROOT) $$(echo $(noinst_JAVA:.java=.class))
+
+ jar_DATA = $(jarfile)
+
+-CLEANFILES = $(jarfile) $$(echo $(dist_noinst_JAVA:.java=.class))
++CLEANFILES = $(jarfile) $$(echo $(noinst_JAVA:.java=.class))
++EXTRA_DIST = $(noinst_JAVA) java.policy manifest.extras
+
+ include Makefile.sources
diff --git a/media-gfx/freewrl/freewrl-1.22.13-r1.ebuild b/media-gfx/freewrl/freewrl-1.22.13-r1.ebuild
deleted file mode 100644
index 31493c559590..000000000000
--- a/media-gfx/freewrl/freewrl-1.22.13-r1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-1.22.13-r1.ebuild,v 1.5 2014/03/12 14:24:13 axs Exp $
-
-EAPI=4
-
-inherit autotools nsplugins eutils flag-o-matic java-pkg-opt-2 multilib
-
-DESCRIPTION="VRML97 and X3D compliant browser, library, and web-browser plugin"
-HOMEPAGE="http://freewrl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/freewrl/${P}.1.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="curl debug +glew java libeai motif +nsplugin osc +sox static-libs"
-
-COMMONDEPEND="x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libX11
- motif? ( x11-libs/motif )
- !motif? ( x11-libs/libXaw )
- media-libs/mesa
- glew? ( media-libs/glew )
- virtual/opengl
- media-libs/libpng
- virtual/jpeg
- media-libs/imlib2
- >=media-libs/freetype-2
- media-libs/fontconfig
- curl? ( net-misc/curl )
- osc? ( media-libs/liblo )
- dev-lang/spidermonkey:0"
-DEPEND="${COMMONDEPEND}
- virtual/pkgconfig
- java? ( >=virtual/jdk-1.4 )
- nsplugin? ( net-misc/npapi-sdk )"
-RDEPEND="${COMMONDEPEND}
- media-fonts/dejavu
- || ( media-gfx/imagemagick
- media-gfx/graphicsmagick[imagemagick] )
- app-arch/unzip
- java? ( >=virtual/jre-1.4 )
- sox? ( media-sound/sox )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fontconfig-match.patch
- if has_version ">=dev-lang/spidermonkey-1.8.7" ; then
- epatch "${FILESDIR}"/${P}-mozjs187-config.patch
- eautoreconf
- fi
-}
-
-src_configure() {
- local myconf="--enable-fontconfig
- --without-expat
- --with-x
- --with-imageconvert=/usr/bin/convert
- --with-unzip=/usr/bin/unzip"
- if use motif; then
- myconf+=" --with-target=motif --with-statusbar=standard"
- else
- myconf+=" --with-target=x11 --with-statusbar=hud"
- fi
- if use nsplugin; then
- myconf+=" --with-plugindir=/usr/$(get_libdir)/${PLUGINS_DIR}"
- myconf+=" --disable-mozilla-plugin --disable-xulrunner-plugin"
- fi
- if use sox; then
- myconf+=" --with-soundconv=/usr/bin/sox"
- fi
- # disable the checks for other js libs, in case they are installed
- if has_version ">=dev-lang/spidermonkey-1.8.5:0" ; then
- # spidermonkey-1.8.5 provides a .pc to pkg-config, it should be findable via mozjs185
- for x in mozilla-js xulrunner-js firefox-js firefox2-js seamonkey-js; do
- myconf+=" --disable-${x}"
- done
- else
- for x in mozjs187 mozjs185 mozilla-js xulrunner-js firefox-js seamonkey-js; do
- myconf+=" --disable-${x}"
- done
- # spidermonkey pre-1.8.5 has no pkg-config, so override ./configure
- JAVASCRIPT_ENGINE_CFLAGS="-I/usr/include/js -DXP_UNIX"
- if has_version ">=dev-lang/spidermonkey-1.8:0" ; then
- # spidermonkey-1.8 changed the name of the lib
- JAVASCRIPT_ENGINE_LIBS="-lmozjs"
- else
- JAVASCRIPT_ENGINE_LIBS="-ljs"
- fi
- if has_version dev-lang/spidermonkey[threadsafe] ; then
- JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
- JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
- fi
- export JAVASCRIPT_ENGINE_CFLAGS
- export JAVASCRIPT_ENGINE_LIBS
- fi
- econf ${myconf} \
- $(use_enable curl libcurl) \
- $(use_with glew) \
- $(use_enable debug) $(use_enable debug thread_colorized) \
- $(use_enable libeai) \
- $(use_enable java) \
- $(use_enable nsplugin plugin) \
- $(use_enable osc) \
- $(use_enable static-libs static) \
- $(use_enable sox sound)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use java; then
- insinto /usr/share/${PN}/lib
- doins src/java/java.policy
- java-pkg_regjar src/java/vrml.jar
- # install vrml.jar as a JRE extension
- dodir /usr/java/packages/lib/ext
- dosym /usr/share/${PN}/lib/vrml.jar /usr/java/packages/lib/ext/vrml.jar
- if ! has_version "media-gfx/freewrl[java]" ; then
- elog "Because vrml.jar requires access to sockets, you will need to incorporate the"
- elog "contents of /usr/share/${PN}/lib/java.policy into your system or user's default"
- elog "java policy:"
- elog " cat /usr/share/${PN}/lib/java.policy >>~/.java.policy"
- fi
- fi
-
- # remove unneeded .la files (as per Flameeyes' rant)
- cd "${D}"
- rm "usr/$(get_libdir)"/*.la "usr/$(get_libdir)/${PLUGINS_DIR}"/*.la
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
- elog "path. If you do not have firefox installed or you wish to use a different"
- elog "web browser to open links that are within VRML / X3D files, please be sure to"
- elog "specify the command via your BROWSER environment variable."
- fi
-}
diff --git a/media-gfx/freewrl/freewrl-1.22.13-r3.ebuild b/media-gfx/freewrl/freewrl-1.22.13-r3.ebuild
index 20753e0a8f87..61688dfe7bcc 100644
--- a/media-gfx/freewrl/freewrl-1.22.13-r3.ebuild
+++ b/media-gfx/freewrl/freewrl-1.22.13-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-1.22.13-r3.ebuild,v 1.2 2014/03/12 14:24:13 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-1.22.13-r3.ebuild,v 1.3 2014/03/14 13:45:19 axs Exp $
EAPI=5
@@ -46,11 +46,12 @@ RDEPEND="${COMMONDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-fontconfig-match.patch
- if has_version ">=dev-lang/spidermonkey-1.8.7" ; then
+ if has_version ">=dev-lang/spidermonkey-1.8.7:0" ; then
epatch "${FILESDIR}"/${P}-mozjs187-config.patch
- eautoreconf
fi
epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-java-fix.patch
+ eautoreconf
}
src_configure() {
@@ -89,7 +90,7 @@ src_configure() {
else
JAVASCRIPT_ENGINE_LIBS="-ljs"
fi
- if has_version dev-lang/spidermonkey[threadsafe] ; then
+ if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
fi
diff --git a/media-gfx/freewrl/freewrl-9999.ebuild b/media-gfx/freewrl/freewrl-9999.ebuild
index 8e7be2e3d8f8..d28a42f27e8a 100644
--- a/media-gfx/freewrl/freewrl-9999.ebuild
+++ b/media-gfx/freewrl/freewrl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-9999.ebuild,v 1.4 2014/03/12 14:24:13 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-9999.ebuild,v 1.5 2014/03/14 13:45:19 axs Exp $
EAPI=5
@@ -80,13 +80,13 @@ src_configure() {
# spidermonkey pre-1.8.5 has no pkg-config, so override ./configure
myconf+="${spidermonkeys_pc[@]/#/ --disable-}"
JAVASCRIPT_ENGINE_CFLAGS="-I/usr/include/js -DXP_UNIX"
- if has_version ">=dev-lang/spidermonkey-1.8" ; then
+ if has_version ">=dev-lang/spidermonkey-1.8:0" ; then
# spidermonkey-1.8 changed the name of the lib
JAVASCRIPT_ENGINE_LIBS="-lmozjs"
else
JAVASCRIPT_ENGINE_LIBS="-ljs"
fi
- if has_version dev-lang/spidermonkey[threadsafe] ; then
+ if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
fi