summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-16 08:52:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-16 08:52:23 +0000
commitcece8e998810e55c011f6bf8c7e327cc986fabf6 (patch)
treefb03307fc40c541e6bd2bcd82bd75309c1221993 /media-gfx/fbv
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-cece8e998810e55c011f6bf8c7e327cc986fabf6.tar.gz
gentoo-2-cece8e998810e55c011f6bf8c7e327cc986fabf6.tar.bz2
gentoo-2-cece8e998810e55c011f6bf8c7e327cc986fabf6.zip
dont access $CC !
Diffstat (limited to 'media-gfx/fbv')
-rw-r--r--media-gfx/fbv/fbv-0.99.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/media-gfx/fbv/fbv-0.99.ebuild b/media-gfx/fbv/fbv-0.99.ebuild
index dba3d242b4bd..4731678ada9e 100644
--- a/media-gfx/fbv/fbv-0.99.ebuild
+++ b/media-gfx/fbv/fbv-0.99.ebuild
@@ -1,42 +1,34 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.1 2003/08/25 13:43:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.2 2004/05/16 08:49:12 vapier Exp $
-IUSE="png gif jpeg"
+inherit gcc
-DESCRIPTION="fbv is a simple program to view pictures on a linux framebuffer device"
+DESCRIPTION="simple program to view pictures on a linux framebuffer device"
HOMEPAGE="http://s-tech.elsat.net.pl/fbv/"
SRC_URI="http://s-tech.elsat.net.pl/fbv//${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="png gif jpeg"
DEPEND="gif? ( media-libs/libungif )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )"
src_compile() {
-
local myconf
use png || myconf="${myconf} --without-libpng"
use gif || myconf="${myconf} --without-libungif"
use jpeg || myconf="${myconf} --without-libjpeg"
-
- ./configure \
- --prefix=/usr \
- --bindir=/usr/bin \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die
- emake CC="${CC} ${CFLAGS}" || die
+ econf ${myconf} || die
+ emake CC="$(gcc-getCC) ${CFLAGS}" || die
}
src_install() {
-
- dobin fbv
+ dobin fbv || die
doman fbv.1
-
dodoc ChangeLog README TODO VERSION
}