summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-09-28 13:05:42 +0000
committerPeter Volkov <pva@gentoo.org>2010-09-28 13:05:42 +0000
commitc05ebc9eda15c4b4b01fe1869b84ffae07cc33b9 (patch)
tree981367c74ab3fcc5ec3cb6bec2a8cfb3f0c860a9 /media-gfx/dcraw
parentAllow building of several media handlers, bug #334145 (diff)
downloadgentoo-2-c05ebc9eda15c4b4b01fe1869b84ffae07cc33b9.tar.gz
gentoo-2-c05ebc9eda15c4b4b01fe1869b84ffae07cc33b9.tar.bz2
gentoo-2-c05ebc9eda15c4b4b01fe1869b84ffae07cc33b9.zip
Version bump, #338372 thank Torsten Stets for report.
(Portage version: 2.1.9.12/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/dcraw')
-rw-r--r--media-gfx/dcraw/ChangeLog7
-rw-r--r--media-gfx/dcraw/dcraw-9.04.ebuild123
2 files changed, 129 insertions, 1 deletions
diff --git a/media-gfx/dcraw/ChangeLog b/media-gfx/dcraw/ChangeLog
index d2dbfb41ac55..e649a0219ef8 100644
--- a/media-gfx/dcraw/ChangeLog
+++ b/media-gfx/dcraw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/dcraw
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/ChangeLog,v 1.59 2010/06/21 12:08:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/ChangeLog,v 1.60 2010/09/28 13:05:42 pva Exp $
+
+*dcraw-9.04 (28 Sep 2010)
+
+ 28 Sep 2010; Peter Volkov <pva@gentoo.org> +dcraw-9.04.ebuild:
+ Version bump, #338372 thank Torsten Stets for report.
21 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> dcraw-8.99.ebuild:
Restrict media-libs/lcms depend to old version.
diff --git a/media-gfx/dcraw/dcraw-9.04.ebuild b/media-gfx/dcraw/dcraw-9.04.ebuild
new file mode 100644
index 000000000000..4c04d7d9f521
--- /dev/null
+++ b/media-gfx/dcraw/dcraw-9.04.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-9.04.ebuild,v 1.1 2010/09/28 13:05:42 pva Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts the native (RAW) format of various digital cameras into netpbm portable pixmap (.ppm) image"
+HOMEPAGE="http://www.cybercom.net/~dcoffin/dcraw/"
+SRC_URI="http://www.cybercom.net/~dcoffin/dcraw/archive/${P}.tar.gz
+ mirror://gentoo/parse-1.71.tar.bz2
+ gimp? ( mirror://gentoo/rawphoto-1.32.tar.bz2 )"
+
+LICENSE="freedist GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="nls gimp jpeg lcms"
+
+COMMON_DEPEND="jpeg? ( >=media-libs/jpeg-8a )
+ lcms? ( =media-libs/lcms-1* )
+ gimp? ( media-gfx/gimp )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ gimp? ( dev-util/pkgconfig )"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/netpbm"
+
+S=${WORKDIR}/dcraw
+
+LANGS="ca cs de da eo es fr hu it nl pl pt ru sv zh_CN zh_TW"
+
+for lng in ${LANGS}; do
+ IUSE+=" linguas_${lng}"
+done
+
+# Helper function to list only langs listed in LANGS or
+linguas_list() {
+ local nolangs=true
+ for lng in ${LANGS}; do
+ if use linguas_${lng}; then
+ nolangs=false
+ echo " ${lng}"
+ fi
+ done
+ if ${nolangs}; then
+ echo ${LANGS}
+ fi
+}
+
+run_build() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_prepare() {
+ rename dcraw_ dcraw. dcraw_*.1 || die "Failed to rename"
+}
+
+src_compile() {
+ local ECFLAGS="-O2" # Without optimisation build fails
+ local ELIBS="-lm"
+
+ use lcms && ELIBS="-llcms ${ELIBS}" || ECFLAGS+=" -DNO_LCMS=yes"
+ use jpeg && ELIBS="-ljpeg ${ELIBS}" || ECFLAGS+=" -DNO_JPEG=yes"
+ use nls && ECFLAGS+=" -DLOCALEDIR=\"/usr/share/locale/\""
+
+ run_build $(tc-getCC) ${ECFLAGS} ${CFLAGS} ${LDFLAGS} \
+ -o dcraw dcraw.c ${ELIBS}
+
+ run_build $(tc-getCC) -O2 ${CFLAGS} ${LDFLAGS} \
+ -o dcparse parse.c
+
+ # rawphoto gimp plugin
+ if use gimp; then
+ run_build $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
+ $(pkg-config --cflags gimpui-2.0) rawphoto.c -o rawphoto \
+ $(pkg-config --libs gimpui-2.0)
+ fi
+
+ if use nls; then
+ for lng in $(linguas_list); do
+ run_build msgfmt -c -o dcraw_${lng}.mo dcraw_${lng}.po
+ done
+ fi
+}
+
+src_install() {
+ dobin dcraw dcparse || die
+ dodoc "${FILESDIR}"/{conversion-examples.txt,dcwrap} || die
+
+ # rawphoto gimp plugin
+ if use gimp; then
+ insinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
+ insopts -m0755
+ doins rawphoto || die
+ fi
+
+ doman dcraw.1 || die
+ if use nls; then
+ for lng in $(linguas_list); do
+ [[ -f dcraw.${lng}.1 ]] && doman dcraw.${lng}.1
+ insinto /usr/share/locale/${lng}/LC_MESSAGES
+ newins dcraw_${lng}.mo dcraw.mo || die "failed to install dcraw_${lng}.mo"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "See conversion-examples.txt.gz on how to convert"
+ elog "the PPM files produced by dcraw to other image formats."
+ elog ""
+ ewarn "The functionality of the external program 'fujiturn' was"
+ ewarn "incorporated into dcraw and is automatically used now."
+ elog ""
+ elog "There's an example wrapper script included called 'dcwrap'."
+ elog ""
+ elog "This package also includes 'dcparse', which extracts"
+ elog "thumbnail images (preferably JPEGs) from any raw digital"
+ elog "camera formats that have them, and shows table contents."
+ elog ""
+}