summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-23 09:59:04 +0000
committerTom William Payne <twp@gentoo.org>2003-04-23 09:59:04 +0000
commit9733244b6b84ce464df6c4e84a4601c89489b85d (patch)
treeb05f7f2277916dadf51f2ea53a24f8f54fba843c /media-fonts
parentAdded media-fonts (bug # 18639). (diff)
downloadgentoo-2-9733244b6b84ce464df6c4e84a4601c89489b85d.tar.gz
gentoo-2-9733244b6b84ce464df6c4e84a4601c89489b85d.tar.bz2
gentoo-2-9733244b6b84ce464df6c4e84a4601c89489b85d.zip
Initial commit.
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/terminus-font/ChangeLog9
-rw-r--r--media-fonts/terminus-font/terminus-font-4.00.ebuild41
2 files changed, 50 insertions, 0 deletions
diff --git a/media-fonts/terminus-font/ChangeLog b/media-fonts/terminus-font/ChangeLog
new file mode 100644
index 000000000000..7d2de3793c0e
--- /dev/null
+++ b/media-fonts/terminus-font/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-fonts/terminus-fonts
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/terminus-font/ChangeLog,v 1.1 2003/04/23 09:59:04 twp Exp $
+
+*terminus-fonts-4.00 (23 Apr 2003)
+
+ 23 Apr 2003; Tom Payne <twp@gentoo.org> terminus-fonts-4.00.ebuild :
+
+ Initial version. Ebuild submitted by Paul Totterman. Bug # 18639.
diff --git a/media-fonts/terminus-font/terminus-font-4.00.ebuild b/media-fonts/terminus-font/terminus-font-4.00.ebuild
new file mode 100644
index 000000000000..cefb9045c0dd
--- /dev/null
+++ b/media-fonts/terminus-font/terminus-font-4.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/terminus-font/terminus-font-4.00.ebuild,v 1.1 2003/04/23 09:59:04 twp Exp $
+
+DESCRIPTION="A clean fixed font for the console and X11"
+HOMEPAGE="http://www.is-vn.bg/hamster/jimmy-en.htm"
+SRC_URI="http://www.is-vn.bg/hamster/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+
+DEPEND="X? ( virtual/x11 ) dev-lang/perl"
+RDEPEND="X? ( virtual/x11 )"
+
+src_compile() {
+ make psf || die
+
+ # If user wants fonts for X11
+ if [ -n "`use X`" ]; then
+ make pcf || die
+ fi
+}
+
+src_install() {
+ ( cd vga && ../configure --prefix=${D}/usr )
+ make -f vga/Makefile install || die
+
+ # If user wants fonts for X11
+ if [ -n "`use X`" ]; then
+ ( cd x11 && ../configure --prefix=${D}/usr )
+ perl -pi -e 's/local/misc/;' x11/Makefile
+ make -f x11/Makefile install || die
+ fi
+
+ dodoc README*
+}
+
+pkg_postinst() {
+ mkfontdir ${ROOT}usr/X11R6/fonts/X11/misc
+}