summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-06-23 22:36:53 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-06-23 22:36:53 +0000
commit0123add08d6c9c94c9d3c0cd1b8a1203638c65cd (patch)
treefeb2b50a8fdc2b513e690bcc25268707a9a0be27 /media-fonts
parentVersion bump (diff)
downloadgentoo-2-0123add08d6c9c94c9d3c0cd1b8a1203638c65cd.tar.gz
gentoo-2-0123add08d6c9c94c9d3c0cd1b8a1203638c65cd.tar.bz2
gentoo-2-0123add08d6c9c94c9d3c0cd1b8a1203638c65cd.zip
Version bumped, bug #423001.
(Portage version: 2.1.10.54/cvs/Linux x86_64)
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/ricty/ChangeLog7
-rw-r--r--media-fonts/ricty/ricty-3.2.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-fonts/ricty/ChangeLog b/media-fonts/ricty/ChangeLog
index fa5a343af9d1..1f17a12ba085 100644
--- a/media-fonts/ricty/ChangeLog
+++ b/media-fonts/ricty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-fonts/ricty
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/ricty/ChangeLog,v 1.4 2012/01/24 15:44:08 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/ricty/ChangeLog,v 1.5 2012/06/23 22:36:53 matsuu Exp $
+
+*ricty-3.2.0 (23 Jun 2012)
+
+ 23 Jun 2012; MATSUU Takuto <matsuu@gentoo.org> +ricty-3.2.0.ebuild:
+ Version bumped, bug #423001.
*ricty-3.1.3 (24 Jan 2012)
diff --git a/media-fonts/ricty/ricty-3.2.0.ebuild b/media-fonts/ricty/ricty-3.2.0.ebuild
new file mode 100644
index 000000000000..7a2c482f2bde
--- /dev/null
+++ b/media-fonts/ricty/ricty-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/ricty/ricty-3.2.0.ebuild,v 1.1 2012/06/23 22:36:53 matsuu Exp $
+
+EAPI=4
+inherit font
+
+MY_PN="Ricty"
+DESCRIPTION="A beautiful sans-serif monotype Japanese font designed for code listings"
+HOMEPAGE="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty.html"
+#SRC_URI="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty/${MY_PN}-${PV}.tar.gz"
+SRC_URI="https://github.com/yascentur/${MY_PN}/tarball/${PV} -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-fonts/inconsolata
+ >=media-fonts/mix-mplus-ipa-20111002
+ media-gfx/fontforge"
+RDEPEND=""
+
+#S="${WORKDIR}/yascentur-${MY_PN}-*"
+S="${WORKDIR}/yascentur-${MY_PN}-b9d8b9c"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+
+# Only installs fonts.
+RESTRICT="strip binchecks"
+
+src_compile() {
+ sh ricty_generator.sh \
+ "${EPREFIX}/usr/share/fonts/inconsolata/Inconsolata.otf" \
+ "${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-regular.ttf" \
+ "${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-bold.ttf" || die
+}