summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-01-24 15:44:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-01-24 15:44:08 +0000
commita4b3db104d31da2abdc5a3075b48cb2bd7873de9 (patch)
tree265df2fcd17ac0345570095bf3f75bd53a3d3d23 /media-fonts/ricty
parentVersion bump. (diff)
downloadgentoo-2-a4b3db104d31da2abdc5a3075b48cb2bd7873de9.tar.gz
gentoo-2-a4b3db104d31da2abdc5a3075b48cb2bd7873de9.tar.bz2
gentoo-2-a4b3db104d31da2abdc5a3075b48cb2bd7873de9.zip
Version bumped.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-fonts/ricty')
-rw-r--r--media-fonts/ricty/ChangeLog9
-rw-r--r--media-fonts/ricty/ricty-3.1.3.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/media-fonts/ricty/ChangeLog b/media-fonts/ricty/ChangeLog
index c6046641cf4c..fa5a343af9d1 100644
--- a/media-fonts/ricty/ChangeLog
+++ b/media-fonts/ricty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-fonts/ricty
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/ricty/ChangeLog,v 1.3 2011/11/08 09:57:35 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/ricty/ChangeLog,v 1.4 2012/01/24 15:44:08 matsuu Exp $
+
+*ricty-3.1.3 (24 Jan 2012)
+
+ 24 Jan 2012; MATSUU Takuto <matsuu@gentoo.org> +ricty-3.1.3.ebuild:
+ Version bumped.
08 Nov 2011; Naohiro Aota <naota@gentoo.org> ricty-3.1.1.ebuild:
Add ~x86-fbsd
diff --git a/media-fonts/ricty/ricty-3.1.3.ebuild b/media-fonts/ricty/ricty-3.1.3.ebuild
new file mode 100644
index 000000000000..277ae93347ca
--- /dev/null
+++ b/media-fonts/ricty/ricty-3.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/ricty/ricty-3.1.3.ebuild,v 1.1 2012/01/24 15:44:08 matsuu Exp $
+
+EAPI=3
+inherit font
+
+MY_PN="Ricty"
+DESCRIPTION="A beautiful sans-serif monotype Japanese font designed for code listings"
+HOMEPAGE="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty.html"
+SRC_URI="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-fonts/inconsolata
+ >=media-fonts/mix-mplus-ipa-20111002
+ media-gfx/fontforge"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+
+# Only installs fonts.
+RESTRICT="strip binchecks"
+
+src_compile() {
+ sh ricty_generator.sh \
+ "${EPREFIX}/usr/share/fonts/inconsolata/Inconsolata.otf" \
+ "${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-regular.ttf" \
+ "${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-bold.ttf" || die
+}