summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-01-12 04:43:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-01-12 04:43:37 +0000
commitd442bc9ceadc69aa89027407218c0666e19ba4ad (patch)
treec353085e54c027df5d2ac8efb1309876269c2050 /media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
parentProvide FONT_PN to override font.eclass using /usr/share/fonts/PN always - th... (diff)
downloadgentoo-2-d442bc9ceadc69aa89027407218c0666e19ba4ad.tar.gz
gentoo-2-d442bc9ceadc69aa89027407218c0666e19ba4ad.tar.bz2
gentoo-2-d442bc9ceadc69aa89027407218c0666e19ba4ad.zip
Clean up ebuild to use font.eclass and font-ebdftopcf.eclass.
(Portage version: 2.0.54)
Diffstat (limited to 'media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild')
-rw-r--r--media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
new file mode 100644
index 000000000000..4185a69d69ce
--- /dev/null
+++ b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild,v 1.1 2006/01/12 04:43:37 robbat2 Exp $
+
+inherit font font-ebdftopcf
+
+DESCRIPTION="Japanese fixed fonts that cover JIS0213 charset"
+
+HOMEPAGE="http://www12.ocn.ne.jp/~imamura/jisx0213.html"
+SRC_BASE1="http://www12.ocn.ne.jp/~imamura"
+SRC_BASE2="http://gitatsu.hp.infoseek.co.jp/bdf"
+SRC_URI="${SRC_BASE1}/jiskan16-2004-1.bdf.gz
+ ${SRC_BASE1}/jiskan16-2000-1.bdf.gz
+ ${SRC_BASE1}/jiskan16-2000-2.bdf.gz
+ ${SRC_BASE1}/K14-2004-1.bdf.gz
+ ${SRC_BASE1}/K14-2000-1.bdf.gz
+ ${SRC_BASE1}/K14-2000-2.bdf.gz
+ ${SRC_BASE1}/K12-1.bdf.gz
+ ${SRC_BASE1}/K12-2.bdf.gz
+ ${SRC_BASE1}/A14.bdf.gz
+ ${SRC_BASE1}/A12.bdf.gz
+ ${SRC_BASE2}/jiskan24-2000-1.bdf.gz
+ ${SRC_BASE2}/jiskan24-2000-2.bdf.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+FONT_S="${S}"
+FONT_PN="${PN/-fonts/}"
+FONTDIR="/usr/share/fonts/${FONT_PN}"
+FONT_SUFFIX="pcf.gz"
+
+pkg_postinst(){
+ einfo "You need you add following line into 'Section \"Files\"' in"
+ einfo "XF86Config and reboot X Window System, to use these fonts."
+ einfo ""
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo ""
+}
+
+pkg_postrm(){
+ einfo "You need you remove following line in 'Section \"Files\"' in"
+ einfo "XF86Config, to unmerge this package completely."
+ einfo ""
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo ""
+}