summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2014-12-09 00:54:59 +0000
committerMatthias Maier <tamiko@gentoo.org>2014-12-09 00:54:59 +0000
commit157cacd13216f7739aac0e07473677ed44e9652b (patch)
treefbc853ac0ffb55018965a150edbb54e4ed540ae8 /mate-base/mate-panel
parentadd missing ${PYTHON_REQUIRED_USE}, bug #523858 (diff)
downloadgentoo-2-157cacd13216f7739aac0e07473677ed44e9652b.tar.gz
gentoo-2-157cacd13216f7739aac0e07473677ed44e9652b.tar.bz2
gentoo-2-157cacd13216f7739aac0e07473677ed44e9652b.zip
version bump; also fixes bug #523162
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'mate-base/mate-panel')
-rw-r--r--mate-base/mate-panel/ChangeLog7
-rw-r--r--mate-base/mate-panel/mate-panel-1.8.1.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/mate-base/mate-panel/ChangeLog b/mate-base/mate-panel/ChangeLog
index acd05f1e8291..1e8a82855268 100644
--- a/mate-base/mate-panel/ChangeLog
+++ b/mate-base/mate-panel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mate-base/mate-panel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-panel/ChangeLog,v 1.13 2014/07/02 09:46:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-panel/ChangeLog,v 1.14 2014/12/09 00:54:59 tamiko Exp $
+
+*mate-panel-1.8.1 (09 Dec 2014)
+
+ 09 Dec 2014; Matthias Maier <tamiko@gentoo.org> +mate-panel-1.8.1.ebuild:
+ version bump; also fixes bug #523162
02 Jul 2014; Pacho Ramos <pacho@gentoo.org> mate-panel-1.8.0.ebuild:
x86 stable, bug 513714
diff --git a/mate-base/mate-panel/mate-panel-1.8.1.ebuild b/mate-base/mate-panel/mate-panel-1.8.1.ebuild
new file mode 100644
index 000000000000..5c570e9691ba
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.8.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-panel/mate-panel-1.8.1.ebuild,v 1.1 2014/12/09 00:54:59 tamiko Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE panel"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X +introspection networkmanager"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libmateweather-1.6
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.10:0
+ gnome-base/librsvg:2
+ >=mate-base/mate-desktop-1.8:0
+ >=mate-base/mate-menus-1.6:0
+ >=media-libs/libcanberra-0.23:0[gtk]
+ >=sys-apps/dbus-1.1.2:0
+ >=x11-libs/cairo-1:0
+ >=x11-libs/gdk-pixbuf-2.7.1:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-2.30:1[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ >=x11-libs/gtk+-2.19.7:2[introspection?]
+ x11-libs/libXau:0
+ >=x11-libs/libXrandr-1.2:0
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
+ networkmanager? ( >=net-misc/networkmanager-0.6:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=dev-lang/perl-5:0=
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.6:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Disable python check.
+ sed -e '/AM_PATH_PYTHON/d' -i configure.ac || die
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable networkmanager network-manager) \
+ $(use_enable introspection) \
+ $(use_with X x)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"