summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-03 11:43:08 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-03 11:43:08 +0000
commit7af56e65d4804138a35ca763e7bfe0188b423d93 (patch)
tree6c2bdf5ff4c85fb1ef7c52834fb3a58de9319a55 /mail-mta
parentalpha/ia64/sparc stable wrt #208366 (diff)
downloadgentoo-2-7af56e65d4804138a35ca763e7bfe0188b423d93.tar.gz
gentoo-2-7af56e65d4804138a35ca763e7bfe0188b423d93.tar.bz2
gentoo-2-7af56e65d4804138a35ca763e7bfe0188b423d93.zip
Replace call to docert by install_cert, bug 201671.
(Portage version: 2.1.4.1, RepoMan options: --force)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/postfix/ChangeLog14
-rw-r--r--mail-mta/postfix/postfix-2.2.11-r1.ebuild (renamed from mail-mta/postfix/postfix-2.2.11.ebuild)27
-rw-r--r--mail-mta/postfix/postfix-2.3.8-r1.ebuild (renamed from mail-mta/postfix/postfix-2.3.8.ebuild)23
-rw-r--r--mail-mta/postfix/postfix-2.4.6-r2.ebuild (renamed from mail-mta/postfix/postfix-2.4.6-r1.ebuild)24
4 files changed, 47 insertions, 41 deletions
diff --git a/mail-mta/postfix/ChangeLog b/mail-mta/postfix/ChangeLog
index 5b27ea036738..7d97ba2b3d4d 100644
--- a/mail-mta/postfix/ChangeLog
+++ b/mail-mta/postfix/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for mail-mta/postfix
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.143 2007/12/12 16:56:07 jer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.144 2008/02/03 11:43:08 ulm Exp $
+
+*postfix-2.4.6-r2 (03 Feb 2008)
+*postfix-2.3.8-r1 (03 Feb 2008)
+*postfix-2.2.11-r1 (03 Feb 2008)
+
+ 03 Feb 2008; Ulrich Mueller <ulm@gentoo.org> -postfix-2.2.11.ebuild,
+ +postfix-2.2.11-r1.ebuild, -postfix-2.3.8.ebuild,
+ +postfix-2.3.8-r1.ebuild, -postfix-2.4.6-r1.ebuild,
+ +postfix-2.4.6-r2.ebuild:
+ Replace docert by install_cert, bug 201671.
12 Dec 2007; Jeroen Roovers <jer@gentoo.org> postfix-2.4.5.ebuild:
Stable for HPPA (bug #199332).
diff --git a/mail-mta/postfix/postfix-2.2.11.ebuild b/mail-mta/postfix/postfix-2.2.11-r1.ebuild
index f523116c7e12..902df8c89c73 100644
--- a/mail-mta/postfix/postfix-2.2.11.ebuild
+++ b/mail-mta/postfix/postfix-2.2.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.11.ebuild,v 1.3 2007/10/21 11:15:08 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.11-r1.ebuild,v 1.1 2008/02/03 11:43:08 ulm Exp $
inherit eutils ssl-cert toolchain-funcs flag-o-matic pam
IUSE="ipv6 pam ldap mysql postgres ssl sasl mailwrapper mbox nis vda selinux hardened cdb"
@@ -148,7 +148,6 @@ src_unpack() {
}
src_compile() {
- cd ${S}
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
@@ -199,7 +198,7 @@ src_compile() {
if has_version dev-db/tinycdb; then
einfo "build with dev-db/tinycdb"
# ugly hack because gentoo doesn't install cdb.h
- cp /usr/include/tinycdb.h ${S}/src/util/cdb.h || die \
+ cp /usr/include/tinycdb.h "${S}"/src/util/cdb.h || die \
"failed to cp /usr/include/tinycdb.h to ${S}/util/cdb.h"
CDB_LIBS="-ltinycdb"
else
@@ -279,7 +278,7 @@ src_install () {
fperms 02711 /usr/sbin/post{drop,queue}
keepdir /etc/postfix
- mv ${D}/usr/share/doc/${PF}/defaults/{*.cf,post*-*} ${D}/etc/postfix
+ mv "${D}"/usr/share/doc/${PF}/defaults/{*.cf,post*-*} "${D}"/etc/postfix
if use mbox ; then
mypostconf="mail_spool_directory=/var/spool/mail"
else
@@ -297,19 +296,11 @@ src_install () {
die "newinitd failed"
mv "${S}/examples" "${D}/usr/share/doc/${PF}/"
- dodoc *README COMPATIBILITY HISTORY INSTALL LICENSE PORTING RELEASE_NOTES*
+ dodoc *README COMPATIBILITY HISTORY INSTALL PORTING RELEASE_NOTES*
dohtml html/*
pamd_mimic_system smtp auth account
- # do not install server.{key,pem) if they are exist.
- if use ssl && [[ ! -f /etc/ssl/postfix/server.key && ! -f /etc/ssl/postfix/server.pem ]]; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
- insinto /etc/ssl/postfix
- docert server
- fowners postfix:mail /etc/ssl/postfix/server.{key,pem}
- fi
-
if use sasl ; then
insinto /etc/sasl2
newins "${FILESDIR}/smtp.sasl" smtpd.conf
@@ -321,6 +312,14 @@ pkg_postinst() {
# add postfix, postdrop user/group. Bug #77565.
group_user_check || die "failed to check/add needed user/group"
+ # Do not install server.{key,pem) SSL certificates if they already exist
+ if use ssl && [[ ! -f "${ROOT}"/etc/ssl/postfix/server.key \
+ && ! -f "${ROOT}"/etc/ssl/postfix/server.pem ]] ; then
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
+ install_cert /etc/ssl/postfix/server
+ chown postfix:mail "${ROOT}"/etc/ssl/postfix/server.{key,pem}
+ fi
+
ebegin "Fixing queue directories and permissions"
"${ROOT}/etc/postfix/post-install" upgrade-permissions
echo
diff --git a/mail-mta/postfix/postfix-2.3.8.ebuild b/mail-mta/postfix/postfix-2.3.8-r1.ebuild
index d6baa9f63c43..59c73b50f1c1 100644
--- a/mail-mta/postfix/postfix-2.3.8.ebuild
+++ b/mail-mta/postfix/postfix-2.3.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.3.8.ebuild,v 1.3 2007/10/21 11:15:08 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.3.8-r1.ebuild,v 1.1 2008/02/03 11:43:08 ulm Exp $
# NOTE: this ebuild is regular ebuild without mailer-config support
# comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -177,7 +177,6 @@ src_unpack() {
}
src_compile() {
- cd ${S}
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
@@ -336,19 +335,11 @@ src_install () {
die "newinitd failed"
mv "${S}/examples" "${D}/usr/share/doc/${PF}/"
- dodoc *README COMPATIBILITY HISTORY INSTALL LICENSE PORTING RELEASE_NOTES*
+ dodoc *README COMPATIBILITY HISTORY INSTALL PORTING RELEASE_NOTES*
dohtml html/*
pamd_mimic_system smtp auth account
- # do not install server.{key,pem) if they are exist.
- if use ssl && [[ ! -f /etc/ssl/postfix/server.key && ! -f /etc/ssl/postfix/server.pem ]]; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
- insinto /etc/ssl/postfix
- docert server
- fowners postfix:mail /etc/ssl/postfix/server.{key,pem}
- fi
-
if use sasl ; then
insinto /etc/sasl2
newins "${FILESDIR}/smtp.sasl" smtpd.conf
@@ -359,6 +350,14 @@ pkg_postinst() {
# add postfix, postdrop user/group. Bug #77565.
group_user_check || die "failed to check/add needed user/group"
+ # Do not install server.{key,pem) SSL certificates if they already exist
+ if use ssl && [[ ! -f "${ROOT}"/etc/ssl/postfix/server.key \
+ && ! -f "${ROOT}"/etc/ssl/postfix/server.pem ]] ; then
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
+ install_cert /etc/ssl/postfix/server
+ chown postfix:mail "${ROOT}"/etc/ssl/postfix/server.{key,pem}
+ fi
+
ebegin "Fixing queue directories and permissions"
"${ROOT}/etc/postfix/post-install" upgrade-permissions
echo
diff --git a/mail-mta/postfix/postfix-2.4.6-r1.ebuild b/mail-mta/postfix/postfix-2.4.6-r2.ebuild
index 4ff38b3b758c..08f89ae53368 100644
--- a/mail-mta/postfix/postfix-2.4.6-r1.ebuild
+++ b/mail-mta/postfix/postfix-2.4.6-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.6-r1.ebuild,v 1.1 2007/11/26 12:09:04 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.6-r2.ebuild,v 1.1 2008/02/03 11:43:08 ulm Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -167,8 +167,6 @@ src_unpack() {
}
src_compile() {
- cd "${S}"
-
# Added -Wl,-z,now wrt bug #62674
# Remove -ldl as it is not necessary, solves bug #106446
# -Wl,-z,now replaced by $(bindnow-flags)
@@ -327,19 +325,11 @@ src_install () {
newinitd "${FILESDIR}/postfix.rc6.${RC_VER}" postfix || die "newinitd failed"
mv "${S}/examples" "${D}/usr/share/doc/${PF}/"
- dodoc *README COMPATIBILITY HISTORY INSTALL LICENSE PORTING RELEASE_NOTES*
+ dodoc *README COMPATIBILITY HISTORY INSTALL PORTING RELEASE_NOTES*
dohtml html/*
pamd_mimic_system smtp auth account
- # Do not install server.{key,pem) SSL certificates if they already exist
- if use ssl && [[ ! -f /etc/ssl/postfix/server.key && ! -f /etc/ssl/postfix/server.pem ]] ; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
- insinto /etc/ssl/postfix
- docert server
- fowners postfix:mail /etc/ssl/postfix/server.{key,pem}
- fi
-
if use sasl ; then
insinto /etc/sasl2
newins "${FILESDIR}/smtp.sasl" smtpd.conf
@@ -350,6 +340,14 @@ pkg_postinst() {
# Add postfix, postdrop user/group (bug #77565)
group_user_check || die "Failed to check/add needed user/group"
+ # Do not install server.{key,pem) SSL certificates if they already exist
+ if use ssl && [[ ! -f "${ROOT}"/etc/ssl/postfix/server.key \
+ && ! -f "${ROOT}"/etc/ssl/postfix/server.pem ]] ; then
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Postfix SMTP Server}"
+ install_cert /etc/ssl/postfix/server
+ chown postfix:mail "${ROOT}"/etc/ssl/postfix/server.{key,pem}
+ fi
+
ebegin "Fixing queue directories and permissions"
"${ROOT}/etc/postfix/post-install" upgrade-permissions
echo