summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-07-14 17:11:38 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-07-14 17:11:38 +0000
commit87ebbee8174fb3d1d0d6a6080052a9bab9691c70 (patch)
tree644abf688871e4a6a8e17ea4a882cc6e0616af0d /mail-mta/courier/courier-0.53.2.ebuild
parentppc stable, bug #139612 (diff)
downloadgentoo-2-87ebbee8174fb3d1d0d6a6080052a9bab9691c70.tar.gz
gentoo-2-87ebbee8174fb3d1d0d6a6080052a9bab9691c70.tar.bz2
gentoo-2-87ebbee8174fb3d1d0d6a6080052a9bab9691c70.zip
Fix issues from bug #135005.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'mail-mta/courier/courier-0.53.2.ebuild')
-rw-r--r--mail-mta/courier/courier-0.53.2.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/mail-mta/courier/courier-0.53.2.ebuild b/mail-mta/courier/courier-0.53.2.ebuild
index f868625d35c7..25cb1dc49f3e 100644
--- a/mail-mta/courier/courier-0.53.2.ebuild
+++ b/mail-mta/courier/courier-0.53.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.53.2.ebuild,v 1.1 2006/07/11 00:21:53 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.53.2.ebuild,v 1.2 2006/07/14 17:11:38 chtekk Exp $
inherit eutils gnuconfig flag-o-matic
@@ -265,6 +265,20 @@ src_install() {
fi
}
+src_test() {
+ addpredict /
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if hasq userpriv ${FEATURES} ; then
+ if ! emake -j1 check; then
+ hasq test ${FEATURES} && die "Make check failed. See above for details."
+ hasq test ${FEATURES} || eerror "Make check failed. See above for details."
+ fi
+ else
+ hasq test ${FEATURES} && eerror "Make check needs FEATURES="userpriv" to work."
+ fi
+ SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
+}
+
pkg_postinst() {
use fam && einfo "fam daemon is needed for courier-imapd" \
|| ewarn "courier was built without fam support"