summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 16:47:32 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 16:47:32 +0000
commitb044b820be572dbd2f9141bc091257a415c3d9f7 (patch)
treee0ecf416f54d5aa76c5b955aa289ad396fc34ede /mail-filter
parentuse dobin instead of exeinto /usr/bin/ && doexe; drop old (diff)
downloadgentoo-2-b044b820be572dbd2f9141bc091257a415c3d9f7.tar.gz
gentoo-2-b044b820be572dbd2f9141bc091257a415c3d9f7.tar.bz2
gentoo-2-b044b820be572dbd2f9141bc091257a415c3d9f7.zip
use dobin instead of exeinto /usr/bin/ && doexe; bump to EAPI=5
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/rblcheck/ChangeLog10
-rw-r--r--mail-filter/rblcheck/rblcheck-1.5-r1.ebuild9
-rw-r--r--mail-filter/rblcheck/rblcheck-1.5-r2.ebuild30
3 files changed, 41 insertions, 8 deletions
diff --git a/mail-filter/rblcheck/ChangeLog b/mail-filter/rblcheck/ChangeLog
index e4446f971082..db6fd1d9ae82 100644
--- a/mail-filter/rblcheck/ChangeLog
+++ b/mail-filter/rblcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/rblcheck
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/rblcheck/ChangeLog,v 1.14 2014/08/10 21:17:07 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/rblcheck/ChangeLog,v 1.15 2015/03/21 16:47:32 jlec Exp $
+
+*rblcheck-1.5-r2 (21 Mar 2015)
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> +rblcheck-1.5-r2.ebuild,
+ rblcheck-1.5-r1.ebuild:
+ use dobin instead of exeinto /usr/bin/ && doexe; bump to EAPI=5
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> rblcheck-1.5-r1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild b/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild
index 9b9e20830fb3..d486a3cddc21 100644
--- a/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild
+++ b/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild,v 1.6 2014/08/10 21:17:07 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild,v 1.7 2015/03/21 16:47:32 jlec Exp $
EAPI=2
@@ -15,8 +15,6 @@ LICENSE="GPL-2"
KEYWORDS="alpha ~amd64 hppa ~mips ppc sparc x86"
IUSE=""
-DEPEND=""
-
src_prepare() {
epatch "${FILESDIR}/${P}-configure.patch"
}
@@ -26,8 +24,7 @@ src_compile() {
}
src_install () {
- exeinto /usr/bin
- doexe rbl rblcheck
+ dobin rbl rblcheck
dodoc README docs/rblcheck.ps docs/rblcheck.rtf
}
diff --git a/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild b/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild
new file mode 100644
index 000000000000..5fd5add5542f
--- /dev/null
+++ b/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild,v 1.1 2015/03/21 16:47:32 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Perform lookups in RBL-styles services"
+HOMEPAGE="http://rblcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rblcheck/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-configure.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin rbl rblcheck
+
+ dodoc README docs/rblcheck.ps docs/rblcheck.rtf
+}