summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Kulbe <superlag@gentoo.org>2004-12-16 01:13:53 +0000
committerAaron Kulbe <superlag@gentoo.org>2004-12-16 01:13:53 +0000
commita27f7a75f6d4567b786c802929331a2bc95c642c (patch)
treee4207f976da767f9486a0d660ba6b745ba96a979 /mail-filter
parentsort (diff)
downloadgentoo-2-a27f7a75f6d4567b786c802929331a2bc95c642c.tar.gz
gentoo-2-a27f7a75f6d4567b786c802929331a2bc95c642c.tar.bz2
gentoo-2-a27f7a75f6d4567b786c802929331a2bc95c642c.zip
Version bump. My second commit. WOO HOO!!!
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/razor/Manifest12
-rw-r--r--mail-filter/razor/files/digest-razor-2.671
-rw-r--r--mail-filter/razor/razor-2.67.ebuild69
3 files changed, 72 insertions, 10 deletions
diff --git a/mail-filter/razor/Manifest b/mail-filter/razor/Manifest
index 4c954e9c5b58..05bc398e3196 100644
--- a/mail-filter/razor/Manifest
+++ b/mail-filter/razor/Manifest
@@ -1,6 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 1739456d96ab6c4384fefc08c437fe6d razor-2.67.ebuild 2735
MD5 75c5d3ad1bc48ae038b747d8f104c1c6 razor-2.40-r1.ebuild 2735
MD5 1739456d96ab6c4384fefc08c437fe6d razor-2.66.ebuild 2735
MD5 7ca5dc039abf88fcb6cb36870cd2e173 razor-2.61.ebuild 2730
@@ -13,11 +11,5 @@ MD5 86ce0f71341d41a9cf561083b241c9fb files/digest-razor-2.36-r1 68
MD5 24b659c729fbfbf960ca1521df9840da files/digest-razor-2.40-r1 68
MD5 8fcc1e253bebf4448a7b0f2562ac3609 files/digest-razor-2.61 68
MD5 1b6d9c47c56378a23bc89814de8a8033 files/digest-razor-2.66 68
+MD5 7a82279f793cdd8926569fcc1f2c51e6 files/digest-razor-2.67 68
MD5 cf27167873572ac8be99c5195762d630 files/razor_uninstall.patch 1765
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBsLPhCHk4+ZoBpvsRAmXgAKC2mK1RLEy9IDw5BBWxDzbNp0MM6gCgvJUO
-bOPI/QKcH7bnfPcQXEoebOM=
-=hY0Z
------END PGP SIGNATURE-----
diff --git a/mail-filter/razor/files/digest-razor-2.67 b/mail-filter/razor/files/digest-razor-2.67
new file mode 100644
index 000000000000..cd666fe181eb
--- /dev/null
+++ b/mail-filter/razor/files/digest-razor-2.67
@@ -0,0 +1 @@
+MD5 0118b6030ea261ea85e73a55cc7eac8e razor-agents-2.67.tar.gz 86705
diff --git a/mail-filter/razor/razor-2.67.ebuild b/mail-filter/razor/razor-2.67.ebuild
new file mode 100644
index 000000000000..58273d0b82a3
--- /dev/null
+++ b/mail-filter/razor/razor-2.67.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/razor-2.67.ebuild,v 1.1 2004/12/16 01:13:53 superlag Exp $
+
+inherit perl-module eutils
+IUSE=""
+DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/razor/razor-agents-${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+S=${WORKDIR}/razor-agents-${PV}
+
+RDEPEND="dev-lang/perl
+ dev-perl/Net-DNS
+ dev-perl/net-ping
+ dev-perl/Time-HiRes
+ dev-perl/Digest-SHA1
+ dev-perl/URI
+ dev-perl/Digest-Nilsimsa"
+
+
+src_install() {
+ epatch ${FILESDIR}/no-install-razor-agents.patch #31365
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ # insures appropriate symlinks have been created
+ /usr/bin/razor-client
+
+ einfo "Run 'razor-admin -create' to create a default config file in your"
+ einfo "home directory under /home/user/.razor. (Remember to change user to"
+ einfo "your username from root before running razor-admin)"
+ einfo ""
+ einfo "Razor v2 requires reporters to be registered so their reputations can"
+ einfo "be computed over time and they can participate in the revocation"
+ einfo "mechanism. Registration is done with razor-admin -register. It has to be"
+ einfo "manually invoked in either of the following ways:"
+ einfo ""
+ einfo "To register user foo with 's1kret' as password: "
+ einfo ""
+ einfo "razor-admin -register -user=foo -pass=s1kr3t"
+ einfo ""
+ einfo "To register with an email address and have the password assigned:"
+ einfo ""
+ einfo "razor-admin -register -user=foo@bar.com "
+ einfo ""
+ einfo "To have both (random) username and password assgined: "
+ einfo ""
+ einfo "razor-admin -register "
+ einfo ""
+ einfo "razor-admin -register negotiates a registration with the Nomination Server"
+ einfo "and writes the identity information in"
+ einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+ einfo "when invoked as root."
+ einfo ""
+ einfo "You can edit razor-agent.conf to change the defaults. Config options"
+ einfo "and their values are defined in the razor-agent.conf(5) manpage."
+
+ einfo "The next step is to integrate razor-check, razor-report and"
+ einfo "razor-revoke in your mail system. If you are running Razor v1, the"
+ einfo "change will be transparent, new versions of razor agents will overwrite"
+ einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
+ einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
+ einfo "refer to manpages of razor-check(1), razor-report(1), and"
+ einfo "razor-revoke(1) for integration instructions."
+}