summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-12-02 10:03:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-12-02 10:03:46 +0000
commitf6e55c1cd87c80c5caa145fcccb0f49ccf11b5d3 (patch)
treeab29f12082c322878dc141cf504b0dda908d9ec7 /mail-filter/spamdyke
parentStable for HPPA (bug #247819). (diff)
downloadgentoo-2-f6e55c1cd87c80c5caa145fcccb0f49ccf11b5d3.tar.gz
gentoo-2-f6e55c1cd87c80c5caa145fcccb0f49ccf11b5d3.tar.bz2
gentoo-2-f6e55c1cd87c80c5caa145fcccb0f49ccf11b5d3.zip
Version bump to 4.0.9
(Portage version: 2.1.4.5)
Diffstat (limited to 'mail-filter/spamdyke')
-rw-r--r--mail-filter/spamdyke/ChangeLog7
-rw-r--r--mail-filter/spamdyke/spamdyke-4.0.9.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/mail-filter/spamdyke/ChangeLog b/mail-filter/spamdyke/ChangeLog
index 8d21b4274f31..7146c4172b84 100644
--- a/mail-filter/spamdyke/ChangeLog
+++ b/mail-filter/spamdyke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/spamdyke
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/ChangeLog,v 1.12 2008/11/17 09:52:47 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/ChangeLog,v 1.13 2008/12/02 10:03:46 tupone Exp $
+
+*spamdyke-4.0.9 (02 Dec 2008)
+
+ 02 Dec 2008; Alfredo Tupone <tupone@gentoo.org> +spamdyke-4.0.9.ebuild:
+ Version bump to 4.0.9
*spamdyke-4.0.8 (17 Nov 2008)
diff --git a/mail-filter/spamdyke/spamdyke-4.0.9.ebuild b/mail-filter/spamdyke/spamdyke-4.0.9.ebuild
new file mode 100644
index 000000000000..48f3748c1fab
--- /dev/null
+++ b/mail-filter/spamdyke/spamdyke-4.0.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/spamdyke-4.0.9.ebuild,v 1.1 2008/12/02 10:03:46 tupone Exp $
+
+EAPI="1"
+
+DESCRIPTION="A drop-in connection-time spam filter for qmail"
+HOMEPAGE="http://www.spamdyke.org/"
+SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tls"
+
+DEPEND="tls? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo "# Configuration option for ${PN}" > ${PN}.conf
+ if use tls; then
+ echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
+ >> ${PN}.conf
+ fi
+ echo "graylist-level=always" >> ${PN}.conf
+ echo "graylist-dir=/var/tmp/${PN}/graylist" >> ${PN}.conf
+ echo "graylist-exception-rdns-dir=/etc/${PN}/never-graylist" >> ${PN}.conf
+ echo "reject-empty-rdns" >> ${PN}.conf
+ echo "reject-unresolvable-rdns" >> ${PN}.conf
+ sed -i \
+ -e "/STRIP_CMD/d" \
+ Makefile.in || die "sed on Makefile.in failed"
+}
+
+src_compile() {
+ econf --with-debug \
+ $(use_enable tls) || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ cd ../utils
+ econf || die "econf failed in utils"
+ emake CFLAGS="${CFLAGS}" || die "emake in utils died"
+}
+
+src_install() {
+ dobin ${PN} || die "Installing ${PN} binary failed"
+ insinto /etc/${PN}
+ doins ${PN}.conf || die "Installing ${PN} configuration file failed"
+ keepdir /var/tmp/${PN}/graylist/$(../utils/domain2path -d localhost)
+ fowners -R qmaild /var/tmp/${PN}
+ insinto /etc/${PN}/never-graylist/$(../utils/domain2path -d localhost)
+ touch localhost
+ doins localhost
+ cd ../utils
+ dobin domain2path || die "Installing domain2path binary failed"
+ cd ../documentation
+ dodoc {Changelog,INSTALL,UPGRADING}.txt
+ dohtml FAQ.html \
+ README.html \
+ README_ip_file_format.html \
+ README_rdns_directory_format.html \
+ README_rdns_file_format.html
+}
+
+pkg_postinst() {
+ elog "In /var/qmail/control/conf-smtpd insert the line:"
+ elog "QMAIL_SMTP_PRE=\"${QMAIL_SMTP_PRE} spamdyke -f /etc/${PN}/${PN}.conf\""
+ elog "Run spamdyke with the '-h' flag to see the available options and"
+ elog "update /etc/spamdyke.conf accordingly"
+}