summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-04-18 13:15:13 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-04-18 13:15:13 +0000
commit6f909ad49caf4ddbb304dd4b9bea21fe5c44e28d (patch)
treed6509208fe08ddd4f5a407ac1e6f29bf1c67097d /mail-client
parentmissed these files (diff)
downloadgentoo-2-6f909ad49caf4ddbb304dd4b9bea21fe5c44e28d.tar.gz
gentoo-2-6f909ad49caf4ddbb304dd4b9bea21fe5c44e28d.tar.bz2
gentoo-2-6f909ad49caf4ddbb304dd4b9bea21fe5c44e28d.zip
Version bump.
NEWS ~~~~ * thread mode: add "tags" pseudo header to message display * case insensitive matching in Addressbook completion * compose: interpret "attach" pseudo header * compose: set initial message tags * envelope: completion for 'From' * reply/forward: more flexible construction of "From" headers (hello plussing!) * thread mode: added bounce command for direct redirection w/o an envelope buffer * thread mode: more robust "pipeto" command * add config option "prefer_plaintext" * prevent multiple 'index locked' notifications * kill some zombies! (#325) * search mode: bulk tagging * less annoying multi-key bindings * add global "move" command for scriptable cursor movement * support for encrypted outgoing mails using PGP/MIME (Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/ChangeLog29
-rw-r--r--mail-client/alot/alot-0.3.4.ebuild90
2 files changed, 117 insertions, 2 deletions
diff --git a/mail-client/alot/ChangeLog b/mail-client/alot/ChangeLog
index bc919521e124..53d2ea26ebeb 100644
--- a/mail-client/alot/ChangeLog
+++ b/mail-client/alot/ChangeLog
@@ -1,7 +1,32 @@
# ChangeLog for mail-client/alot
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.15 2012/09/10 14:33:36 aidecoe Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.16 2013/04/18 13:15:13 aidecoe Exp $
+*alot-0.3.4 (18 Apr 2013)
+
+ 18 Apr 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> +alot-0.3.4.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+
+ * thread mode: add "tags" pseudo header to message display
+ * case insensitive matching in Addressbook completion
+ * compose: interpret "attach" pseudo header
+ * compose: set initial message tags
+ * envelope: completion for 'From'
+ * reply/forward: more flexible construction of "From" headers (hello
+ plussing!)
+ * thread mode: added bounce command for direct redirection w/o an envelope
+ buffer
+ * thread mode: more robust "pipeto" command
+ * add config option "prefer_plaintext"
+ * prevent multiple 'index locked' notifications
+ * kill some zombies! (#325)
+ * search mode: bulk tagging
+ * less annoying multi-key bindings
+ * add global "move" command for scriptable cursor movement
+ * support for encrypted outgoing mails using PGP/MIME
*alot-0.3.3 (10 Sep 2012)
diff --git a/mail-client/alot/alot-0.3.4.ebuild b/mail-client/alot/alot-0.3.4.ebuild
new file mode 100644
index 000000000000..82128c4c91be
--- /dev/null
+++ b/mail-client/alot/alot-0.3.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.3.4.ebuild,v 1.1 2013/04/18 13:15:13 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[456] 3.*"
+
+inherit distutils eutils vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ doc? ( dev-python/sphinx )
+ "
+RDEPEND="
+ >=dev-python/configobj-4.6.0
+ dev-python/pygpgme
+ >=dev-python/twisted-10.2.0
+ >=dev-python/urwid-1.1.0
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ sys-apps/file[python]
+ "
+
+ALOT_UPDATE=""
+
+pkg_setup() {
+ python_pkg_setup
+
+ if has_version "<${CATEGORY}/${PN}-0.3.2"; then
+ ALOT_UPDATE="yes"
+ fi
+}
+
+src_prepare() {
+ #epatch "${FILESDIR}/${PV}-subject-fix.patch"
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
+ -e '1i# -*- coding: utf-8 -*-' -i || die
+
+ distutils_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}"
+ done
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ pushd docs || die
+ emake html
+ popd || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /usr/share/alot
+ insinto /usr/share/alot
+ doins -r extra
+
+ if use doc; then
+ dohtml -r docs/build/html/*
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ALOT_UPDATE} = yes ]]; then
+ ewarn "The syntax of theme-files and custom tags-sections of the config"
+ ewarn "has been changed. You have to revise your config. There are"
+ ewarn "converter scripts in /usr/share/alot/extra to help you out with"
+ ewarn "this:"
+ ewarn ""
+ ewarn " * tagsections_convert.py for your ~/.config/alot/config"
+ ewarn " * theme_convert.py to update your custom theme files"
+ fi
+}