summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-06-13 02:26:39 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-06-13 02:26:39 +0000
commitdfedbe3a95d83e57ec51da9ce37e90e5f72bfa55 (patch)
treea4df4904a1710dcfcff78941b13c257d6f05208e /mail-client/thunderbird/files
parentVersion bump to fix bugs: 298919, 298916, 301582, 269498, 287092. Add Gentoo ... (diff)
downloadgentoo-2-dfedbe3a95d83e57ec51da9ce37e90e5f72bfa55.tar.gz
gentoo-2-dfedbe3a95d83e57ec51da9ce37e90e5f72bfa55.tar.bz2
gentoo-2-dfedbe3a95d83e57ec51da9ce37e90e5f72bfa55.zip
Add mail-client/thunderbird as part of pkgmove from mail-client/mozilla-thunderbird
(Portage version: 2.1.8.3/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'mail-client/thunderbird/files')
-rw-r--r--mail-client/thunderbird/files/1002_fix-system-hunspell-dict-detections.patch112
-rw-r--r--mail-client/thunderbird/files/icon/thunderbird-icon-unbranded.pngbin0 -> 13280 bytes
-rw-r--r--mail-client/thunderbird/files/icon/thunderbird-icon.pngbin0 -> 6499 bytes
-rw-r--r--mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop8
-rw-r--r--mail-client/thunderbird/files/icon/thunderbird.desktop8
-rw-r--r--mail-client/thunderbird/files/thunderbird-gentoo-default-prefs.js14
6 files changed, 142 insertions, 0 deletions
diff --git a/mail-client/thunderbird/files/1002_fix-system-hunspell-dict-detections.patch b/mail-client/thunderbird/files/1002_fix-system-hunspell-dict-detections.patch
new file mode 100644
index 000000000000..5a905aaf4ac0
--- /dev/null
+++ b/mail-client/thunderbird/files/1002_fix-system-hunspell-dict-detections.patch
@@ -0,0 +1,112 @@
+diff -r e06632956519 mozilla/extensions/spellcheck/Makefile.in
+--- a/mozilla/extensions/spellcheck/Makefile.in Sun Apr 04 07:02:14 2010 +0300
++++ b/mozilla/extensions/spellcheck/Makefile.in Tue Apr 06 23:07:03 2010 -0500
+@@ -42,13 +42,19 @@
+ include $(DEPTH)/config/autoconf.mk
+
+ MODULE = spellchecker
++ifndef MOZ_NATIVE_HUNSPELL
+ DIRS = idl locales
++else
++DIRS = idl
++endif
+
+ ifeq (camino,$(MOZ_BUILD_APP))
+ DIRS += osxspell
+ else
++ifndef MOZ_NATIVE_HUNSPELL
+ DIRS += hunspell
+ endif
++endif
+
+ DIRS += src
+
+diff -r e06632956519 mozilla/extensions/spellcheck/hunspell/src/mozHunspell.cpp
+--- a/mozilla/extensions/spellcheck/hunspell/src/mozHunspell.cpp Sun Apr 04 07:02:14 2010 +0300
++++ b/mozilla/extensions/spellcheck/hunspell/src/mozHunspell.cpp Tue Apr 06 23:07:03 2010 -0500
+@@ -63,6 +63,9 @@
+ #include "nsISimpleEnumerator.h"
+ #include "nsIDirectoryEnumerator.h"
+ #include "nsIFile.h"
++#ifdef MOZ_NATIVE_HUNSPELL
++#include "nsILocalFile.h"
++#endif
+ #include "nsDirectoryServiceUtils.h"
+ #include "nsDirectoryServiceDefs.h"
+ #include "mozISpellI18NManager.h"
+@@ -307,7 +310,16 @@
+ return;
+
+ nsCOMPtr<nsIFile> dictDir;
+- rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
++ #ifdef MOZ_NATIVE_HUNSPELL
++ nsCOMPtr<nsILocalFile> localFile;
++ rv = NS_NewNativeLocalFile(nsDependentCString("/usr/share/myspell"),PR_TRUE, getter_AddRefs(localFile));
++ if (localFile && NS_SUCCEEDED(rv)) {
++ localFile->QueryInterface(NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
++ LoadDictionariesFromDir(dictDir);
++ }
++ else {
++ #endif
++ rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
+ NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
+ if (NS_SUCCEEDED(rv)) {
+ LoadDictionariesFromDir(dictDir);
+@@ -332,6 +344,9 @@
+ LoadDictionariesFromDir(appDir);
+ }
+ }
++#ifdef MOZ_NATIVE_HUNSPELL
++ }
++#endif
+
+ nsCOMPtr<nsISimpleEnumerator> dictDirs;
+ rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY_LIST,
+diff -r e06632956519 mozilla/extensions/spellcheck/src/Makefile.in
+--- a/mozilla/extensions/spellcheck/src/Makefile.in Sun Apr 04 07:02:14 2010 +0300
++++ b/mozilla/extensions/spellcheck/src/Makefile.in Tue Apr 06 23:07:03 2010 -0500
+@@ -63,9 +63,15 @@
+ txtsvc \
+ uconv \
+ unicharutil \
++ xulapp \
+ $(NULL)
+
+-CPPSRCS = \
++ifdef MOZ_NATIVE_HUNSPELL
++CPPSRCS += mozHunspell.cpp \
++ mozHunspellDirProvider.cpp
++endif
++
++CPPSRCS += \
+ mozSpellCheckerFactory.cpp \
+ mozSpellChecker.cpp \
+ mozPersonalDictionary.cpp \
+@@ -80,8 +86,15 @@
+ SHARED_LIBRARY_LIBS += ../osxspell/src/$(LIB_PREFIX)osxspell_s.$(LIB_SUFFIX)
+ LOCAL_INCLUDES += -I$(srcdir)/../osxspell/src
+ else
++ifndef MOZ_NATIVE_HUNSPELL
+ SHARED_LIBRARY_LIBS += ../hunspell/src/$(LIB_PREFIX)hunspell_s.$(LIB_SUFFIX)
+ LOCAL_INCLUDES += -I$(srcdir)/../hunspell/src
++else
++LOCAL_INCLUDES += $(MOZ_HUNSPELL_CFLAGS) \
++ -I$(srcdir)/../hunspell/src \
++ -DMOZ_NATIVE_HUNSPELL \
++ $(NULL)
++endif
+ endif
+
+ EXTRA_DSO_LDOPTS = \
+@@ -96,3 +109,11 @@
+ LOCAL_INCLUDES += \
+ -I$(topsrcdir)/xpcom/io \
+ $(NULL)
++
++ifdef MOZ_NATIVE_HUNSPELL
++export:: $(srcdir)/../hunspell/src/mozHunspell.cpp $(srcdir)/../hunspell/src/mozHunspellDirProvider.cpp
++ $(INSTALL) $(srcdir)/../hunspell/src/mozHunspell.* $(srcdir)/../hunspell/src/mozHunspellDirProvider.* .
++GARBAGE += mozHunspell.$(OBJ_SUFFIX) mozHunspell.cpp mozHunspellDirProvider.$(OBJ_SUFFIX) mozHunspellDirProvider.cpp
++clean::
++ rm -f mozHunspell.* mozHunspellDirProvider.*
++endif
diff --git a/mail-client/thunderbird/files/icon/thunderbird-icon-unbranded.png b/mail-client/thunderbird/files/icon/thunderbird-icon-unbranded.png
new file mode 100644
index 000000000000..27265e08a7ca
--- /dev/null
+++ b/mail-client/thunderbird/files/icon/thunderbird-icon-unbranded.png
Binary files differ
diff --git a/mail-client/thunderbird/files/icon/thunderbird-icon.png b/mail-client/thunderbird/files/icon/thunderbird-icon.png
new file mode 100644
index 000000000000..90ff395ff5bc
--- /dev/null
+++ b/mail-client/thunderbird/files/icon/thunderbird-icon.png
Binary files differ
diff --git a/mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop b/mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop
new file mode 100644
index 000000000000..90c02da03d3a
--- /dev/null
+++ b/mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mozilla Thunderbird
+Comment=Mail & News Reader
+Exec=/usr/bin/thunderbird
+Icon=thunderbird-icon-unbranded
+Terminal=false
+Type=Application
+Categories=Office;Email;
diff --git a/mail-client/thunderbird/files/icon/thunderbird.desktop b/mail-client/thunderbird/files/icon/thunderbird.desktop
new file mode 100644
index 000000000000..b696085d49bd
--- /dev/null
+++ b/mail-client/thunderbird/files/icon/thunderbird.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mozilla Thunderbird
+Comment=Mail & News Reader
+Exec=/usr/bin/thunderbird
+Icon=thunderbird-icon
+Terminal=false
+Type=Application
+Categories=Office;Email;
diff --git a/mail-client/thunderbird/files/thunderbird-gentoo-default-prefs.js b/mail-client/thunderbird/files/thunderbird-gentoo-default-prefs.js
new file mode 100644
index 000000000000..38bb11c6ee3d
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-gentoo-default-prefs.js
@@ -0,0 +1,14 @@
+pref("app.update.enabled", false);
+pref("app.update.autoInstallEnabled", false);
+pref("browser.display.use_system_colors", true);
+pref("intl.locale.matchOS", true);
+pref("mail.shell.checkDefaultClient", false);
+
+# Disable global indexing by default
+pref("mailnews.database.global.indexer.enabled", false);
+
+# Do not switch to Smart Folders after upgrade to 3.0b4
+pref("mail.folder.views.version", "1");
+
+# Ensure we work with imap as expected
+pref("mail.server.default.use_condstore", false)