summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 12:53:11 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 12:53:11 +0000
commitd3ac3881762e3a9c889aacdaa90e173a7ba62b84 (patch)
tree5a3d45f850c9722c2819853bc853fda39b0b118c /mail-client/thunderbird/files
parentAdd patch for ARM OS detection, bug 327783 (diff)
downloadgentoo-2-d3ac3881762e3a9c889aacdaa90e173a7ba62b84.tar.gz
gentoo-2-d3ac3881762e3a9c889aacdaa90e173a7ba62b84.tar.bz2
gentoo-2-d3ac3881762e3a9c889aacdaa90e173a7ba62b84.zip
Add patch for ARM OS detection, bug 327783
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'mail-client/thunderbird/files')
-rw-r--r--mail-client/thunderbird/files/thunderbird-xul-1.9.2-arm-fixes.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail-client/thunderbird/files/thunderbird-xul-1.9.2-arm-fixes.patch b/mail-client/thunderbird/files/thunderbird-xul-1.9.2-arm-fixes.patch
new file mode 100644
index 000000000000..c7d7a65bf43d
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-xul-1.9.2-arm-fixes.patch
@@ -0,0 +1,35 @@
+Fix arm OS detection
+
+https://bugs.gentoo.org/327783
+https://bugzilla.mozilla.org/show_bug.cgi?id=577319
+---
+--- configure.in
++++ configure.in
+@@ -1424,9 +1424,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
+--- mozilla/js/src/configure.in
++++ mozilla/js/src/configure.in
+@@ -1162,9 +1162,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac