summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2014-04-04 09:30:12 +0000
committerAkinori Hattori <hattya@gentoo.org>2014-04-04 09:30:12 +0000
commit5cd1f9c86611daf4b5794fe1fb0040a684dd5521 (patch)
tree974ad7cfca489be6bb32c0c48c1ca4d813200cc1 /mail-client/sylpheed
parentAdd RESTRICT=splitdebug addition to ChangeLog. (diff)
downloadgentoo-2-5cd1f9c86611daf4b5794fe1fb0040a684dd5521.tar.gz
gentoo-2-5cd1f9c86611daf4b5794fe1fb0040a684dd5521.tar.bz2
gentoo-2-5cd1f9c86611daf4b5794fe1fb0040a684dd5521.zip
new upstream release, fixes bug #506670
(Portage version: 2.2.8-r1/cvs/Linux i686, signed Manifest commit with key EC917A6D)
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 6e887ad3edb0..413e377f5634 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.333 2014/04/02 15:04:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.334 2014/04/04 09:30:12 hattya Exp $
+
+*sylpheed-3.4.0 (04 Apr 2014)
+
+ 04 Apr 2014; Akinori Hattori <hattya@gentoo.org> +sylpheed-3.4.0.ebuild:
+ new upstream release, fixes bug #506670
02 Apr 2014; Jeroen Roovers <jer@gentoo.org> sylpheed-3.3.0-r1.ebuild:
Stable for HPPA (bug #502822).
diff --git a/mail-client/sylpheed/sylpheed-3.4.0.ebuild b/mail-client/sylpheed/sylpheed-3.4.0.ebuild
new file mode 100644
index 000000000000..2b0b0ec4eb3b
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.4.0.ebuild,v 1.1 2014/04/04 09:30:12 hattya Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://${PN}.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* PLUGIN* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+
+ cd plugin/attachment_tool
+ docinto plugin/attachment_tool
+ emake DESTDIR="${D}" install-plugin
+ dodoc README
+}