summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-06-25 02:54:14 +0000
committerMarius Mauch <genone@gentoo.org>2006-06-25 02:54:14 +0000
commit955697bc490cbeb2ad1c48c4ce5d2e9ed7c78244 (patch)
treed45e37240b58640e6fc6bba94a2269d6dfcad3f5 /mail-client/sylpheed-claws-acpi-notifier
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-955697bc490cbeb2ad1c48c4ce5d2e9ed7c78244.tar.gz
gentoo-2-955697bc490cbeb2ad1c48c4ce5d2e9ed7c78244.tar.bz2
gentoo-2-955697bc490cbeb2ad1c48c4ce5d2e9ed7c78244.zip
Version bump, removing default postinst message as it's not really correct anymore as the plugin now also supports userspace tools.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'mail-client/sylpheed-claws-acpi-notifier')
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/ChangeLog9
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.23
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.2.ebuild44
3 files changed, 55 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws-acpi-notifier/ChangeLog b/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
index a838e6ac42a6..50100ac4f103 100644
--- a/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
+++ b/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/sylpheed-claws-acpi-notifier
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/ChangeLog,v 1.2 2006/02/10 18:09:25 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/ChangeLog,v 1.3 2006/06/25 02:54:14 genone Exp $
+
+*sylpheed-claws-acpi-notifier-1.0.2 (25 Jun 2006)
+
+ 25 Jun 2006; Marius Mauch <genone@gentoo.org>
+ +sylpheed-claws-acpi-notifier-1.0.2.ebuild:
+ Version bump, removing default postinst message as it's not really correct
+ anymore as the plugin now also supports userspace tools.
*sylpheed-claws-acpi-notifier-0.8 (10 Feb 2006)
diff --git a/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.2 b/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.2
new file mode 100644
index 000000000000..60b313a1234c
--- /dev/null
+++ b/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.2
@@ -0,0 +1,3 @@
+MD5 06b53d69913ea1c96fb154fa2686606a sylpheed-claws-extra-plugins-2.3.0.tar.bz2 3901667
+RMD160 64f026271d993de2c5895c251abf18c529b0244d sylpheed-claws-extra-plugins-2.3.0.tar.bz2 3901667
+SHA256 45e30623f3908577518a474a2f308453654d1f6422a2f15ff27ec4fb934aa438 sylpheed-claws-extra-plugins-2.3.0.tar.bz2 3901667
diff --git a/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.2.ebuild b/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.2.ebuild
new file mode 100644
index 000000000000..c39320ab8568
--- /dev/null
+++ b/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.2.ebuild,v 1.1 2006/06/25 02:54:14 genone Exp $
+
+inherit eutils
+
+MY_PN="${PN#sylpheed-claws-}"
+MY_PN="${MY_PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+SC_BASE="2.3.0"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="This plugin enables mail notification via LEDs on some laptops."
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_P}"
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f ${D}usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ PROC_IFACES="$(echo /proc/acpi/{asus/mled,ibm/led,acer/mailled}) /proc/driver/acerhk/led"
+
+ local procfile
+ local message_shown=false
+
+ for procfile in ${PROC_IFACES}; do
+ if [[ -f ${procfile} ]]; then
+ einfo "Make sure ${procfile} is writable by users of this plugin."
+ message_shown=true
+ fi
+ done
+}