summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2006-04-30 03:15:40 +0000
committerJory Pratt <anarchy@gentoo.org>2006-04-30 03:15:40 +0000
commit0ddb40ca43ec0014034d5d7d5ad3b92800e74032 (patch)
tree309c6f07980d1838d09bfffe4a72c6174418d0a9 /mail-client/mozilla-thunderbird
parenttextrel fix introduced (diff)
downloadgentoo-2-0ddb40ca43ec0014034d5d7d5ad3b92800e74032.tar.gz
gentoo-2-0ddb40ca43ec0014034d5d7d5ad3b92800e74032.tar.bz2
gentoo-2-0ddb40ca43ec0014034d5d7d5ad3b92800e74032.zip
textrels fix introduced
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'mail-client/mozilla-thunderbird')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog8
-rw-r--r--mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.5.0.2-r16
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.2-r1.ebuild187
3 files changed, 200 insertions, 1 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index ec3c0c693c6e..d40a2a8f1133 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.110 2006/04/29 11:35:15 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.111 2006/04/30 03:15:40 anarchy Exp $
+
+*mozilla-thunderbird-1.5.0.2-r1 (30 Apr 2006)
+
+ 30 Apr 2006; Jory A. Pratt <anarchy@gentoo.org>
+ +mozilla-thunderbird-1.5.0.2-r1.ebuild:
+ textrels fix introduced
29 Apr 2006; Jory A. Pratt <anarchy@gentoo.org>
mozilla-thunderbird-1.5.0.2.ebuild:
diff --git a/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.5.0.2-r1 b/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.5.0.2-r1
new file mode 100644
index 000000000000..c668e0b98d71
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.5.0.2-r1
@@ -0,0 +1,6 @@
+MD5 0647e319855808f50c5cb30a499ce48f mozilla-thunderbird-1.5.0.2-patches-1.3.tar.bz2 31424
+RMD160 a3e22fd8de4688e7e3ed513c86f6317cab9308b5 mozilla-thunderbird-1.5.0.2-patches-1.3.tar.bz2 31424
+SHA256 25a6d47859303fd2c1e49d6d81bb1b6c3c729e37bde43d4f277ef75902dbaa17 mozilla-thunderbird-1.5.0.2-patches-1.3.tar.bz2 31424
+MD5 3f32b847330c9d58297147be19714962 thunderbird-1.5.0.2-source.tar.bz2 35880369
+RMD160 8aaf02c205b131a38fa0384fe6126eec325c3e9e thunderbird-1.5.0.2-source.tar.bz2 35880369
+SHA256 d01a4edef782ea0d86e7ed5899ffdd48998211d5e134e3e93b1a0f9e56198151 thunderbird-1.5.0.2-source.tar.bz2 35880369
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.2-r1.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.2-r1.ebuild
new file mode 100644
index 000000000000..8a0761c20ea9
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.2-r1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.2-r1.ebuild,v 1.1 2006/04/30 03:15:40 anarchy Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib autotools
+
+PVER="1.3"
+
+DESCRIPTION="Thunderbird Mail Client"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird/"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2
+ mirror://gentoo/${P}-patches-${PVER}.tar.bz2
+ http://dev.gentoo.org/~anarchy/dist/${P}-patches-${PVER}.tar.bz2"
+
+KEYWORDS="amd64 ~ia64 ppc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE="ldap crypt"
+
+RDEPEND=">=www-client/mozilla-launcher-1.39
+ >=dev-libs/nss-3.10
+ >=dev-libs/nspr-4.6.1"
+
+PDEPEND="crypt? ( x11-plugins/enigmail ) "
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ declare x
+
+ for x in ${A}; do
+ [[ $x == *.tar.* ]] || continue
+ unpack $x || die "unpack failed"
+ done
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_FORCE="yes" epatch ${WORKDIR}/patch
+
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, it detects a ppc64 system.
+ # -- hansmi, 2005-11-13
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
+
+ WANT_AUTOCONF="2.13" \
+ WANT_AUTOMAKE="2.13" \
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ # tb-specific settings
+ mozconfig_use_enable ldap
+ mozconfig_use_enable ldap ldap-experimental
+ mozconfig_annotate '' --enable-extensions=default
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+ mozconfig_annotate '' --with-user-appdir=.thunderbird
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --enable-official-branding
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, which breaks us
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+ append-flags -freorder-blocks -fno-reorder-functions
+
+ # Export CPU_ARCH_TEST as it is not exported by default.
+ case $(tc-arch) in
+ amd64) [[ ${ABI} == "x86" ]] && CPU_ARCH_TEST="x86" || CPU_ARCH_TEST="x86_64" ;;
+ ia64) CPU_ARCH_TEST="ia64" ;;
+ ppc) CPU_ARCH_TEST="ppc" ;;
+ *) CPU_ARCH_TEST=$(tc-arch) ;;
+ esac
+
+ export CPU_ARCH_TEST
+
+ CPPFLAGS="${CPPFLAGS}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake || die
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ echo ""
+ einfo "We are removing old install before we continue. This is to help"
+ einfo "eliminate any problems during the install, sorry for those of you"
+ einfo "who disagree with this but this will ensure a sane build for everyone"
+ einfo "Comments and suggestion should be addressed to mozilla@gentoo.org"
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Most of the installation happens here
+ dodir ${MOZILLA_FIVE_HOME}
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}${MOZILLA_FIVE_HOME}
+
+ # Create directory structure to support portage-installed extensions.
+ # See update_chrome() in mozilla-launcher
+ keepdir ${MOZILLA_FIVE_HOME}/chrome.d
+ keepdir ${MOZILLA_FIVE_HOME}/extensions.d
+ cp ${D}${MOZILLA_FIVE_HOME}/chrome/installed-chrome.txt \
+ ${D}${MOZILLA_FIVE_HOME}/chrome.d/0_base-chrome.txt
+
+ # Create /usr/bin/thunderbird
+ install_mozilla_launcher_stub thunderbird ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/thunderbird-icon.png
+
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird.desktop
+
+ ####################################
+ #
+ # Install files necessary for applications to build against firefox
+ #
+ ####################################
+
+ ewarn "Installing includes and idl files..."
+ dodir ${MOZILLA_FIVE_HOME}/idl ${MOZILLA_FIVE_HOME}/include
+ cd ${S}/dist
+ cp -LfR include/* ${D}${MOZILLA_FIVE_HOME}/include || die "failed to copy"
+ cp -LfR idl/* ${D}${MOZILLA_FIVE_HOME}/idl || die "failed to copy"
+
+ # Dirty hack to get some applications using this header running
+ dosym ${MOZILLA_FIVE_HOME}/include/necko/nsIURI.h \
+ /usr/$(get_libdir)/${MOZILLA_FIVE_HOME##*/}/include/nsIURI.h
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ update_mozilla_launcher_symlinks
+}