summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-04-04 17:35:41 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-04-04 17:35:41 +0000
commit86579751fbac6281180482f623ce9cbda6ebfb48 (patch)
tree940f1561aba64081e7474f5e0e220041e039ce5b /mail-client/mozilla-thunderbird-bin
parentAdd ~arm/~s390/~sh (diff)
downloadgentoo-2-86579751fbac6281180482f623ce9cbda6ebfb48.tar.gz
gentoo-2-86579751fbac6281180482f623ce9cbda6ebfb48.tar.bz2
gentoo-2-86579751fbac6281180482f623ce9cbda6ebfb48.zip
whitespace, remove old
(Portage version: 2.1.6.7/cvs/Linux ia64)
Diffstat (limited to 'mail-client/mozilla-thunderbird-bin')
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta1.ebuild173
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild4
2 files changed, 2 insertions, 175 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta1.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta1.ebuild
deleted file mode 100644
index f681780041c3..000000000000
--- a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta1.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta1.ebuild,v 1.1 2008/12/12 10:48:01 armin76 Exp $
-
-inherit eutils mozilla-launcher multilib mozextension
-
-LANGS="af ar be cs de en-GB en-US es-AR es-ES et eu fr fy-NL ga-IE hu id it ja ka ko lt nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru si sk sq sv-SE uk zh-CN zh-TW"
-NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
-
-MY_PV="${PV/_beta/b}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Thunderbird Mail Client"
-SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${MY_PV}/linux-i686/en-US/thunderbird-${MY_PV}.tar.bz2"
-HOMEPAGE="http://www.mozilla.com/thunderbird"
-RESTRICT="strip"
-
-KEYWORDS="-* ~amd64 ~x86"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE=""
-
-for X in ${LANGS} ; do
- if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( http://dev.gentooexperimental.org/~armin76/dist/${MY_P/-bin}-xpi/${MY_P/-bin/}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # english is handled internally
- if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
- if [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${MY_P/-bin}-xpi/${MY_P/-bin/}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
-DEPEND="app-arch/unzip"
-RDEPEND="x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXmu
- x86? (
- >=x11-libs/gtk+-2.2
- )
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-1.0
- >=app-emulation/emul-linux-x86-gtklibs-1.0
- app-emulation/emul-linux-x86-compat
- )"
-
-S="${WORKDIR}/thunderbird"
-
-pkg_setup() {
- # This is a binary x86 package => ABI=x86
- # Please keep this in future versions
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- has_multilib_profile && ABI="x86"
-}
-
-linguas() {
- local LANG SLANG
- for LANG in ${LINGUAS}; do
- if has ${LANG} en en_US; then
- has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
- continue
- elif has ${LANG} ${LANGS//-/_}; then
- has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
- continue
- elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
- for X in ${LANGS}; do
- if [[ "${X}" == "${LANG}-"* ]] && \
- [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
- has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
- done
-}
-
-src_unpack() {
- unpack ${A}
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != en ]] && xpi_unpack ${MY_P/-bin}-${X}.xpi
- done
- if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
- einfo "Selected language packs (first will be default): ${linguas}"
- fi
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME="/opt/thunderbird"
-
- # Install thunderbird in /opt
- dodir ${MOZILLA_FIVE_HOME%/*}
- mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != en ]] && xpi_install ${WORKDIR}/${MY_P/-bin}-${X}
- done
-
- local LANG=${linguas%% *}
- if [[ ${LANG} != "" && ${LANG} != "en" ]]; then
- ebegin "Setting default locale to ${LANG}"
- sed -i "s:pref(\"general.useragent.locale\", \"en-US\"):pref(\"general.useragent.locale\", \"${LANG}\"):" \
- "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-thunderbird.js \
- "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-l10n.js
- eend $? || die "sed failed to change locale"
- fi
-
- # Install /usr/bin/thunderbird-bin
- make_wrapper thunderbird-bin "${MOZILLA_FIVE_HOME}/thunderbird"
-
- # Install icon and .desktop for menu entry
- doicon "${FILESDIR}"/icon/${PN}-icon.png
- domenu "${FILESDIR}"/icon/${PN}.desktop
-
- # revdep-rebuild entry
- insinto /etc/revdep-rebuild
- doins "${FILESDIR}"/10thunderbird-bin
-
- # install ldpath env.d
- doenvd "${FILESDIR}"/71thunderbird-bin
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME="/opt/thunderbird"
-
- # Remove entire installed instance to solve various
- # problems, for example see bug 27719
- rm -rf "${ROOT}"${MOZILLA_FIVE_HOME}
-}
-
-pkg_postinst() {
- #elog "For enigmail, please see instructions at"
- #elog " http://enigmail.mozdev.org/"
-
- ewarn "Enigmail or probably any other extension won't work"
- ewarn "with Thunderbird 3.0."
-
- if use x86; then
- if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
- || ! has_version 'net-misc/curl'; then
- einfo
- einfo "For using the crashreporter, you need gnome-base/gconf,"
- einfo "gnome-base/orbit and net-misc/curl emerged."
- einfo
- fi
- if has_version 'net-misc/curl' && built_with_use --missing \
- true 'net-misc/curl' nss; then
- einfo
- einfo "Crashreporter won't be able to send reports"
- einfo "if you have curl emerged with the nss USE-flag"
- einfo
- fi
- else
- einfo
- einfo "NB: You just installed a 32-bit thunderbird"
- einfo
- einfo "Crashreporter won't work on amd64"
- einfo
- fi
- update_mozilla_launcher_symlinks
-}
-
-pkg_postrm() {
- update_mozilla_launcher_symlinks
-}
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild
index d4f7da8d9727..68f015b3eb29 100644
--- a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild,v 1.1 2009/03/12 18:25:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta2.ebuild,v 1.2 2009/04/04 17:35:41 armin76 Exp $
inherit eutils mozilla-launcher multilib mozextension
@@ -162,7 +162,7 @@ pkg_postinst() {
einfo
einfo "NB: You just installed a 32-bit thunderbird"
einfo
- einfo "Crashreporter won't work on amd64"
+ einfo "Crashreporter won't work on amd64"
einfo
fi
update_mozilla_launcher_symlinks