summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-09 15:37:54 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-09 15:37:54 +0000
commit4bb940c2f71868964b4ba1122e8588d5cc3d49c8 (patch)
tree5e6affcd6a980bb5ac0be35ae50fa25ebe0873c5 /mail-client/evolution
parentadd missing newline at end of file (Manifest recommit) (diff)
downloadgentoo-2-4bb940c2f71868964b4ba1122e8588d5cc3d49c8.tar.gz
gentoo-2-4bb940c2f71868964b4ba1122e8588d5cc3d49c8.tar.bz2
gentoo-2-4bb940c2f71868964b4ba1122e8588d5cc3d49c8.zip
Fix use invocation
Diffstat (limited to 'mail-client/evolution')
-rw-r--r--mail-client/evolution/ChangeLog6
-rw-r--r--mail-client/evolution/evolution-1.2.4.ebuild20
-rw-r--r--mail-client/evolution/evolution-1.4.5.ebuild6
-rw-r--r--mail-client/evolution/evolution-1.4.6.ebuild8
4 files changed, 22 insertions, 18 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index 64e1809a893f..e6248ee24f17 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/evolution
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.3 2004/06/01 21:57:46 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.4 2004/06/09 15:36:40 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> evolution-1.2.4.ebuild,
+ evolution-1.4.5.ebuild, evolution-1.4.6.ebuild:
+ Fix use invocation
01 Jun 2004; Travis Tilley <lv@gentoo.org> evolution-1.4.6.ebuild:
stable on amd64
diff --git a/mail-client/evolution/evolution-1.2.4.ebuild b/mail-client/evolution/evolution-1.2.4.ebuild
index a6defdfbc55b..c2502599eff4 100644
--- a/mail-client/evolution/evolution-1.2.4.ebuild
+++ b/mail-client/evolution/evolution-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.2.4.ebuild,v 1.1 2004/05/30 02:43:48 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.2.4.ebuild,v 1.2 2004/06/09 15:36:40 agriffis Exp $
IUSE="ssl nls mozilla ldap doc spell pda ipv6 kerberos kde crypt"
@@ -125,26 +125,26 @@ src_compile() {
local myconf=""
local MOZILLA="${MOZILLA_FIVE_HOME}"
- if [ -n "`use pda`" ] ; then
+ if use pda ; then
myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
else
myconf="${myconf} --enable-pilot-conduits=no"
fi
- if [ -n "`use ldap`" ] ; then
+ if use ldap ; then
myconf="${myconf} --with-openldap=yes --with-static-ldap=no"
else
myconf="${myconf} --with-openldap=no"
fi
- if [ -n "`use kerberos`" ]; then
+ if use kerberos; then
myconf="${myconf} --with-krb5=/usr --with-krb4=/usr"
else
myconf="${myconf} --with-krb5=no --with-krb4=no"
fi
# Use Mozilla NSS libs if 'mozilla' *and* 'ssl' in USE
- if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ if use ssl && use mozilla; then
myconf="${myconf} --enable-nss=yes \
--with-nspr-includes=${MOZILLA}/include/nspr \
--with-nspr-libs=${MOZILLA} \
@@ -156,23 +156,23 @@ src_compile() {
fi
# Else use OpenSSL if 'mozilla' not in USE ...
- if [ -n "`use ssl`" -a -z "`use mozilla`" ] ; then
+ if use ssl && ! use mozilla; then
myconf="${myconf} --enable-openssl=yes"
fi
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
myconf="${myconf} --enable-gtk-doc"
else
myconf="${myconf} --disable-gtk-doc"
fi
- if [ -n "`use ipv6`" ] ; then
+ if use ipv6 ; then
myconf="${myconf} --enable-ipv6=yes"
else
myconf="${myconf} --enable-ipv6=no"
fi
- if [ -z "`use nls`" ] ; then
+ if ! use nls ; then
myconf="${myconf} --disable-nls"
fi
@@ -217,7 +217,7 @@ src_install() {
install || die
# remove kde link if USE="-kde"
- if [ -z "`use kde`" ]; then
+ if ! use kde; then
rm -rf ${D}/usr/share/applnk
fi
diff --git a/mail-client/evolution/evolution-1.4.5.ebuild b/mail-client/evolution/evolution-1.4.5.ebuild
index 128568a6d3a2..01f512b9b6b0 100644
--- a/mail-client/evolution/evolution-1.4.5.ebuild
+++ b/mail-client/evolution/evolution-1.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.4.5.ebuild,v 1.2 2004/05/30 11:01:31 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.4.5.ebuild,v 1.3 2004/06/09 15:36:40 agriffis Exp $
# kde before gnome2, otherwise kde_src_install will override gnome2_src_install
use kde && inherit kde
@@ -148,7 +148,7 @@ src_compile() {
&& myconf="${myconf} --with-kde-applnk-path=${KDEDIR}/share/applnk"
# Use Mozilla NSS/NSPR libs if 'mozilla' *and* 'ssl' in USE
- if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ if use ssl && use mozilla; then
if has_version "dev-libs/nspr"; then
NSS_LIB=/usr/lib
NSS_INC=/usr/include
@@ -171,7 +171,7 @@ src_compile() {
fi
# Else use OpenSSL if 'mozilla' not in USE ...
- if [ -n "`use ssl`" -a -z "`use mozilla`" ] ; then
+ if use ssl && ! use mozilla; then
myconf="${myconf} --enable-openssl=yes"
fi
diff --git a/mail-client/evolution/evolution-1.4.6.ebuild b/mail-client/evolution/evolution-1.4.6.ebuild
index e7d29f691975..26cef303fee8 100644
--- a/mail-client/evolution/evolution-1.4.6.ebuild
+++ b/mail-client/evolution/evolution-1.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.4.6.ebuild,v 1.4 2004/06/01 21:57:46 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.4.6.ebuild,v 1.5 2004/06/09 15:36:40 agriffis Exp $
# kde before gnome2, otherwise kde_src_install will override gnome2_src_install
use kde && inherit kde
@@ -126,7 +126,7 @@ src_compile() {
&& myconf="${myconf} --with-openldap=yes --with-static-ldap=no" \
|| myconf="${myconf} --with-openldap=no"
- [ `use kerberos` -a ! `use amd64` ] \
+ ( use kerberos && ! use amd64 ) \
&& myconf="${myconf} --with-krb5=/usr" \
|| myconf="${myconf} --without-krb5"
@@ -142,7 +142,7 @@ src_compile() {
&& myconf="${myconf} --with-kde-applnk-path=${KDEDIR}/share/applnk"
# Use Mozilla NSS/NSPR libs if 'mozilla' *and* 'ssl' in USE
- if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ if use ssl && use mozilla; then
if has_version "dev-libs/nspr"; then
NSS_LIB=/usr/lib
NSS_INC=/usr/include
@@ -165,7 +165,7 @@ src_compile() {
fi
# Else use OpenSSL if 'mozilla' not in USE ...
- if [ -n "`use ssl`" -a -z "`use mozilla`" ] ; then
+ if use ssl && ! use mozilla; then
myconf="${myconf} --enable-openssl=yes"
fi